Skin help -1 reply

  • 1
  • 2

Please wait...

Sidias

Be Polite, Be Efficient

50 XP

15th August 2009

0 Uploads

10 Posts

0 Threads

#1 8 years ago

I'm working on my own personal skin, and, since for some reason or another modview doesn't work, I have to check the skin out in game. So I load up MP, start a solo match, and I try to pick my model as the model i reskinned. Only problem is, is that its not there! The only thing I can think of of why its not showing up at all is that I compressed the folder as a .zip, then changed the extension to a .pk3.

I kept the folder hierarchy exactly the same as the original mod (Hap's Anakin), so everything should've worked. The only difference is that I changed some of the skins.

if it helps I'm using Windows 7.




Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#2 8 years ago

Check your console for errors/warnings. Make sure all image dimensions are to the power of 2 (16, 32, 64, 128, 256, 512, 1024) Does ModView give you an error? Try using the /model command to change your model instead of selecting it through the menu.




ChalklYne

Boats n Hoes XDDD

50 XP

20th September 2009

0 Uploads

406 Posts

0 Threads

#3 8 years ago

post the pk3 here lemme give her a looksie.. did u change the skin file to be your custom skin? like.. did u edit model_default.skin? and what do u mean by "its not there"? when u load up the model does it have its default skin? a grey (shader problem) skin? birthday suit? XD id say either post it, or start from scratch at compiling and make sure like razor said, power of 2, and checkthe console warnings when u load yer model... but no converting it to .zip, then .pk3 wont matter..

EDIT: razor your avatar scares the hell outta me XD seriously




Sidias

Be Polite, Be Efficient

50 XP

15th August 2009

0 Uploads

10 Posts

0 Threads

#4 8 years ago
-Raz0r-;5207909Check your console for errors/warnings.

Checked my console, and it apparently found the pk3 file. Still no sign of it actually there though...

Make sure all image dimensions are to the power of 2 (16, 32, 64, 128, 256, 512, 1024)

Check. All the dimensions are the same as they were originally, and they were to the power of 2.

Does ModView give you an error?

No, oddly. When I started it up, it gave me a (mostly) blank white screen. When I tried to load the model, it gave me a usual "Shader files are not found!" error, (which I've gotten at least 1000 times before while looking at models) and in the lower left hand corner, it just said "Registering shader: models/player/hs_anakin/hips.tga" and doesn't go farther than that. Task Manager says that its not responding, and then I end the program. I even re-downloaded the bugger. The new download doesn't work either. :\

Try using the /model command to change your model instead of selecting it through the menu.

Just tried it, gave me Kyle for some reason.

EDIT:

post the pk3 here lemme give her a looksie.. did u change the skin file to be your custom skin? like.. did u edit model_default.skin? and what do u mean by "its not there"? when u load up the model does it have its default skin? a grey (shader problem) skin? birthday suit? XD id say either post it, or start from scratch at compiling and make sure like razor said, power of 2, and checkthe console warnings when u load yer model... but no converting it to .zip, then .pk3 wont matter..

No, all I did was edit the skin in Photoshop, and saved it with the original file name and standard compression. No .skin editing.

And since you asked for it... here. Note that my skin is still a WIP, and I'm still sort of working on it...




ChalklYne

Boats n Hoes XDDD

50 XP

20th September 2009

0 Uploads

406 Posts

0 Threads

#5 8 years ago

ok.. so.. i see a couple of problems, first, no folder..just the directories right in the root of the pk3... so in the pk3, there shouldnt be a folder named hs_anakinxxx or whatever.. just botfiles, models, shaders, etc.. with me so far? and now the only other problem is u made a different .skin file for each of the body parts.. u can look at the structure of the other anakins there in that pk3 to kinda get the jisst of the way u should set up a skin file.. not a seperate one for each body part.. now, i would fix this, but one, i dont know which parts you wanna use and where, and second, its just better u learn it... so first fix the folders to be in the root of the pk3, then u can move on to fixing up your skins.. and if u extract all the files in this pk3 (after u fix the directory structure) into your c:/gamedata/base folder, modview will work for u.. i just did it.. after that, id say just look at the other .skins in the other models, to see what your going for.. if your just reskinning it though, u shouldve just edited the uvmaps in photoshop, and copy and pasted a .skin file,changed the names of the .jpg's it has in it to the ones u edited, then renamed it to whatever u want yer skin to be called.. with me?




The One and Only

I R Scary Eyeball

50 XP

29th January 2004

0 Uploads

4,091 Posts

0 Threads

#6 8 years ago

You didn't put spaces in any of the folder names or anything?




Sidias

Be Polite, Be Efficient

50 XP

15th August 2009

0 Uploads

10 Posts

0 Threads

#7 8 years ago
The One and Only;5208230You didn't put spaces in any of the folder names or anything?

Nope.

I tried using chalk's suggestions. All the lines in the .skin file are correct, I got rid of all the excess files which were from the original mod, and I know how to use modview. Its not a problem with my skin, its a problem with my end. But the thread isn't about how I should fix modview, its how I should fix my skin so that it shows up in game. I re-packed the pk3 with nothing but the bare essentials, and still nothing happened. I even went a step further and checked my shader files.




eezstreet

Lord of the .DCC files

50 XP

16th June 2008

0 Uploads

2,662 Posts

0 Threads

#8 8 years ago
Sidias;5207925No, all I did was edit the skin in Photoshop, and saved it with the original file name and standard compression. No .skin editing.

Make sure you save it as baseline, not progressive.




Sidias

Be Polite, Be Efficient

50 XP

15th August 2009

0 Uploads

10 Posts

0 Threads

#9 8 years ago
eezstreet;5208314Make sure you save it as baseline, not progressive.

I made sure. I even saved it again as baseline, to be safe. Still no beans.

And yes, I'm making sure that I'm repacking the files.




Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#10 8 years ago

The reason it's not working is because your heirarchy is wrong. You have everything starting in the HS_anakin folder inside the PK3 (JK3 will have no flippin' clue what that is or that it should even look inside it). Get rid of it.

Also, don't overwrite the original model if you intend to release it. That's kind of obnoxious. And you only need to put in the PK3 what you've made for your mod.




  • 1
  • 2