Strange texture behavior... -1 reply

Please wait...

Innocent Hawk

Not so innocent?

50 XP

18th July 2005

0 Uploads

207 Posts

0 Threads

#1 11 years ago

Well I've been working on a map for a very long time, and now that I have my new computer I want to be able to finally finish it, but I'm having a little trouble.

Certain textures which I wrote custom shaders for no longer seem to show up in-game. All these textures have a shader from the same shader file, and all of them are made to be shiny. Instead of seeing the regular texture with the shader blended over it, all I see is the shader and grey underneath. Not the black box with white border as you would see if there was a texture missing. Just shiny grey. EDIT: Nevermind. I took a closer look, and it would seem my new computer is just rendering the shaders a little differently than my old computer. I'll just rework the shaders a little bit.

Another problem I have is that a certain statue model that I placed in the map no longer seems to have any textures. I had a 100% fresh install when I popped in the last compile of my map that completely worked on my last computer, but on my new computer the model shows up but with a missing texture. I am pretty certain the model is in base JA because otherwise the model would not have shown up at all, but it is odd that the texture would be missing. The only thing I can think of is that my old computer used GTK Radiant 1.3.12, which included a bunch of models including that statue, and my new computer uses GTK 1.4 which also included the same models, but perhaps it has a missing/screwed up texture or shader.

I dunno. Any thoughts or suggestions?




lassev

Degenerate scripter

50 XP

21st June 2004

0 Uploads

847 Posts

0 Threads

#2 11 years ago

JA contains a bunch of models with no textures shipped. Many of those are legacy JO models Raven ported over yet didn't use and dropped the textures. Possibly to save file space, or something. There might also be other models with no textures.

Your options are to check whether it's a JO model, in which case it's easy enough to fetch the texture from over there (assuming you own JO), but if it's not, then you could always get the texture name from inside the md3 and create / alter / summon a texture of that name. Or get it from the old Gtk installation, if you are desperate enough and it indeed was from there.

Naturally you can also check the shader situation once you know the texture name.




Innocent Hawk

Not so innocent?

50 XP

18th July 2005

0 Uploads

207 Posts

0 Threads

#3 11 years ago

Well, I transfered over the .md3 and .ase from my old comp and replaced the ones on my new comp with them, and that did not work. I searched all through my base folder and found no other trace of the model and skin (which leaves me baffled as to why it ever worked).

I think my only option at this point is to get it from JO. I don't really feel like installing it on my new comp, and I uninstalled it on my old comp ages ago. I can install it if I need to, but I would prefer if someone around here could extract it and put it in a .zip for me. Anyone willing to do that? The statue I need is that guy in a robe holding that staff/pointy stick thing. I believe the Valley of the Jedi place in the JO cut scene had them in it.




lassev

Degenerate scripter

50 XP

21st June 2004

0 Uploads

847 Posts

0 Threads

#4 11 years ago

You don't need to install it. Just search the cd. The pk3s are on the cd (in some subfolder) just like they would be on your hd after installation. Take them directly from the pk3 on the cd or copy the pk3 onto your hd temporarily. Then just use winzip (or whatever) to get the file(s) you need from inside it.

Edit: I should leave saying this to Kouen, the EULA fanboy, but telling you don't "feel like installing it" and asking somebody else to send them over sounds like you don't even own (a legal copy of) the game, and thus make such a request. Now, I'm sure you do, but that's what it sounds like.




Innocent Hawk

Not so innocent?

50 XP

18th July 2005

0 Uploads

207 Posts

0 Threads

#5 11 years ago

:Puzzled: I do own a copy of it. MW was founded by my real life friends, and it started in JK2, so it would have been impossible for me to be in the clan without it lol. If you don't believe me there are about a dozen people that could attest to this, as well as a dozens of screenshots, a clan history database, and even a personal skin that I made for myself... but anyway, I didn't know that I could grab the files by just accessing the disk. That's awesome! Now I can have complete access to all the models. =p The model has texture now, thanks for you help! Now to fix those shaders...