View distance question -1 reply

Please wait...

DuketheLuke

You are reading this.

50 XP

15th February 2009

0 Uploads

309 Posts

0 Threads

#1 9 years ago

Okay, I've have my map, it's a space map, but every time I try to make it, I get the MAX_VISIBILITY_EXCEEDED error when using VIS mapping, or something of the sort, but when I make it a smaller skybox around the map, it's fine and compiles fine. But I've seen other maps like The Battle over Coruscant that has a HUGE space zone, I can barely go anywhere in my map because of the skybox needing to be so small, can someone please help?




eezstreet

Lord of the .DCC files

50 XP

16th June 2008

0 Uploads

2,662 Posts

0 Threads

#2 9 years ago

Turn on distance culling




jk3editor

Retard Hungarian Modder

50 XP

21st August 2008

0 Uploads

1,520 Posts

0 Threads

#3 9 years ago

[COLOR=Navy]I'm sure that won't fix this problem, that's just for the editor. Btw DuketheLuke, all the outside brushes of the map must be structural, and the map mustn't be leaked. Check it. [/COLOR]




AshuraDX

WTF ?! BOOOOOOOM !

50 XP

10th May 2009

0 Uploads

1,462 Posts

0 Threads

#4 9 years ago
jk3editor;5219230[COLOR=Navy]I'm sure that won't fix this problem, that's just for the editor. Btw DuketheLuke, all the outside brushes of the map must be structural, and the map mustn't be leaked. Check it. [/COLOR]

actually Distance cullnig works ingame too it's a key for the worldspawn entity if I remember correctly :)




jk3editor

Retard Hungarian Modder

50 XP

21st August 2008

0 Uploads

1,520 Posts

0 Threads

#5 9 years ago

[COLOR=Navy]Ohh, sry I composited it bad. I want say, that basically the distance culling isn't 'turned off', so you can't 'turn it on'. If you don't set it, it's 8000, or I don't know how many. But it has default value. And I've tried it a time ago in my map, that I set it to really big, but that didn't fix the problem. I had to make all the outside brushes to Structural :) [/COLOR]




MaceCrusherMadunusus

Movie Battles II Mapper

50 XP

12th January 2005

0 Uploads

323 Posts

0 Threads

#6 9 years ago

Distancecull isn't the fix here. Max visibility almost simply means you've gone over the maximum portal count that the map can have. I do not remember the exact number anymore, since its been a long time since I have hit it, but its somewhere between 3,000 - roughly 4,000 portals.

First way to go about fixing, is to be sure you have proper detailing in the map while still being sure you aren't compromising VIS structurally.

The second way, is through the _blocksize key. The game has a default automatic portal size of 1024x1024x1024. That of course, is alright for most small maps. However, on big space maps with a lot of pointless open space it is just creating portals for no reason. Depending on the size of your map, use key: _blocksize with a value of 2048, 4096 or 8192 in the worldspawn depending on your mapsize. Some people will say bring it down to 0, but in this case here you do not want the blocksize as 0.

Theres more methods for sure, but try those out for now.




NAB622

EAT ME!

50 XP

8th October 2005

0 Uploads

6,921 Posts

0 Threads

#7 9 years ago

DuketheLuke;5219160it's a space map[/QUOTE]

[QUOTE=MaceCrusherMadunusus;5220175]_blocksize

'Nuff said.