Weighting => Bugz ? -1 reply

Please wait...

Salek

I don't spend enough time here

50 XP

30th October 2007

0 Uploads

28 Posts

0 Threads

#1 9 years ago

Hey !

Okay, I'm trying to make my model, I made it successfully and I weighted it without problems. I have my textures, my model.glm, my .skin, all is okay but when I look ingame, I've a Kyle. If I look in the Profil (with Ja+) I see this : failzpx9.png

When I look in ModView, there are a lot of bugs :

bug1ok3.png

When I look at the bone "Lower_Lumbar" he is on the head...

bug2yu9.png

The same for rfemurYZ

bug3nq5.png

And when I launch the animation TALKCOMM1 I've this :

bug4ps9.png

I don't know what's the problem, I tried to weight the model 3 times, always the same bug. Have someone any idea ?

PS : Sorry about my language. I'm not english and I know it sucks :P




LightNinja

Ninjonator

50 XP

22nd March 2003

0 Uploads

922 Posts

0 Threads

#2 9 years ago

what skeleton are you using?




=Someone=

MovieBattles II Modeler

50 XP

15th January 2008

0 Uploads

160 Posts

0 Threads

#3 9 years ago

When you export your model, make sure you have "re-orient scene" checked and those deformations will be gone.




Salek

I don't spend enough time here

50 XP

30th October 2007

0 Uploads

28 Posts

0 Threads

#4 9 years ago

Lightninja => I am using the JK3 Skeleton, this one : JK3_Skeleton.max Download File on FileFront

Someone => The re-orient scene is checked. I re exported it and it's the same problem.




Jose Carlos

Why? Cause normal is boring.

50 XP

28th March 2006

0 Uploads

2,118 Posts

0 Threads

#5 9 years ago

Select all parts of the model, go to the utilities tab, hit 'Reset Xform'. Now go over each and every part of the model, do a 'collapse all' and reweigh it.




Salek

I don't spend enough time here

50 XP

30th October 2007

0 Uploads

28 Posts

0 Threads

#6 9 years ago

I've already do this... But I will try, thanks. But it's maybe a skeletton problem, he doesn't fit the model correctly maybe and I've read this in the Psykopat's tutorial :

-Make sure you build or fit your mesh around this skeleton or you will have animation problems.

Here is some screenshots in 3dsmax :

max1zk3.pngmax2ye9.pngmax3vo4.png




minilogoguy18

kitty dances for rep!

50 XP

4th September 2004

0 Uploads

2,675 Posts

0 Threads

#7 9 years ago

yeah your transforms are all jacked. you said you did the reset xform already? what you should try is doing the reset xform and turn on backface culling so that you cannot see backsides of polygons and flip any of them that may get flipped and do another reset xform, collapse the modifier stack and reweigh.




Salek

I don't spend enough time here

50 XP

30th October 2007

0 Uploads

28 Posts

0 Threads

#8 9 years ago
turn on backface culling

Erm, I'm sorry but... How turn on backface culling? :confused:

Edit : I select a part of the model, I do right click, I select Properties and I turn on/off Backface Cull, that's right?




Salek

I don't spend enough time here

50 XP

30th October 2007

0 Uploads

28 Posts

0 Threads

#9 9 years ago

(Sorry for the double post)

Okay, I have selected every parts, do a Reset XForm, do Collapse All and reweight all. Doesn't work, the same problem, no change.

Minilogoguy, my model is always set on backface cull on and I don't understand what do you say when you say Ā«flip any of them that may get flippedĀ». How flip any of them ? :P




Inyri Forge VIP Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#10 9 years ago

Did you make sure to unlink the meshes before you reset the transforms?