autoexec isn't working -1 reply

Please wait...

FireDragon100

The Internet ends at GF

50 XP

27th August 2008

0 Uploads

123 Posts

0 Threads

#1 10 years ago

Hi!

My command-lines in my auto-exec are NOT working! Every time I restart the game, the commands go back to the original default-settings! :(

That's my autoexec:

seta HelpUsObi "1" seta g_saberrealsticcombat "5" seta g_dismembermentprobabilities "100" seta g_dismember "100" seta g_knockback "3000"

I even made a "default.cfg" in my base-folder and put all the commands in there. But they're still not working! They go always back to the standard-values :(

I also tried to write it all into the jaconfig.cfg but they're still not working :bawl:

When I write them while I'm already playing in SP-Mode, they work fine! But why is my autoexec not working? Why do I have to write the commands again and again when I restart the game?

I know from Counter Strike, that there was something like "exec autoexec.cfg" you had to write in your normal "config.cfg".... Is there something similar in Jedi Academy?

The console of the game shows no problems... it says:

execing autoexec.cfg.... "" config.cg.... "" default.cfg.... "" setlanguage.cfg.....

BUT at the bottom it says:

couldn't write jaconfig.cfg....




N-7

... and a nice big Cip-Quad

50 XP

21st September 2007

0 Uploads

579 Posts

0 Threads

#2 10 years ago

Well, you'd better make jaconfig.cfg writable then (check its read-only flag, if that's not it try running the game as administrator or - if you don't want that - grant yourself write access to the base folder plus the files therein).

EDIT: That's not it. autoexec.cfg works for me even if jaconfig.cfg isn't writable. Have you checked that it's really not working (enter helpusobi at the console and see if its 1 or 0).

BTW, which operating system do you run. And is your game patched or not (because, you know, it could be that with the patch, g_saberrealisticcombat has been replaced with g_sabermorerealistic or something, but I'm not sure). And it's called g_dismemberProbabilities rather than g_dismembermentprobabilities as far as i know (that is, without the patch).




FireDragon100

The Internet ends at GF

50 XP

27th August 2008

0 Uploads

123 Posts

0 Threads

#3 10 years ago

I have Windows Vista Home Premium.

HelpUsObi is set to 1... g_saberrealsticcombat is set to 2 g_knockback is set to 1000

hmm okay the other 2 commands are on 100

all files in the folder are writeable now

...

so i still have probs with g_saberrealsticcombat and g_knockback




NAB622

EAT ME!

50 XP

8th October 2005

0 Uploads

6,921 Posts

0 Threads

#4 10 years ago

Nah, I don't think that's the problem.

When jampconfig.cfg gets larger than 14 KB, you lose all your settings. The problem is that this file goes over that size whenever you load a map in JA+ (including solo mode), so this is probably your problem.

I got around this by saving my settings to a cfg file from the main menu, and saving it under a different name. I start JA using a batch file that replaces jampconfig.cfg with my saved one, then JA loads normally.

This also means I can mess up my binds however I like and it will reset when I'm done. Very handy!




FireDragon100

The Internet ends at GF

50 XP

27th August 2008

0 Uploads

123 Posts

0 Threads

#5 10 years ago

How can I save a new cfg from main menu?

first i write all the commands i wanna have in that config and THEN i save, right?

mmh but i don't play JA+ in solo-mode... i play the normal game... without any mod or custom-map... i just want to use the commands in singleplayer, not in multiplayer... so does your "method" also works with jaconfig, ov_nab622???

how can i do this "batch-file"? O.o it sounds very helpful, i think that could be the solution for my problem




NAB622

EAT ME!

50 XP

8th October 2005

0 Uploads

6,921 Posts

0 Threads

#6 10 years ago

I don't know if vista will let you use batch files or not.

If you know anything about old DOS commands or how to use CMD.exe, you'll be able to do it fine. Here's my batch file, for reference:

Spoiler: Show

Copy "C:\Games\SW JK JA\GameData\NABsaves\jampconfig.cfg" "C:\Games\SW JK JA\Gamedata\japlus"

REM "JAM's Jedi Knight KT v2.0" REM start jamKt.exe REM cd ..

start jamp.exe +set fs_game japlus +exec (whatever you want here)

The part with the REM you can leave out. That was what I used to start JAM's KT....years ago.




Merios

Dont cross the streams.//

50 XP

19th August 2008

0 Uploads

78 Posts

0 Threads

#7 10 years ago

I don't know if it's been said, but here goes:

g_saberrealsticcombat will not work unless you want to go through and make almost every character file writable as well as most of the cfgs.

Helpful Alternatives/Links

Also, if you downloaded the patch, there should be an option called "Dismemberment" in the Setup area somwhere (in the main menu). Toggle that to on. Also, you can set the difficulty to Jedi Master to get 1-hit kills with dismemberment if you set the option.




FireDragon100

The Internet ends at GF

50 XP

27th August 2008

0 Uploads

123 Posts

0 Threads

#8 10 years ago

Hmm okay I created a batch-file :rolleyes:

I can start the game with the batch-file and in main-menu the command-lines have the values i wanted :rolleyes:

BUT there's another problem... when I load any saved game or a "new" map (with devmap.... or map... or from the load-menu) I can't change my saber anymore o_O i have these binds:

seta bind R "saber sniper"

seta bind T "sabercolor 1 red; saber sniper_bh; sabercolor 1 red"

and they worked perfectly. The bind on T is for the backhand-saber:

Backhand Lightsabers, Jedi Knight 3 Downloads, Jedi Knight 3 Mini-Mods

I had no problems with these binds, BEFORE I created the batch-file... The commands also don't work, if they write them when I'm in the game o_O Normally the saber must change from backhand to forehand when I wrote an old savegame where I had a backhand-saber and write "saber sniper" or "saber kyle" or "saber desann".... but it doesn't change oO And when I load a saved game where I had a forehand saber, I can't change to backhand with "saber sniper_bh" o_O But it worked BEFORE the batch-file o_O There is no warning, no error... just nothing! Any effect! Nothing happens when I write the console-commands o_O:uhm:




NAB622

EAT ME!

50 XP

8th October 2005

0 Uploads

6,921 Posts

0 Threads

#9 10 years ago
FireDragon100;4548170 seta bind R "saber sniper"

How about just "Bind" ?

"Seta" means you're setting a CVar, but bind is for key commands. I think you're confusing the game.

bind R "saber sniper" Should work fine.




FireDragon100

The Internet ends at GF

50 XP

27th August 2008

0 Uploads

123 Posts

0 Threads

#10 10 years ago

hmm okay thanks to everybody!

I tried everything you said... some things were useful... but no solution was perfect.. i think's it's impossible to play the game like i want it to play...

after reinstalling the game, I made a new config with every command i want to have... then i binded the config to a key on my keyboard... and now I always have to press the key, when i load a map and everthing works fine :)

I wrote bind R "saber sniper" in my config.cfg and not in my own "new" config.

thanks to everyone! :) :):):):)