Hosting a server and ip problems... -1 reply

Please wait...

xkon

I'm too cool to Post

50 XP

16th April 2004

0 Uploads

3 Posts

0 Threads

#1 17 years ago

After a full day of trying to figure out why i cant host a server, i think i may have found out why, but do not know how to fix it. The ip address of my computer is 192.168.2.212 for sure, i have set it myself because i have a belkin router. I have opened the port 29070 and made sure im using that port in the dedicated server (also have congfigured my ip in the server...using /net_ip and /net_port ). However, my friend, who found my ip from logging on to his forums, told me my IP was 66.186.92.3, and another site that tells you your ip also says that. So, my question is, if i cant change my computers IP because my router would then not work, and i do not know what the 66.186.92.3 ip is from... (btw i use efni DSL), is there anyway to get around this, or does anybody know what i must do to fix this problem? Thnx in advance Update: I opened the port 29071 with UDP instead of TCP on my router, and then changed the port used in the dedicated server to 29071, and now my server shows up on the master list but it tries to connect to 66.186.92.3:29070 i like how its showing up, but its not connecting to the right thing.




{UPS}BobaFett

I don't spend enough time here

50 XP

1st February 2004

0 Uploads

18 Posts

0 Threads

#2 17 years ago

Try adding server to your favorites section under your [color=blue]local[/color] IP 192.168.2.212:port Not your [color=blue]net[/color] IP 66.186.92.3:port And make sure your router is set to forward the port traffic to the computer running the server.




xkon

I'm too cool to Post

50 XP

16th April 2004

0 Uploads

3 Posts

0 Threads

#3 17 years ago

yeah, when i add 192.168.2.212:'port' to my favs, it shows up...but for me only (im assuming cause im on the network, because my other comp can see it), but anyone i give my ip to (192.168.2.212) cannot see it. dunno if this helps but...here are settings on router... Cable/DSL : CONNECTED WAN IP: 66.186.92.3 Gateway IP: 66.186.92.1 DNS: 209.91.128.11 Secondary DNS: 204.187.88.10 and for telling the router to forward info to my comp, i cant find any place to put that kind of information.




{UPS}BobaFett

I don't spend enough time here

50 XP

1st February 2004

0 Uploads

18 Posts

0 Threads

#4 17 years ago

Because you are giving them your [color=blue]local [/color]IP. No-one can logon from the net with your [color=blue]local[/color] IP.




xkon

I'm too cool to Post

50 XP

16th April 2004

0 Uploads

3 Posts

0 Threads

#5 17 years ago

so give them 66.186.92.3?...cause i tried that...so unless my friends dont know what they are doing, they couldn't see me w/ that one




Fire-Storm

Mapper & Clan Leader of JKNR

50 XP

11th October 2003

0 Uploads

74 Posts

0 Threads

#6 17 years ago

Ok I am prety sure you have the same prob as me. First yes you give them your net IP but the port will not be 29070 and it will generate a new port every time you start the server so the way to get the IP will be to go into the ingame internet game browser and sort them by ping and set it so the lowest ping is at the top. Once you have done that then your server should be the top server because your server will have a ping of 1 when looking for it one the same computer as it is hosted on. Then once you have your server hit the about and right down the port that is there and tell them it (ie 66.186.92.3:-****) for me every time it is a negitive port but it may be different for you. Please remember that the port will change every time you start the server.




Guest

I didn't make it!

0 XP

 
#7 16 years ago

your problem is: u need a static IP address! u also need a non-wireless connetion to your modem!




Scriptersx

I'm too cool to Post

50 XP

13th July 2004

0 Uploads

2 Posts

0 Threads

#8 16 years ago

Check if your router has port forwarding/Virtual server. When some one trys to join the server on your IP they just hit the router as the router is occuping that address, but Port Forwarding/Virtual Server can forward certain ports to your computer. I have also had the same problem if you would like more help you can pm me




tcharp

I don't spend enough time here

50 XP

13th July 2004

0 Uploads

15 Posts

0 Threads

#9 16 years ago
xkon The ip address of my computer is 192.168.2.212 for sure, i have set it myself because i have a belkin router. However, my friend, who found my ip from logging on to his forums, told me my IP was 66.186.92.3, and another site that tells you your ip also says that.

The IP you are setting is only for your local network. It has nothing to do with you actual internet IP which is assigned by your ISP and cannot be changed, except by them. For other computers to connect to you, you will have to use the IP assigned by your ISP. -TC