Inyri's hoverboard -1 reply

Please wait...

P@radox

IT'S A TRAP

50 XP

5th October 2009

0 Uploads

18 Posts

0 Threads

#1 11 years ago

Hello, I have a problem using Inyri's hoverboard which is a great model mod btw. My problem with it though is my character still sits on it like a swoop instead of standing on it. Could you or someone else here I suppose tell me the reasoning for this and how to fix it?

I was looking around your site but found no way for personal communication so I decided to throw it up here ;)

EDIT: this is all on devmap btw and just letting you know after three hoverboard spawns jka crashes D:

bluesigcopy.png




Inyri Forge Advanced Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#2 11 years ago

Try reading the read-me file.




P@radox

IT'S A TRAP

50 XP

5th October 2009

0 Uploads

18 Posts

0 Threads

#3 11 years ago
Read MePlease note that the extra skins and SP swoop replacement will *not* function with hoverboard_if.pk3.

I did read it to begin with, but upon a second go through I found this

This is the only thing in the read me that makes any sense about this. If that's the problem let me know. I do have both the .pk3's in. The boards there, you just kinda sit in midair on it

EDIT: I tried removing the extras and I still sit rather than stand




Inyri Forge Advanced Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#4 11 years ago

That was a typo, which I really should correct at some point. But really, I thought I made it pretty clear.




P@radox

IT'S A TRAP

50 XP

5th October 2009

0 Uploads

18 Posts

0 Threads

#5 11 years ago

so that means what? that it doesn't actually work in mp? I'm attempting again without anything in my base thinking maybe I picked up a custom animation somewhere without my noticing

EDIT: ok so yeah it must have been an animation somewhere that I would have no idea where to find it any idea on the crashing issue though? The error message is

Error: BG_GetVehicleModelName:couldn't find vehicle hoverboard_if3

I can accept it if it's just something with the mod, just wondering if you were aware




Averus_Retruthan

...Or has it just begun?

50 XP

19th September 2006

0 Uploads

473 Posts

0 Threads

#6 11 years ago

Alright, since Inyri is offering such excellent customer support on her own mod, I suppose I'll step in ¬_¬

Now, to understand what's going on, one would need more information usually. However, for the record, I'm going to assume you are using JAplus for these trial demonstrations. While Inyri's info *WAS* vague, there was a key element listed within:

I've had to completely overwrite the swoop rider animations. This is one reason I've included a swoop overwrite. Not only is it cool, but it's really handy if you have the other swoops installed (spawn the MP swoop with this mod installed and you'll see why). Also, because this mod edits animations.cfg, this means any other animation mods may cause conflicts (included serverside mods with their own CFG files - editing may need to be done for compatibility).

So, to recap, as you yourself probably found out, this WILL WORK IN SP AND MP,but if you're using JA+ or any other mod that overwrites the default animation.cfg's, you're SOL, I'm afraid, unless you plan to modify said .cfgs to support this mod. Will anyone on this site do it for you? Probably not, since their noses are buried elsewhere.

This is about all the advice I can offer given the amount of information given. If you are trying this mod out on base JA and are still having problems, then let me know.

Now, onto the "crashing" issue. I tested this mod on an empty base to try and recreate the problem. From what I've found, this issue is indeed universal, but god knows what's causing it. I looked into the .veh file to see if there were any paranormal additions. The only clue I found was in the MP console:

Spoiler: Show
Hovboarderror.jpg

This led me to try a couple things in game, to see if this problem could be bypassed. Unfortunately, I could not find a solution. Granted, this issue does not crop up EVERY TIME on my machine. I can spawn it maybe 4-6 times each session before it crashes, so if you're lucky, you can too and just be careful with what you do with it XD otherwise, just steer clear of that board.

Just holler if there are any new developments.




Inyri Forge Advanced Member

[Insert User Title Here]

55 XP

15th March 2005

0 Uploads

25,940 Posts

0 Threads

#7 11 years ago
P@radox;5226429EDIT: ok so yeah it must have been an animation somewhere that I would have no idea where to find it any idea on the crashing issue though? The error message is

That is a problem with the engine, as far as I'm aware. As for the other problem, like I said, read the read-me and attempt to comprehend. Luckily for you Averus spelled it out for you. I wrote it so I wouldn't have to constantly explain why there are animations bugs.




Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#8 11 years ago

Okay, digging into that BG_ error..

There are a few ways it can be caused (After a 3 minute search): 1) Malformed .veh file (missing parameters, unexpected braces, unexpected EOF etc) 2) Loading a vehicle with no name (Console should warn you if this is the case) 3) Too many vehicles (Console should warn you if this is the case)

So it's most likely the first cause. Check thoroughly.




P@radox

IT'S A TRAP

50 XP

5th October 2009

0 Uploads

18 Posts

0 Threads

#9 11 years ago

I have ja+ installed but always start up with base. This is why I didn't really think too much about ja+ being the issue because as I said I wasn't running in ja+

well in any case it works when I take things out of my base (which only contains a few skins/models and about 5 maps) thank you for all of your help, and Inyri I'm sorry I apparently was unable to comprehend all parts of your read me but like I said it's all working (minus the crash which I will just ignore seeing how I don't really need more than one hoverboard, I only spawned more to see the variants)

so thanks for the help guys I really appreciate it