Jedi Academy... on Vista...? -1 reply

  • 1
  • 2

Please wait...

Getherer

I'm too cool to Post

50 XP

27th February 2007

0 Uploads

14 Posts

0 Threads

#1 10 years ago

Well hi i have got weird problems with my Jedi Academy...

Well I installed it and run SP- it worked normally with no problems, but when i launched Multiplayer and tried to login to the server- it crashed. Right, no prob, I changed compability and selected run as admin option in properties and it actually worked. But when i log in to the server or even select solo game it... LAGS as hell!!! I have like slide show, very low rate of fps.

I have got Vista Home Premmium 2GB RAM DDR2 GF 7600GS 512MB 320GB HDD Internet 2MB/s

WTF? Why does it lag like that? Im telling you its like slide show, like trying to play Most Wanted full details on GFMX440 64MB!!

Really bad, i need help with that... desperately!!:bawl:




Guest

I didn't make it!

0 XP

 
#2 10 years ago

I have an idea. You will need to reinstall the game for this. When you want to install the game again , close that splash screen (JA launcher , you know what I mean) , go to My Computer , right click on your CD (DVD) drive icon , select "Open" , go to "GameData" folder , right click on "Setup.exe" file , go to "Compatibility" tab and set compatibility with Win 98 or XP. Since I don`t have Vista , this procedure may be slightly different on your computer , but you get the general idea. Click "OK" then doubleclick that "Setup.exe" file. When the installation completes , restart OS. Then go to your LucasArts / JA folder and set the same compatibility on all .exe files you find. That should solve your problem , but don`t be surprised if it doesn`t. Vista is still quite buggy and game unfriendly , so there may be no solution for your problem at all. Try my suggestion and inform me about a resoult. I hope I helped you. Bye. :cya:




Getherer

I'm too cool to Post

50 XP

27th February 2007

0 Uploads

14 Posts

0 Threads

#3 10 years ago

Ehh... Well No, it didnt work.

it was actually even worse- when i tried to launch the game it only came up to Star Wars: Jedi Knight: Jedi Academy screen and freeze... it crash and i am forced to use task manager to close JA.

And yes i know vista is not compatible with games at all, but as far as i know most of the people which have vista can play normally and actually they have most likely same version of vista as i do... i have updated all drivers to graphics card and stuff which did not helped either, also i tried to install directx 8.0 , directx 9.0c and directx 10 which i actually use and it still not helped. I think the only way to play it is reinstall system to XP... but to do that i must first wait till my dad send me my XP >.> ...

So, still no other ideas? You think its just vista and it cant be helped?




ikyojo

AKA Daxs

50 XP

26th July 2007

0 Uploads

411 Posts

0 Threads

#4 10 years ago

Make sure all exe are set to run as admin and update jka to the latest and also try this copying the main pk3s off the cd or dvd to the base again and also in your base click show compattabilty files and delete all your jmpconfig.cfg and try once more that what got mine working




Tsubasa

Blarg!

50 XP

15th December 2006

0 Uploads

21 Posts

0 Threads

#5 10 years ago

You need a GeForce 8 card to run DirectX 10. <.




Guest

I didn't make it!

0 XP

 
#6 10 years ago

I apologize for causing you more problems with my bad suggestion. I hope you are not angry at me. I have more suggestions , if you are willing to try them. You said that you updated graphic card drivers , right? If you just installed them over the existing ones , try completely removing them and then install them again using "New Hardware Wizard". If you don`t know how to do all that , ask me and I will explain it to you in details. This is quite of a longshot , so it probably won`t do any good , but try it anyway. Just make sure that you have correct drivers for your graphic card`s generation and your OS (Vista). Did you disabled all Vista`s "eyecandies"? I heard that theese are quite of a resource consumers. Disableing them might improve framerate in your games. You may also try formatting the hard drive and reinstalling Vista itself. But leave that as the last resort. Have you consider conctating Microsoft helpdesk? Maybe they can help you. Finally , if nothing else works , go back to XP. Or wait for Vista to get that first service pack. Who knows , maybe it will solve Vista`s compatibility issues with old(er) games. Well , I hope I helped you this time. Please , inform me about a resoult. Bye.




Getherer

I'm too cool to Post

50 XP

27th February 2007

0 Uploads

14 Posts

0 Threads

#7 10 years ago

Yes yes I tried all... i have latest drivers and updated jka... still the same.

But what are those candies? never heard of them can you explain me how to switch them off and what it gonna give me?

Anyway I know that i shouldnt trying but just just to XP but for that i must wait some few weeks more.. so.. you have time you can still try to help :P




Guest

I didn't make it!

0 XP

 
#8 10 years ago

Thoose "eyecandies" , as I call them , are Vista`s visual improvements , like 3D windows. Since I don`t have Vista I don`t know much about that. You should ask someone who has some expiriance with Vista about that (Microsoft helpdesk , maybe?). All I know is that thoose "eyecandies" require significant amount of computer resources (CPU , RAM , VRAM) to run properly. And what do you have from them? Nothing! Disableing them will take the load off your system and improve framerate in your games. Like I said , I don`t have Vista , so I don`t know how to disable them. Explore entire Control Panel. I`m sure you will find something useful there.




Getherer

I'm too cool to Post

50 XP

27th February 2007

0 Uploads

14 Posts

0 Threads

#9 10 years ago

oh, right! I see... but you know, the first thing i did onmy computer with vista was switching off those animations and windows and stuff ;] those things are for kids who like fancy colors... anyway... any other ideas? anyway i think i will get xp quite soon so...i could probably wait but if he solve the problem it could help in future other people...




Guest

I didn't make it!

0 XP

 
#10 10 years ago

Sorry man , but I`m in a clue free zone over here. In other words , I don`t know what else to suggest you. There`s probably nothing that you or anyone else can do. Vista simply has compatibilty issues with old(er) games. Like I said , that first service pack will probably solve this , but don`t count on it. I`m really sorry that I couldn`t help you. If I discover something new , I will let you know. Until then , bye.




  • 1
  • 2