JKA and Windows 7 (64 bit) -1 reply

Please wait...

Atra

«CoF» Rogue High Council

50 XP

7th January 2008

0 Uploads

16 Posts

0 Threads

#1 8 years ago

Okay peeps, I hope someone will be able to help cuz I'm growing desperate here.

I'm running windows 7 (64 bit) and thus have my compatibility mode set to XP SP3 for Xfire, jamp.exe, jasp.exe and Ultra Utility (I believe most of you will know what that is). I also have the "Run as Administrator" thing checked, plus I granted full security permissions (read, write, etc.) to the program's folders. I also have the JA+ mod 2.2 installed.

Now starting JKA from UltraUtility is no problem. Starting it with jamp.exe or play_japlus works fine too. However, when I try to launch the game via Xfire it crashes and gives me the "JKA has stopped working" crap.

I'm out of ideas, so I hope for your input =)

Thanks in Advance




Illrian Damaris

Dark Lord of the Sith

50 XP

30th September 2010

0 Uploads

336 Posts

0 Threads

#2 8 years ago

[COLOR="DeepSkyBlue"]Are your security settings for both Xfire and JKA the exact same? Because if just one small piece is different, then they won't work with each other at all. So you have to have all the security features and that good crap set the same way. [/COLOR]




Caelum

Spoons & llamas guy

50 XP

24th October 2008

0 Uploads

501 Posts

0 Threads

#3 8 years ago
I also have the "Run as Administrator" thing checked

On both jamp.exe and xfire?

Tried without compatibility mode?




jk3editor

Retard Hungarian Modder

50 XP

21st August 2008

0 Uploads

1,520 Posts

0 Threads

#4 8 years ago

You must check the 'disable desktop composition' and the 'disable themes' or whatever too, I don't know, I have Hungarian version...but something like that :)




Atra

«CoF» Rogue High Council

50 XP

7th January 2008

0 Uploads

16 Posts

0 Threads

#5 8 years ago
[COLOR=DeepSkyBlue]Are your security settings for both Xfire and JKA the exact same?

[/COLOR]Yup they are

On both jamp.exe and xfire? Tried without compatibility mode?

Yup tried that, no go.

You must check the 'disable desktop composition' and the 'disable themes'

The game automatically disables the themes when it's started




{RRS}RL

I don't spend enough time here

50 XP

7th February 2004

0 Uploads

24 Posts

0 Threads

#6 8 years ago

What graphics card and driver do you have? Radeon cards with newer drivers (newer than 10.4) causes jka to crash unless you put a .dll called atioglxx.dll into GameData.

Other than that, I have win7x64 myself and it works fine, I never needed to mess with compability modes.




Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#7 8 years ago

But the issue is only for launching through Xfire, so it doesn't sound like a graphics driver problem.




UU_BobaFett

JKG Lead coder

50 XP

18th July 2006

0 Uploads

202 Posts

0 Threads

#8 8 years ago

I'm assuming here that you've installed Jedi Academy in Program Files or another restricted directory, if not, disregard my post.

If that is the case, the reason JA will not run when launched from xfire is because xfire doesnt have admin rights by default, and launching JA from xfire means that JA wont have them either.

For JA to run, it needs to extract and load its dll's at startup. In the event of JA being inside a restricted directory (like program files), extraction will fail as writing to files is not allowed there unless the program runs with admin rights.

The easiest way to fix this without ever needing admin rights again, is to override the security restrictions on the GameData directory (and all directories within) to allow full access to all files for all users. To do that, do the following:

1. Go to the JA directory, which would normally be 'C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData'.

2. Right-click and go to properties.

3. Inside the properties window, go to the security tab.

4. Click on the Edit button, which should bring up a new window (maybe after a lil security warning)

5. In that new window, choose 'Users' from the top list and tick Full Control in the Allow column in the bottom list.

6. Click OK to apply the settings, which may take a second.

7. Close the properties window 'n all that.

You should now be able to play Jedi Academy without needing admin rights, and it should work properly when launched from xfire 'n whatnot.

PS. Once ya did this, disable compatibility mode for JA.