NPC Related Error -1 reply

Please wait...

megaman295

What?

50 XP

29th April 2008

0 Uploads

262 Posts

0 Threads

#1 10 years ago

I get an NPC related message while playing SP. When I am playing the "Mercenary Activity" mission at the beginning, whenever I go into a room that should have a trandoshan, it say "ERROR: Couldn't spawn NPC Trandoshan." When I get to the part where Jaden says "We need more cover," after I kill all the other NPCs, the cutscene that should take place doesn't, and the enemies don't come out of the door. HELP!!!




Guest

I didn't make it!

0 XP

 
#2 10 years ago

First , it`s not very nice to post your problem in someone else`s thread , especially if it`s an old thread like this one. Now for your problem. Did you read everything in posts above and tryed that? Apparently , you have too many NPC files in your "Base" folder. Clear out all .pk3 files you added yourself , if you added any. That should solve the problem. If those .pk3 files are skins and you feel like fiddleing with them , you can remove NPC files from them and still keep your skins. I`m not sure about models. I think that models can`t work without NPC files.




Mikouen VIP Member

What?

145,650 XP

4th September 2005

4 Uploads

11,732 Posts

2 Threads

#3 10 years ago

The game loads models the same way it loads skins, essentially. Just that there's more files involved. .npc files aren't necessary for a skin or model to function.

It's either one of two issues: too many .npc files installed, or the .npc file in the base assets for the Trandoshan has been compromised (either by corruption or human interference).

Try using Pakscape to remove the .npc files from any third-party downloads, and if that doesn't work, try copying the assets1.pk3 file from the CD and pasting it over the one in your base folder.


I don't know how, and I don't know why, but this is totally Sheep's fault.



megaman295

What?

50 XP

29th April 2008

0 Uploads

262 Posts

0 Threads

#4 10 years ago
Jedi_Sabrina;4344546First , it`s not very nice to post your problem in someone else`s thread , especially if it`s an old thread like this one.

Sorry. I'm kinda new, and I didn't see how old it was.

Thanks Kouen. I deleted the NPCs, and it worked! Thank you so much!