Server doesnt appear in list -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 13 years ago

I created a server (as said in http://www.chopshopservers.com/education/homeserver.htm) I asked 2 friends to join. They were able to conenct over my IP but they told me the server doesnt appear in the game browsers list (neither in the All seeing eye) :confused:




IrishDragon

Living deity

50 XP

22nd July 2005

0 Uploads

178 Posts

0 Threads

#2 13 years ago

Hmm...they can connect to a server that does not appear on the master list...interesting..

By connect you mean they were able to join your server correct?

Usually the biggest issue people have with PC hosted servers is bypassing the router. *Opening the correct ports allowing information for the game to be seen outside the home network and access from outside the home network*

Other than that...make sure this is at the top of your server.cfg *as quoted from Amidala*

seta sv_master1 "masterjk3.ravensoft.com" seta sv_master2 "master.qtracker.com" seta sv_master3 "clanservers.net" seta sv_master4 "master0.gamespy.com"



Guest

I didn't make it!

0 XP

 
#3 13 years ago

How u know ive got a router? :D I already got the seta sv_master1 "masterjk3.ravensoft.com" seta sv_master2 "master.qtracker.com" seta sv_master3 "clanservers.net" seta sv_master4 "master0.gamespy.com" thing on top of my autoexec.cfg

Ya my friends could join and we did duels and stuff but what u mean with "allowing information for the game to be seen outside the home network and access from outside the home network" perhaps my problem has something to do with the information my computer has to send to masterjk3.ravensoft.com but cant... I opened all the ports listed at Amidalas page (29060-29062 and 29070-27081 <- correct? -.-)




IrishDragon

Living deity

50 XP

22nd July 2005

0 Uploads

178 Posts

0 Threads

#4 13 years ago

I never had to open that many ports. I would open 29070 and 29071 maybe 29072

Once your server is up refresh the main server list. I am unsure of HOW you are starting your server. There are several different methods. Mine was starting JAmpDed by simply clicking an icon on my desktop. Simply clicking the icon would start up my server. If you are starting your server by going in and selecting create game...then your servers name by default would be *Jedi*

Have your friends add your IP to their favorites list...then refresh. This should bring up your server.




Guest

I didn't make it!

0 XP

 
#5 13 years ago

I open server with this little trick most of the people do (because I wanna play on my server too) First I create a dedicated internet server then this nice black console opens, I wait until its ready (im not really sure about that... these are the entrys:

JAmp: v1.0.0.0 win-x86 Aug 5 2003 ----- FS_Startup ----- Current search path: D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\kamino_sjc.pk3 (125 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\Jedi's_Home(JL).pk3 (92 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\Jedi'sHomeJL_II.pk3 (120 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\ffa_episode1_2004.pk3 (162 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets2.pk3 (62 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets1.pk3 (8320 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets0.pk3 (15346 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData/base

---------------------- 24227 files in pk3 files execing mpdefault.cfg execing jampconfig.cfg execing autoexec.cfg execing Recordingdemos.cfg Unknown command "map" ...detecting CPU, found logfile opened on Mon Oct 03 19:12:49 2005

Intel Pentium IV

------- Input Initialization ------- Skipping check for DirectInput Joystick is not active. ------------------------------------ ...initializing QGL succeeded ...setting mode 4: 800 600 W ...created window@3,22 (806x626) Initializing OpenGL driver ...getting DC: succeeded ...GLW_ChoosePFD( 32, 24, 8 ) ...51 PFDs found ...hardware acceleration found ...PIXELFORMAT 3 selected ...creating GL context: succeeded ...making context current: succeeded Initializing OpenGL extensions ...GL_S3_s3tc available ...GL_EXT_texture_compression_s3tc available ...no tc preference specified .....using GL_EXT_texture_compression_s3tc ...using GL_EXT_texture_env_add ...GL_EXT_texture_filter_anisotropic available ...using GL_EXT_texture_filter_anisotropic ...Using GL_EXT_texture_edge_clamp ...using WGL_EXT_swap_control ...using GL_ARB_multitexture ...using GL_EXT_compiled_vertex_array ...using GL_EXT_point_parameters ...GL_NV_register_combiners not found

GL_VENDOR: ATI Technologies Inc. GL_RENDERER: RADEON X800 PRO x86/SSE2 GL_VERSION: 2.0.5147 WinXP Release GL_EXTENSIONS: GL_ARB_multitexture GL_EXT_texture_env_add GL_EXT_compiled_vertex_array GL_S3_s3tc GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_multisample GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_element_array GL_ATI_envmap_bumpmap GL_ATI_fragment_shader GL_ATI_map_object_buffer GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_ATI_vertex_array_object GL_ATI_vertex_attrib_array_object GL_ATI_vertex_streams GL_ATIX_texture_env_combine3 GL_ATIX_texture_env_route GL_ATIX_vertex_shader_output_point_size GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EXT_texgen_reflection GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_EXT_vertex_shader GL_HP_occlusion_test GL_NV_blend_square GL_NV_occlusion_query GL_NV_texgen_reflection GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays GL_WIN_swap_hint WGL_EXT_extensions_string WGL_EXT_swap_control GL_MAX_TEXTURE_SIZE: 2048 GL_MAX_ACTIVE_TEXTURES_ARB: 8

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(8-bits) MODE: 4, 800 x 600 windowed hz:60 GAMMA: hardware w/ 0 overbright bits CPU: Intel Pentium IV @ 1699 MHz rendering primitives: single glDrawElements texturemode: GL_LINEAR_MIPMAP_NEAREST picmip: 1 texture bits: 0 lightmap texture bits: 0 multitexture: enabled compiled vertex arrays: enabled texenv add: enabled compressed textures: enabled compressed lightmaps: disabled texture compression method: GL_EXT_texture_compression_s3tc anisotropic filtering: enabled (16.000000 of 16.000000) Dynamic Glow: disabled

------- sound initialization ------- ----- Sound Info ----- sound system is muted EAX 4.0 not supported Eal file not loaded s_EnvironmentID = 0 s_bInWater = false No background file. ---------------------- ------------------------------------

--- ambient sound initialization --- Sound memory manager started Loading dll file ui. --- Common Initialization Complete --- Winsock Initialized Opening IP socket: localhost:29070 Hostname: Markus IP: 192.168.212.2 ------ Server Initialization ------ Server: mp/ffa3 ----- FS_Startup ----- Current search path: D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\kamino_sjc.pk3 (125 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\Jedi's_Home(JL).pk3 (92 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\Jedi'sHomeJL_II.pk3 (120 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\ffa_episode1_2004.pk3 (162 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets2.pk3 (62 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets1.pk3 (8320 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets0.pk3 (15346 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData/base

handle 1: qconsole.log ---------------------- 48454 files in pk3 files Loading dll file jampgame. ------- Game Initialization ------- gamename: basejk gamedate: Jul 22 2003 Loading dll file ui. Loading dll file cgame. menu file not found: 1, using default ******************* ERROR: Disconnected from server ******************** Loading dll file ui. DROPPED Scanning for servers on the local network... Shutting down OpenGL subsystem Hitch warning: 1350 msec frame time ------ Server Initialization ------ Server: mp/ffa3 ----- FS_Startup ----- Current search path: D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\kamino_sjc.pk3 (125 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\Jedi's_Home(JL).pk3 (92 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\Jedi'sHomeJL_II.pk3 (120 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\ffa_episode1_2004.pk3 (162 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets2.pk3 (62 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets1.pk3 (8320 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets0.pk3 (15346 files) D:\Programme\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData/base

handle 1: qconsole.log ---------------------- 72681 files in pk3 files Loading dll file jampgame. ------- Game Initialization ------- gamename: basejk gamedate: Jul 22 2003 ------------------------------------------------------------ InitGame: \sv_allowDownload\0\sv_allowAnonymous\0\sv_privateClients\0\g_gametype\0\g_maxGameClients\5\g_jediVmerc\0\g_forceRegenTime\0\g_forcePowerDisable\262143\g_weaponDisable\524279\g_siegeRespawn\20\g_siegeTeam1\none\g_siegeTeam2\none\g_siegeTeamSwitch\1\g_blueTeam\Rebellion\g_redTeam\Empire\sv_floodProtect\1\sv_maxPing\500\sv_minPing\0\sv_maxRate\4000\sv_maxclients\8\sv_hostname\->^Insanity^<-\g_duelWeaponDisable\524279\g_forceBasedTeams\0\duel_fraglimit\10\g_maxForceRank\999\g_saberLocking\0\g_privateDuel\1\timelimit\0\fraglimit\0\dmflags\8\version\JAmp: v1.0.0.0 win-x86 Aug 5 2003\g_maxHolocronCarry\3\g_needpass\0\protocol\25\mapname\mp/ffa3\bot_minplayers\0\g_debugMelee\0\g_stepSlideFix\1\g_noSpecMove\0\gamename\basejk\g_allowNPC\1\g_saberWallDamageScale\0.4\bg_fighterAltControl\0\g_showDuelHealths\0 Hitch warning: 3082 msec frame time Resolving masterjk3.ravensoft.com masterjk3.ravensoft.com resolved to 63.146.124.53:29060 Sending heartbeat to masterjk3.ravensoft.com Resolving qtracker.com Couldn't resolve address: qtracker.com Resolving clanservers.net clanservers.net resolved to 69.93.209.187:29060 Sending heartbeat to clanservers.net Resolving master0.gamespy.com master0.gamespy.com resolved to 207.38.11.34:29060 Sending heartbeat to master0.gamespy.com Hitch warning: 3037 msec frame time

then I just set dedicated to 0 and the main menu opens I go create game, and change dedicated to No then the game starts again. Then I send my IP to my friends and they join by typing /connect into console

The server appears in the 'local' server list as [UDP] But not in the Internet list.

I also tried the other way. (open dedicated server with Jampded.exe, then I open my game and join my own server with /connect Because my friends join over the IP of my router (which is kinda 84.128.53.43 (<- example) I join my server over my Internal IP (192.168.212.2) The problem is that my CPU is not very fast so the server gets lag

The tutorial from chopservers says that I wouldnt be able to see my server in the Internet list only in the local. thats right but my friends (not connected to my home network) cant see it anywhere -.-

Have your friends add your IP to their favorites list...then refresh. This should bring up your server.

ya thats how we do it but I wanna play with ppl I dun know...

I asked some admins from home servers and they told me they did it just as i did and their servers appear in the list :banghead:

PS: my game version is 1.0.0.0 -.-




IrishDragon

Living deity

50 XP

22nd July 2005

0 Uploads

178 Posts

0 Threads

#6 13 years ago

PS: my game version is 1.0.0.0 -.-

Upgrade that and try again. Even the server companies out there that host the game...at least the company I use start ya out with baseJKA version 1.0.1.0

Give that a try and get back to me.




Amidala

Don't whine, respawn!

50 XP

26th September 2003

0 Uploads

505 Posts

0 Threads

#7 13 years ago

IrishDragon is correct, the problem is that you are using version 1.00 instead of 1.01.

I'm glad you found my tutorial to be helpful, but right in the first section ("What you will need") I clearly stated

What you will need

* A broadband (cable, DSL, T1) Internet connection. Upload bandwidth is what matters for servers. The more you have, the more players you can host.

* A Pentium III 700 MHz or faster computer, the faster the better.

* The game installed and patched to the latest version (1.04 for Jedi Outcast, 1.01 for Jedi Academy).....

Those of us who were running servers the first day that Jedi Academy came out remember the biggest bug with that version: less than 10% of the servers running were showing up in the ingame browser. The 30 or so servers that were visible were full, and the other 400 were empty. The servers that were lucky enough to show up in the ingame browser would change from day to day. So your server would be invisible and empty for days, then visible and totally full 24 hours a day for a day or two, and then back to invisible and empty for days at a time. It caused a lot of anger among the people who were paying for their invisible and empty servers, and it took LucasArts and Raven way too much time to come out with a patch to fix it. That bug should have been patched within days, not the month that it took.

So anyway, the problem is with version 1.00. Also, new servers don't show up instantly on the master list. It sometimes takes up to a day for it to show up. And your friends will also have to patch their games to version 1.01 to play on your 1.01 server. Far more people are using 1.01 than 1.00 (there are around 30 1.00 servers and around 500 1.01 servers) so you and your friends will have more servers to choose from and more players will be able to join your server.




Guest

I didn't make it!

0 XP

 
#8 13 years ago

Thats baaad ... I dun like the patch :thumbsdown: But there are several servers on 1.0.0.0 which are alwys in the list like e.g. Gaaras or rommies HGR server -.- and one of my clan friends always creates a server and 2 minutes later it appears in my list Thats kinda strange isnt it :confused:

Thanks for your help :thatsgreat:




Guest

I didn't make it!

0 XP

 
#9 13 years ago

(lol where is the edit button? sry for doublepost :uhm:) I patched... my server doesnt appear in the list in 1.01 (wtf?)