Server issue -1 reply

Please wait...

Ryojin

lolwut?

536,504 XP

8th November 2005

5 Uploads

52,632 Posts

406 Threads

#1 6 years ago

So some of my friends just got JA, and I wanted to play with them. I tried to start up a server like I usually did, but it didn't seem to be working. No matter what I did, the server was set to local play only. I have a .bat file that I was always using before, and it was working, but it isn't anymore. I tried launching a server from inside the game. Setting the "Dedicated" option to anything made no difference whatsoever.

I've looked through the .bat, through all the .cfg files that I thought might be relevant, and nothing has helped at all. Anyone here have any suggestions? I'd like to play with my friends on a server of my own.

I would just try to get one of them to host it, but their internet connections aren't great, so it's been left to me again.


Disclaimer: Personal opinions still not endorsed by Ryojin.



Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#2 6 years ago

Use jampDed.exe Make sure the .bat has: +set dedicated "2" Connect to it via /connect localhost:29070

Your ISP may not allow you to "loopback" so you'll have to connect locally. Other people should be able to join by typing /connect x.x.x.x:29070 (replacing "x.x.x.x" for your external IP)

Apart from that, make sure you've set up port forwarding rules and allowed it through your local firewall.

Specific error messages or explaining in detail what "isn't working" would help.




ProxXect

.

50 XP

24th July 2003

0 Uploads

411 Posts

0 Threads

#3 6 years ago

I'm refering to [this thread] which I posted yesterday. The master server list is down, which means that even though your server is up and running, no one will be able to see it.

The only thing we can do right now is trade server information (IPs) and manually /connect through the console.

Oh, and if you're hosting the server on the same machine that you are playing on, it will only show up in local on your end. :)

[EDIT] Raven Software is currently looking into the matter and working on rebooting the servers. ;)




Ryojin

lolwut?

536,504 XP

8th November 2005

5 Uploads

52,632 Posts

406 Threads

#4 6 years ago

Raz0r;5629399Use jampDed.exe Make sure the .bat has: +set dedicated "2" Connect to it via /connect localhost:29070

Your ISP may not allow you to "loopback" so you'll have to connect locally. Other people should be able to join by typing /connect x.x.x.x:29070 (replacing "x.x.x.x" for your external IP)

Apart from that, make sure you've set up port forwarding rules and allowed it through your local firewall.

Specific error messages or explaining in detail what "isn't working" would help.

I've tried just that... No matter what I try, though, nobody can connect through my external IP. It doesn't give any specific error messages, so there is not much more I can say besides what I already said.

I know port forwarding has been set up, and I am fairly certain that it is allowed through my local firewall. Like I said before, I used to run a server just fine.

Now that I think about it, though, I only ran a server before switching over to Win7... Perhaps there's something interfering that I have overlooked...


Disclaimer: Personal opinions still not endorsed by Ryojin.



Ryojin

lolwut?

536,504 XP

8th November 2005

5 Uploads

52,632 Posts

406 Threads

#5 6 years ago

Okay, so after looking over my firewall, I saw that the game wasn't allowed access for some reason. After enabling it and trying to launch a server again... Same problem. The server can not be detected by any outside sources at all. I also notice that the game console that is launched says the IP is my local IP, but I don't know whether or not it would show that even if it were working right.


Disclaimer: Personal opinions still not endorsed by Ryojin.



Ryojin

lolwut?

536,504 XP

8th November 2005

5 Uploads

52,632 Posts

406 Threads

#6 6 years ago

Just double checked my port forwarding settings, that's all good there. I don't get why this isn't working, but I suspect that it has something to do with the fact that I am using Win7 now instead of XP.


Disclaimer: Personal opinions still not endorsed by Ryojin.



Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#7 6 years ago

I host servers fine on W7. The most important part is making sure "dedicated" is set to 2 at startup, not after.

What does "net_port" and "dedicated" say in the server console? Oh, and after you start it up make sure a map is loaded before connecting =D




Ryojin

lolwut?

536,504 XP

8th November 2005

5 Uploads

52,632 Posts

406 Threads

#8 6 years ago

The server console says nothing of either 'net_port' or 'dedicated'

I'm launching it through a .bat file that I used before just fine... Here's the contents:

Spoiler: Show
C: cd\program files cd lucasarts cd star wars jedi knight jedi academy cd gamedata .\jamp.exe +set dedicated 2 +set net_port 29070 +set fs_game japlus +set com_hunkmegs 256 +set sv_maxclients 14 +exec server.cfg

Another thing to note is that if I use Hamachi to create a network with my friends, they can then access the server just fine. One of them, however, has serious problems with Hamachi, and they lag far too much to be able to play.


Disclaimer: Personal opinions still not endorsed by Ryojin.