Spawning NPC's in MP -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 13 years ago

Yes I am haveing a problem spawning npc's in multiplayer, I has been a while since I have played Jedi Academy but I figured I would load it up and fool around with it again, well I remeber being able to spawn npc's in multiplayer back in the day no problem but evey time I try and do it now by typeing in \npc spawn [npc name] lets say a stormtrooper I keep getting the message "ERROR: cannot spawn npc stormtrooper", well i figured it was because I didn't have cheats on, well I turned on cheats useing devmap and all that but still I can't spawn them, and I get the same Error, I tried everything I can think of but no dice and I was wondering is there was something I was doing wrong or forgetting to do, so if any of you have any suggestions or know of anything that I am forgetting like a mod or something it would be really helpful.




zero89

Dark jedi master

50 XP

18th August 2005

0 Uploads

44 Posts

0 Threads

#2 13 years ago

you dont need to use cheats to spawn all u do is login as the admin the way i do this is type all these into console window (main console) seta jp_councilPass "(Your password)"

g_allowNPC 1

jp_councilallowedcmd 4

jp_councilallowedcmd 536870910

then it shud work




RaizanDelta

The Three Storms

50 XP

29th May 2005

0 Uploads

159 Posts

0 Threads

#3 13 years ago

are you running a dedicated JA+ v2.3 server from your own pc? if you are, here's what you do... 1) go into base 2) change assets0.pk3 to .zip 3) find the folder 'ext_data' 4) copy the whole folder 5) place the extracted 'ext_data' in japlus (so it goes like gamedata/japlus/ext_data) that oughtta fix it. for some reason, when running a home hosted JA+ server, all NPCs and vehicles need to be installed to the JA+ folder.....




TubbyTim

Mapper, skinner, n00b modeler

50 XP

31st May 2005

0 Uploads

578 Posts

0 Threads

#4 13 years ago

im gettin the same error but its not in ja+ its in ANY mod or even default jk3 i get this and i DIDNT delete anything cause i just reinstalled jk3 and it worked fine but then i patched it and now i cant spawn ANY default raven npcs suchs as rancors swoops atsts noghri but i can spawn custom ones made by othere peeps like yoda and stuff PLEAZ HELP ME sorry if u consider this to be taking over your thread....




RaizanDelta

The Three Storms

50 XP

29th May 2005

0 Uploads

159 Posts

0 Threads

#5 13 years ago

sorry tim i dunno bout that one...




axem

I want to be like the Admins

50 XP

24th March 2004

0 Uploads

239 Posts

0 Threads

#6 13 years ago

OK, old thread, I know...

I have a related question to NPCs, but in Mapping...

I know how to insert an NPC in my map, but I'd like him to be static... so it won't move, no matter what.... someone knows how to do that, if possible..




Mikouen VIP Member

What?

145,650 XP

4th September 2005

4 Uploads

11,732 Posts

2 Threads

#7 13 years ago

It's one of the spawnflags. Try opening the entity window, there will be a checkbox that disables the NPC AI. Or, alternately, you could just insert the model without NPC attachment. As for Tim's question, it seems like your assets files are corrupted.


I don't know how, and I don't know why, but this is totally Sheep's fault.