Start JK3-Internet-Server over LAN -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 12 years ago

hi, unfortunately i have some serious problems starting a JK3-internet-server and i am quite at a loss. i read tons of forum-threads, but i couldnt solve the problem yet. this is what i did so far: i installed JK3 , downloaded/unzipped the dedicatet server 1.011, and didnt touch the server.cfg-file so far (except for the server-name). when i connect my computer directly to the modem, the server works fine and i can see it on the serverlist in the game. when i connect my computer to the (netgear)router, i get an error-message, when i try to start the JK3-server:

Opening IP socket: 213.47.*.*:28070 WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL Opening IP socket: 213.47.*.*:28071 WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL Opening IP socket: 213.47.*.*:28072 WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL Opening IP socket: 213.47.*.*:28073 WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL Opening IP socket: 213.47.*.*:28074 WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL Opening IP socket: 213.47.*.*:28075 WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL Opening IP socket: 213.47.*.*:28076 WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL Opening IP socket: 213.47.*.*:28077 WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL Opening IP socket: 213.47.*.*:28078 WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL Opening IP socket: 213.47.*.*:28079 WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL WARNING: Couldn't allocate IP port

i tried the following things, but they dont work: i use the parameter "+exec server.cfg +set net_port "28070" +set net_ip "213.47.*.*"" to start the server, so it uses my "ISP-IP" and not my "LAN-IP". i configurated the port-forwarding of my router to forward the required ports to the correct IP (i even tried to forward all ports from 27000 to 30000, to make sure i didnt forget an important port). in addition is set my computer as the "Default DMZ Server". the error-message is still appearing! i really dont know where the mistake could be... perhaps you can give me an idea, how to get rid of this annoying error. so long (and excuse my poor english ;) )!