Windows 7 and OpenGL -1 reply

  • 1
  • 2

Please wait...

AHadley

A Man on a Mission

50 XP

14th August 2007

0 Uploads

46 Posts

0 Threads

#1 11 years ago

I've been having problems with all my Q3 games in Windows 7, and it's getting really bloody annoying. The same games worked fine on XPMCE.

Here's my console spam.

Spoiler: Show

JA: v1.0.1.0 win-x86 Oct 24 2003 Initialising zone memory ..... ----- FS_Startup ----- Current search path: C:\Games\Jedi Academy\GameData\base\assets3.pk3 (16 files) C:\Games\Jedi Academy\GameData\base\assets2.pk3 (62 files) C:\Games\Jedi Academy\GameData\base\assets1.pk3 (8320 files) C:\Games\Jedi Academy\GameData\base\assets0.pk3 (15346 files) C:\Games\Jedi Academy\GameData/base

---------------------- 23744 files in pk3 files execing default.cfg couldn't exec jaconfig.cfg couldn't exec autoexec.cfg ...detecting CPU, found Intel Pentium IV

------- Input Initialization ------- Skipping check for DirectInput Joystick is not active. ------------------------------------ ----- Client Initialization ----- ----- Initializing Renderer ---- ------------------------------- ----- Client Initialization Complete ----- --- Common Initialization Complete --- Working directory: C:\Games\Jedi Academy\GameData Initializing OpenGL subsystem ...initializing QGL succeeded ...setting mode 4: 800 600 FS ...using desktop display depth of 32 ...calling CDS: ok ...registered window class ...created window@0,0 (800x600) Initializing OpenGL driver ...getting DC: succeeded ...GLW_ChoosePFD( 32, 24, 8 ) ...35 PFDs found ...GLW_ChoosePFD failed ...GLW_ChoosePFD( 32, 24, 0 ) ...35 PFDs found ...GLW_ChoosePFD failed ...failed to find an appropriate PIXELFORMAT ...restoring display settings ...WARNING: could not set the given mode (4) ...setting mode 3: 640 480 FS ...using colorsbits of 16 ...calling CDS: ok ...created window@0,0 (640x480) Initializing OpenGL driver ...getting DC: succeeded ...GLW_ChoosePFD( 16, 16, 0 ) ...35 PFDs found ...GLW_ChoosePFD failed ...GLW_ChoosePFD( 16, 16, 0 ) ...35 PFDs found ...GLW_ChoosePFD failed ...failed to find an appropriate PIXELFORMAT ...restoring display settings ...WARNING: could not set the given mode (3) ...shutting down QGL ...unloading OpenGL DLL ----- CL_Shutdown ----- ----------------------- GLW_StartOpenGL() - could not load OpenGL subsystem




Guest

I didn't make it!

0 XP

 
#2 11 years ago

Make sure you're using Windows 7 graphic drivers. Some people make a mistake and use Vista drivers by accident. Btw, what graphic card (company and generation) do you have? NVIDIA or ATI?




jk3editor

Retard Hungarian Modder

50 XP

21st August 2008

0 Uploads

1,520 Posts

0 Threads

#3 11 years ago

[COLOR="Navy"]Try to update your video card driver. That usually fixes this problem.[/COLOR]




Raz0r

Worse than most terrible

50 XP

27th September 2006

0 Uploads

6,737 Posts

0 Threads

#4 11 years ago

Just a bit of a hunch, but try starting JA with this command line: call jamp.exe +set developer 1 +set r_mode 4 I doubt it'll work, but I'd be trying anything.

Oh, and what Tricorder said ;)




Nozyspy

31,830 XP

30th August 2004

12 Uploads

2,853 Posts

0 Threads

#5 11 years ago

JKA should definitely work on Windows 7 as i know at least one person who uses it on Win 7.




AHadley

A Man on a Mission

50 XP

14th August 2007

0 Uploads

46 Posts

0 Threads

#6 11 years ago

I have an Intel 82865G Graphics and Memory Chipset Controller - the newest drivers for it are for XPMCE. I'm currently trying to raise Ā£376 for a new PC.




Guest

I didn't make it!

0 XP

 
#7 11 years ago

Integrated graphic chip, huh? I don't think there's much you can do about it without the proper drivers. Unless someone here knows something I don't. :clueless:




jk3editor

Retard Hungarian Modder

50 XP

21st August 2008

0 Uploads

1,520 Posts

0 Threads

#8 11 years ago

[COLOR=Navy]

Nozyspy;5171636JKA should definitely work on Windows 7 as i know at least one person who uses it on Win 7.
I have Win7 too, and it works perfectly :P Oh, and the Win7 always download the newest drivers....it did it for mi to my nVidia card...so I think that isn't problem, except if you disabled it :P [/COLOR]



AHadley

A Man on a Mission

50 XP

14th August 2007

0 Uploads

46 Posts

0 Threads

#9 11 years ago
jk3editor;5172502[COLOR=Navy] Oh, and the Win7 always download the newest drivers....it did it for mi to my nVidia card...so I think that isn't problem, except if you disabled it :P [/COLOR]

That's a common misconception. W7 downloads what it thinks are the newest drivers, and there are issues with some nVidia cards not having the correct ones. Might be the 8000-series G-Force models. Fortunately, the issue only rears its ugly head on a few games, JK3 not being one of them.




jk3editor

Retard Hungarian Modder

50 XP

21st August 2008

0 Uploads

1,520 Posts

0 Threads

#10 11 years ago

[COLOR="Navy"]Ah, but it's cool for me :O[/COLOR]




  • 1
  • 2