Securom thingy-Possible 1.03 issue -1 reply

Please wait...


Slightly cooler than a n00b

50 XP

7th July 2008

0 Uploads

46 Posts

0 Threads

#1 11 years ago

Hi all, several monthss ago I tried to play KOTOR on my new PC-suprise suprise it didn't work cuz it came up with a Securom Disk emulator confliction. I left it after that until today-I installed the game as normal but I DID NOT install the 1.03 patch/update and it has worked flawlessly. Last time I was able to play the game(with 1.03) only 1 time before it locked up on me when I came back to the game the following day-this time I have been able to play on all occasions even after I turned my computer off etc etc etc. I don't know if this is the solution to the general problem but it worked for me. This is what happened in short 1. Installed 2. Played for a bit 3. Turned game off 4. Installed 1.03 5. Securom of death notice 6. Re-installed 7. DID NOT install 1.03 8. Played for hours plus turning game and pc on and off. I really hope this helps people or at least some people.



50 XP

21st April 2008

0 Uploads

180 Posts

0 Threads

#2 11 years ago

I blame SecuRom, myself. That is perhaps the sh**tiest thing I have EVER seen. (Made me install BioShock 6 times then made it crash when I tried to play it :mad:)