Game not starting up -1 reply

Please wait...

Darth Mandalore

The ultimate sith lord!

50 XP

17th November 2008

0 Uploads

12 Posts

0 Threads

#1 10 years ago

Hey, can someone please help me. I recently got a new computer which came with Vista and when I started up TSL (after installing) it just gave me the Vista loading cursor and even that goes away after a few seconds and then nothing happens. If it will help my computer's specs are: OS: Windows Vista Home Premium 64 Bit CPU:Intel Core 2 Duo 2.66 GHz RAM: 4GB Graphics card: Nvidia Geforce 9800 GT Sound Card: Realtek High Definition Audio DirectX: V9.0c

When I scanned my hardware with the TSL hardware scan thing it said: OS: Passed - Windows XP Service Pack 2:confused: (I don't know why this is because I have Vista) CPU:Passed RAM:Passed HDD:Passed Video:Failed - (null) 4096 MB:confused: Audio:Passed OpenGL:Passed DirectX:Passed

Could someone please help me I really like TSL and I really want to play it on my new computer:bawl:




G.R.A.E.M.E. VIP Member

No-Life Overwatch Player

178,803 XP

14th August 2008

0 Uploads

15,861 Posts

0 Threads

#2 10 years ago

Ehm... does your test refer the graphics card memory to the RAM instead?... It's quite confusing, seeing as your test displays it as (null) :confused: Hm, could you please specify how high your graphics card memory is?


Formerly known as Graeme and Arld.



Darth Mandalore

The ultimate sith lord!

50 XP

17th November 2008

0 Uploads

12 Posts

0 Threads

#3 10 years ago

I have 512 MB of GDDR3 Graphics RAM.




G.R.A.E.M.E. VIP Member

No-Life Overwatch Player

178,803 XP

14th August 2008

0 Uploads

15,861 Posts

0 Threads

#4 10 years ago

Then I can't see any reason why your test displays it as Null. :confused:


Formerly known as Graeme and Arld.



Guest

I didn't make it!

0 XP

 
#5 10 years ago

Since you have Vista, try this:

  • right click on .exe file and choose Properties
  • go to Compatibility tab
  • enable Compatibility Mode and set it for Windows 98 / Windows Me
  • enable running with Administrative priviledges
  • disable Desktop Composition
  • click Ok and try running the game

If that doesn't help, try reducing your RAM amount. That means opening your computer and taking some RAM modules out (depends on how many of them you have). I'm probably wrong, but having too much RAM is not always a good thing, especially with old(er) games. And before someone points that out; yes, I know it's apparently the VRAM and not the RAM problem, so that makes this even more confusing.




Darth Mandalore

The ultimate sith lord!

50 XP

17th November 2008

0 Uploads

12 Posts

0 Threads

#6 10 years ago

Tricorder;4745803Since you have Vista, try this:

  • right click on .exe file and choose Properties
  • go to Compatibility tab
  • enable Compatibility Mode and set it for Windows 98 / Windows Me
  • enable running with Administrative priviledges
  • disable Desktop Composition
  • click Ok and try running the game

I have already tried that and it didn't do anything, however I have fixed the problem by downloading the TSL Vista Fix from Filefront. BTW I know how to take RAM out.




Guest

I didn't make it!

0 XP

 
#7 10 years ago

I'm glad you solved the problem. Here's a link to that fix in case someone else comes here with the same problem:

TSL Windows Vista Fix, Knights of the Old Republic 2 Downloads, Knights of the Old Republic 2 Patches




Guest

I didn't make it!

0 XP

 
#8 10 years ago

have you by any chance tryed using the update patches? such as the one on LucasArts.com | Star Wars Knights of the Old Republic II: The Sith Lords as this can help the game run (by the way if using the patches install 1.0a twice as it can mess up and then do 1.0b)