KOTOR 2 on Vista (Secondary Thread) -1 reply

Please wait...

MechWarrior001

Sci-Fi Fantasist.

50 XP

19th August 2007

0 Uploads

85 Posts

0 Threads

#1 10 years ago

Ok...

I have KOTOR 2 patched to 1.0b

HQ Music patch = installed

HQ Movie Patch = Installed (not noticing much difference, mb need to reinstall)

Nvidia Driver version = 169.25

Error: (null) 1024 Your current video card drivers are out of date. NVidia cards require Detonator 45.23 drivers or better. - What the $^^& is Detonator?

OS = Microsoft Windows [Version 6.0.6000] (Vista Home Premium)

And one other thing:

When traveling through the Apartment module 082 on Telos, my frames drop to 10-20.

In Apt. Mod. 081 & other places I get 30-40 frames.

Oh and It happens even on min settings too. Any help please?




Guest

I didn't make it!

0 XP

 
#2 10 years ago

I'm surprised it works at all, I didn't know there were any fixes to make it work. I would just ignore the video message if it still works, probably just a little bug. Also, if the only time the frame rate drops, then you probably just have to deal with it, there's not much you can do. Many a time have I had to restart the game due to frame rate issues. Good luck though, and congrats on it working at all on Vista, I thought it couldn't be done, read that somewhere.




JCarter426

I'm watching you...

50 XP

2nd September 2007

0 Uploads

1,503 Posts

0 Threads

#3 10 years ago

No, it can be done now. Well, K2 at least (I don't know about K1). All I had to do was replace the Mss32.dll. If you haven't done that, then I suggest you do. Mss32.dll - FileFront.com




Guest

I didn't make it!

0 XP

 
#4 10 years ago

Thanks for that! Good to know, I'll probably be switching to vista in a bit, and I've had second thoughts with the talk of kotor not working.




TLM16

The Internet ends at GF

50 XP

13th June 2007

0 Uploads

126 Posts

0 Threads

#5 10 years ago

I should point out that that fix doesn't work for everyone. It's had a fair bit of success, to be fair, but it's not perfect. Hope it works for ya though ;)




Temeraire788

Jedi Guardian of Lore

50 XP

22nd May 2007

0 Uploads

15 Posts

0 Threads

#6 10 years ago

If you have XP, I think you ought to stick with that. Vista has given me so many problems. It's like it hates games or something..




JCarter426

I'm watching you...

50 XP

2nd September 2007

0 Uploads

1,503 Posts

0 Threads

#7 10 years ago

It's not that Vista hates games; it's that Microsoft hates people.




valient20

Slightly cooler than a n00b

50 XP

19th August 2005

0 Uploads

34 Posts

0 Threads

#8 10 years ago

What about the Cheat Options? I am, admittedly, one who uses them, and cant get them to work now. Any ideas?




JCarter426

I'm watching you...

50 XP

2nd September 2007

0 Uploads

1,503 Posts

0 Threads

#9 10 years ago

This one is an easy fix. It won't let you save swkotor2.ini, right? Just right click the file, go to properties, then security, and then permissions. Give your user name full permission, hit apply, and exit. Then you should be able to edit the file to enable cheats.




valient20

Slightly cooler than a n00b

50 XP

19th August 2005

0 Uploads

34 Posts

0 Threads

#10 10 years ago

Not quite so easy. I've already saved it. I just cant get the console to pop up. I was able to do this with XP, but Vista is being dumb. Big surprise.