KoTOR 2 on Vista -1 reply

Please wait...

Ḷëģöläš-OLD

You'll never walk alone.

99,355 XP

18th June 2008

0 Uploads

9,518 Posts

0 Threads

#51 10 years ago

this should be in TSL lol




bignutjob

Heart of Darkness

50 XP

26th August 2001

0 Uploads

209 Posts

0 Threads

#52 10 years ago
Legolas*;4589125this should be in TSL lol[/quote] Yes it should, but I don't mind helping here. [quote=s.butler1;4581249]i get the impression that your knowledge of computing is greater than mine, and if you dont mind id like to ask a question i have downloaded directx sdk (august 2008) from microsoft, is it all .dll files from every directory that i want to move to the system folder, is that system32 and finally do i need to put them into files within in the system folder or just straight into the root directory?

Place the dll's into the windows system32 folder, do not overwrite any tho just let it copy over the ones that are missing. Repeat the process if there is a system folder (doesn't hurt). I can't remember off hand atm as I am on my XP pc. I will fire up my vista pc at some stage tonight and double check and post back here.




GlitchMasterShmit

One and only...

50 XP

24th April 2007

0 Uploads

1,197 Posts

0 Threads

#53 10 years ago

i cant even get the damn disc to get recognized by the drive. halp!




Guest

I didn't make it!

0 XP

 
#54 10 years ago

I can get the first KOTOR working great on my pc using compatibility mode. I was able to get KOTOR 2 running once, but all other times i just get the application stopped error message.




bignutjob

Heart of Darkness

50 XP

26th August 2001

0 Uploads

209 Posts

0 Threads

#55 10 years ago

How I got K2 to work on vista.

I am running an intel duo core cpu with windows vista ultimate edition x86. My video adapter is a Radeon X series pcie.

Now, on the first install and run of the game it blacked screened me, as in all I got WAS a black screen and it hung and did nowt. So I thought forget it and tossed it away to the side. After researching other games on the internet and vista I did this.

I inserted the cd and quit the auto installer that popped up. I then browsed the cd's dir structure and found the actuall setup either .exe or .msi can't recall which. I right clicked on it and in properties set to run it as admin. I then installed it and as soon as it was installed I went into the games dir structure and found the k2 exe which I then also set to run as admin.

I then put the cd back in and when the auto player came up I clicked on update game and let it patch itself. Viola, that worked for me. The game ran fine altho running it as admin it will keep asking you if you are sure lol. Small sacrafice imo.

Give it a try, as I said it worked for me.




uglyman

aka dannydamnage

50 XP

5th October 2008

0 Uploads

24 Posts

0 Threads

#56 10 years ago

bignutjob;4596102Yes it should, but I don't mind helping here.

Place the dll's into the windows system32 folder, do not overwrite any tho just let it copy over the ones that are missing. Repeat the process if there is a system folder (doesn't hurt). I can't remember off hand atm as I am on my XP pc. I will fire up my vista pc at some stage tonight and double check and post back here.

are you talking about the .dll's in all the zip folders?




Guest

I didn't make it!

0 XP

 
#57 9 years ago

Hi, I found a solution for kotor on vista. Please click the link and read the steps. I have no problems with kotor 2 anymore! "How To" KOTOR 2 On Vista - Obsidian Forum Community




Guest

I didn't make it!

0 XP

 
#58 9 years ago

okay I'm new to this whole thing...and I only know so much about computers....:confused: All I know is i have a Toshiba that uses Vista and my KOTOR 2 game ISNT working.... oh and it's done this with another game too.




Guest

I didn't make it!

0 XP

 
#59 9 years ago
Graeme;4558942Hehe, don't blame Vista! I use it too, and it works fine.:p

I DO blame vista...I like the way XP works better.




Guest

I didn't make it!

0 XP

 
#60 9 years ago

It does seem to be Vista that causes all the problems but it also seems like one fix doesnt work for every one, I had the problem where I would run the game and it would crash after start up so I tired the disabling sound trick and it fixed it but I really wanted sound so I went back to the configuration panel and checked off "Force Software Sound" and that also worked, I really have no clue why though but I hope this helps people still looking for a solution (this is on 32-bit Vista Home Premium btw)