KotOR 2 problem.Black screen @ Telos Academy -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 8 years ago

hello and i just want to say what an honor is to join this community. never knew there was a forum like this dedicated only to KofOR 2.

i have installed KofOR2 recently since i really felt i need to re-play this game. so i've install it and it worked fine, till i reach a certain point : Telos Academy when i'm about to leave with the Eban Hawk. for some strange reason, the game loads, then i hear some music and i'm in the ship, but i can't see anything since the entire screen is black. only if i want to load the game, i can see clearly i'm in the ship ( from the picture from the LOAD menu ). the problem is that if i try to load from that point, the game starts the loading procedure ( backround bla bla bla ) but the loading bar gets stuck at about 1 3rd. still, i left the PC like that for 10 minutes and the loading bar didn't move a millimeter to the right. so i'm kind of sad cause i have spent some time with the game, and i can't go farther. i have also found a post on this forum and the guy who posted it has the same problem as me. just watch the movie he made with XFire , it's exactly the same. http://forums.filefront.com/sw-kotor2-problems-errors-help/426119-cant-get-past-telos-using-tsl-restoration-mod.html

i also want to add that i haven't altered the game in any way: no mods, no cheats or anything. the version of my game is :" Your game version is: 2.00.424 English " and my computer is more than capable of handling this game : Quad Core @ 2 GHz, 4 GB DDR3, ATI 4670 HD 1 GB DDR5 with a Windows 7 64 bit OS. i also want to say that i don't think there's a problem with the video drivers, since if there were any, the game wouldn't have work at all. i mean , till Telos Academy, i had no problems what so ever.

so what should i do so i can get over this problem ? thanx in advanced !




Guest

I didn't make it!

0 XP

 
#2 8 years ago

It might have to do with Window's 7, there are a few games that will work fine for a while then suddenly not work in one spot. Try running it in Compatability Mode, that has helped with other games I've worked with. You can set the Compatability Mode by right clicking on your KotORII shortcut, >Properties>Compatability, then check the run in Compatability Mode box. Also, welcome to our little community! Have fun and feel free to roam around. :D




Guest

I didn't make it!

0 XP

 
#3 8 years ago

i have found a temporary solution for my problem. while searching on google for an answer i have read something about a " warp cheat " which allows you to teleport from 1 place to another. so i said to myself that i could jump from my last working location straight to Eban Hawk. i had to modify some file ( www.dlh.net -> english version of the site -> cheats -> search for Star Wars ... ) ( i don't encourage the usage of cheats ! ) but before i made a backup of the file. after that i gave it a try and it didn't work. i was pissed and i wanted to close the game, even uninstall it. but by mistake i pressed Quick Load and i found myself in front of the Eban Hawk again ( that's where i made my Quick Save ) . and i gave it a go again, knowing that i will get a black screen again. Well, it worked ... and i'm happy know.

also i need to add that , the "warp cheat" wasn't the only thing that got me out of the problem. i also found a "Kotor_2_Vista_fix" on google. it's a file named Mss32.dll which is about 2 KB shorter than the original file. also make a copy of the original file before you copy the fix into the KOTOR directory. also, under haKZ direction, i have changed the Compatibility mode of the game , from "normal" ( or whatever was initially ) to Windows 2000 / Windows XP SP3.

Now, i don't know if the entire " cocktail " is responsible for fixing my problem or only parts of it, but what matters is that the game is working fine.

Enjoy the game !




Guest

I didn't make it!

0 XP

 
#4 8 years ago

Hello fellow KOTORII fans!

I am running the game on Win7 64-bit with an ATI Radeon 4870 x2. So far the game has run relatively smooth, but now I'm stranded at the Telos Academy due to the black screen glitch.

I have tried installing the Vista fix that scorpion2001 suggested. I have also tried the Vista and Win2000 compatibility modes.

I'd like to try the XP SP3 compatibility mode, but the game can't seem to find my saved games when run this mode.

Any suggestions as to why this is would be much appreciated.

Thanks! Dagfinn




Guest

I didn't make it!

0 XP

 
#5 7 years ago

scorpion2001;5419016hello and i just want to say what an honor is to join this community. never knew there was a forum like this dedicated only to KofOR 2.

i have installed KofOR2 recently since i really felt i need to re-play this game. so i've install it and it worked fine, till i reach a certain point : Telos Academy when i'm about to leave with the Eban Hawk. for some strange reason, the game loads, then i hear some music and i'm in the ship, but i can't see anything since the entire screen is black. only if i want to load the game, i can see clearly i'm in the ship ( from the picture from the LOAD menu ). the problem is that if i try to load from that point, the game starts the loading procedure ( backround bla bla bla ) but the loading bar gets stuck at about 1 3rd. still, i left the PC like that for 10 minutes and the loading bar didn't move a millimeter to the right. so i'm kind of sad cause i have spent some time with the game, and i can't go farther. i have also found a post on this forum and the guy who posted it has the same problem as me. just watch the movie he made with XFire , it's exactly the same. http://forums.filefront.com/sw-kotor2-problems-errors-help/426119-cant-get-past-telos-using-tsl-restoration-mod.html

i also want to add that i haven't altered the game in any way: no mods, no cheats or anything. the version of my game is :" Your game version is: 2.00.424 English " and my computer is more than capable of handling this game : Quad Core @ 2 GHz, 4 GB DDR3, ATI 4670 HD 1 GB DDR5 with a Windows 7 64 bit OS. i also want to say that i don't think there's a problem with the video drivers, since if there were any, the game wouldn't have work at all. i mean , till Telos Academy, i had no problems what so ever.

so what should i do so i can get over this problem ? thanx in advanced !

I've been having same prob but I re-installed the game and are on my way back to the same point.Now I know I'm not crazy.Gonna try the compatability thing and hope that helps if not then Im sending a b-ball bat thru my moniter........again!