Annoying sound issue 12 replies

  • 1
  • 2

Please wait...

G.R.A.E.M.E. VIP Member

OW & HS Addict

178,776 XP

14th August 2008

0 Uploads

15,860 Posts

0 Threads

#1 8 years ago

Well basically, I decided to re-install my OS (Win7 Pro x64) on my HP Pavilion dv6 and kind of came across an issue I had earlier, but managed to fix that. It seems that both the 'headphone-mode' and 'speaker-mode' are together as one, rather than each apart.

To elaborate what I mean precisely: for example, when you usually mute your speaker sound, plug-in your headphone and turn on volume, it should stay muted if you plug it out afterwards, as that's what you have set before. However, mine are 'shared', meaning that if I mute my speakers, plug-in my headphone, it stays muted. This didn't seem to occur before I re-installed my OS (except the time I upgraded from Vista to Win7).

I have tried to roll-back my driver once and that didn't work. I then went to the Realtek site (clicky) and downloaded the 'Vista, Windows 7 Driver (64 bits)'. After installing, that didn't work either as the issue remained as it was before.

So, any idea what I could do? As aforementioned: I did manage to fix it a while ago, but kind of forgot what I did precisely.

Any help would be greatly appreciated.


Formerly known as Graeme and Arld.



>Omen<

Modern Warfare

50 XP

1st January 2005

0 Uploads

7,395 Posts

0 Threads

#2 8 years ago

Check to see that your front panel audio cables are still hooked up properly. The feature you're referring to is called "Return", often labeled as L Ret and R Ret.




D3matt

I take what n0e says way too seriously

50 XP

19th November 2007

0 Uploads

2,552 Posts

0 Threads

#3 8 years ago

Sounds like a normal behavior to me. The speakers should automatically mute when headphones are plugged in, and transfer over any settings (volume, mute) to the headphone jack. Honestly I'd be more surprised if I had to separate adjust the volume for the 2.

Then again it's possible I've entirely misunderstood what you're saying.




G.R.A.E.M.E. VIP Member

OW & HS Addict

178,776 XP

14th August 2008

0 Uploads

15,860 Posts

0 Threads

#4 8 years ago
>Omen<;5355636Check to see that your front panel audio cables are still hooked up properly.

Yes, they're plugged in properly.

And I do think you misunderstood, D3. If I plug-in my headphone, the audio does switch over to said headphone. However, the settings, so to say, should be independent. By that, I mean that if my speakers are muted, I should not have to turn on the volume again once I plug-in my headphone. It should 'save' the setting of volume I've previously set.


Formerly known as Graeme and Arld.



*Daedalus

A Phoenix from the ashes

50 XP

18th April 2006

0 Uploads

3,091 Posts

0 Threads

#5 8 years ago

Graeme;5355640Yes, they're plugged in properly.

And I do think you misunderstood, D3. If I plug-in my headphone, the audio does switch over to said headphone. However, the settings, so to say, should be independent. By that, I mean that if my speakers are muted, I should not have to turn on the volume again once I plug-in my headphone. It should 'save' the setting of volume I've previously set.

It doesn't with mine. (Win7 Ultimate x64) I'm pretty sure that's normal behavior. I'll have a look into it and get back to you though.




G.R.A.E.M.E. VIP Member

OW & HS Addict

178,776 XP

14th August 2008

0 Uploads

15,860 Posts

0 Threads

#6 8 years ago

That'd be appreciated yes. And nope, as far as I'm aware, it's not normal behaviour as this is exactly the opposite of what I used to experience (and liked). :uhm:


Formerly known as Graeme and Arld.



D3matt

I take what n0e says way too seriously

50 XP

19th November 2007

0 Uploads

2,552 Posts

0 Threads

#7 8 years ago

Huh. Must just be something depending on how you plug in your headphones (I know I have like 3 or 4 different ways to do so :P), and there may not actually be a true "normal" behavior.

Maybe there's a setting in the BIOS or in the sound control settings somewhere that got changed when you reinstalled?




G.R.A.E.M.E. VIP Member

OW & HS Addict

178,776 XP

14th August 2008

0 Uploads

15,860 Posts

0 Threads

#8 8 years ago

Well, I didn't do anything beside re-installing my OS, and as far as I'm aware, nothing really 'changed' compared to post-wipe, except this little issue. And it's rather annoying seeing as I tend to accidentally pull my headphone out, which then causes a load of noise at night (ahem, yes <_<).


Formerly known as Graeme and Arld.



D3matt

I take what n0e says way too seriously

50 XP

19th November 2007

0 Uploads

2,552 Posts

0 Threads

#9 8 years ago

Well it can't be a hardware issues if all you did was reinstall the OS. It most certainly has to be software.




Red_Fist

GF is my bext friend *hugs GF*

50 XP

28th April 2010

0 Uploads

1,004 Posts

0 Threads

#10 8 years ago

I think it's based on using the front jacks as opposed to the rear motherboard jacks (back of computer.) You will find a setting to not use the front jacks, or not use the back ones or mute the front jacks or something like that..

Then the front jacks will have more or less control, sorry I can't BE SPECIFIC. But I know it is a setting in realteck driver interface.

Windows has nothing to do with it.(it may read things unlike old OS and cause the problem in light of it finding and running things (hardware) correctly.)

Download the driver from your motherboard manufacturer




  • 1
  • 2