cd-rom driver 7 replies

Please wait...

Nice Guy

Trimming bushes. Since 1992.

50 XP

30th December 2004

0 Uploads

318 Posts

0 Threads

#1 12 years ago

yesterday i was cleaning my comp, deleting junk data etc, and it looks like by accident i deleted my cd-rom drivers. so i checked the internet to get new drivers to install. i'm using LITE-ON LTR-48246K and TEAC CD-540E, both screwed.

no success so far, i also checked the windows szupport center or whatever it is, it didnt help me out. tried to reinstall LTR, it only said that driver might be damaged or something and click finish to close the wizard (d00rgh i hate wizards). i downloaded LTR firmware/driver, the only file i could get at all. it showed an error saying "no drive detected!". thx a lot :rolleyes:

so please help me with this cuz its driving me crazy :uhoh:

cu :cya:




SteVen

"World's Best Boss"

50 XP

14th August 2004

0 Uploads

3,254 Posts

0 Threads

#2 12 years ago

A new CD drive isnt very expensive, i dont think you can get the driver back by downloading them....You would probably have to system repair which would get rid of EVERYTHING :uhoh:. Hell, heres a new CD-rom drive for 14 bucks http://www.newegg.com/Product/Product.asp?Item=N82E16827134004




rob.

I am the Walrus

50 XP

24th October 2004

0 Uploads

5,580 Posts

0 Threads

#3 12 years ago

I never even thought of needing Rom drivers.

Try unplugging it, and plugging it back in.




Agentlaidlaw

Pie

50 XP

21st February 2005

0 Uploads

3,801 Posts

0 Threads

#4 12 years ago

Kommandant RoβI never even thought of needing Rom drivers.

Try unplugging it, and plugging it back in.

That should work.... If not, reformat be your last thing to do.




Nice Guy

Trimming bushes. Since 1992.

50 XP

30th December 2004

0 Uploads

318 Posts

0 Threads

#5 12 years ago

nah im not buying a new drive, i'm just looking for a way to fix the old ones. i'll try to unplug and plug it again, otherwise i'll just stick with floppy and USB for the next 2 months, till the reformat. although, are u sure there's no other way to fix it?

thx anyway




eMp[T]y

I guess i like dead people

50 XP

12th April 2006

0 Uploads

79 Posts

0 Threads

#6 12 years ago

I don't know why everyone results to buying a new part. Just try what Rob suggested. If not unistall the driver from System > Device Manager > CD Rom(s) > Unistall Driver. Also did you check out this http://www.driverskit.com/freedownload/Firmware/LiteOn/LTR-48246K_CD-Rw_SK0A/13701.html http://www.teac.co.jp/dspd/download/firmware/cd-w540e/explain.html Let us know if anything worked. eMp[T]y




Nice Guy

Trimming bushes. Since 1992.

50 XP

30th December 2004

0 Uploads

318 Posts

0 Threads

#7 12 years ago

nevermind, it looks like it fixed itself (WTF?!) lol thx for help anyway.




Bs|Archaon

I would die without GF

50 XP

15th March 2006

0 Uploads

5,910 Posts

0 Threads

#8 12 years ago

You'll find it's very hard to actually remove that kind of thing from Windows, chances are all it needed was to detect the hardware again, eg through a reboot or whatever.