Extreme Sound Issue.. 10 replies

  • 1
  • 2

Please wait...

SteVen

"World's Best Boss"

50 XP

14th August 2004

0 Uploads

3,254 Posts

0 Threads

#1 11 years ago

I recently bought a new sound card, this one to be exact.

http://www.creative.com/products/product.asp?category=209&subcategory=669&product=15854

Mostly for the games that I own...The problem is though there is an extremely loud and annoying screeching and static noise that comes and goes at random and wont go away unless I exit out of whatever program the noise started up in. I had this same problem with my old Sound Card but never acted up as random as this one now and was no where near extreme as this screeching and static I'm getting now. The wierd thing is the static and screeching has never come up at all during games (which sound totally fantastic btw). So I find this very strange..I've tried putting it in a differen't PCI slot with no effect at all and have reinstalled the drivers it came with many times. And have tried MANY differen't speakers and headphones....can't count how many I've gone through. The only guess I can have is something is interefering with the sound card but I have no idea what....I've tried everything I can think of. Please help.




The-Bleh-Bleh

Hasselhoff is my hero

50 XP

12th December 2006

0 Uploads

6,189 Posts

0 Threads

#2 11 years ago

Weird. I remember the same thing happen to someone elses computer, but only in games. It went away after a day though... it was weird. What kind of programs does it mess up in?




Chris

I pretend I'm cooler than AzH

50 XP

20th February 2006

0 Uploads

5,663 Posts

0 Threads

#3 11 years ago

My mp3 player does it to my speakers, but not to my headphones.

Have you updated the sound drivers?




SteVen

"World's Best Boss"

50 XP

14th August 2004

0 Uploads

3,254 Posts

0 Threads

#4 11 years ago

Sorry for late reply. The programs the sound acts up in are totally random....But most of the time it happens when I have more than 1 program up. It will somtimes act up in IE7 trying to watch a video....Sometimes while I'm downloading, its just very random. I've checked the website for new drivers on the card....it looks like the drivers the card came with is all they have *click*. The only thing I can think of is something outside or inside of my PC is interefering with the sound....but if something was wouldnt it be screeching and making static noise all the time? I dont know what to try/do.




Bs|Archaon

I would die without GF

50 XP

15th March 2006

0 Uploads

5,910 Posts

0 Threads

#5 11 years ago
masterstevenx4;3538353The only thing I can think of is something outside or inside of my PC is interefering with the sound....but if something was wouldnt it be screeching and making static noise all the time? I dont know what to try/do.

No. Mobile phones, for example, only create that much interference when they're sending or receiving something; for example if you receive a text message your speakers will usually act up a few seconds before your phone rings.




UNDIESRULES

Waffle-Sprocket is broke

11,795 XP

24th November 2003

0 Uploads

1,097 Posts

0 Threads

#6 11 years ago

I teach telecommunications as part of my work and it could be a phenomenon known as RFI/MEMIC whereby one of the fans or components inside the case is the problem.




SteVen

"World's Best Boss"

50 XP

14th August 2004

0 Uploads

3,254 Posts

0 Threads

#7 11 years ago

I just unplugged most of my fans and tested the sound...still acting up. The only fans I didnt unplug is the one in the PSU and the one on top of my CPU.




RSXHiTMAN

I don't spend enough time here

50 XP

15th February 2007

0 Uploads

18 Posts

0 Threads

#8 11 years ago

i have this problem too with my usb head phones, it starts like BASKDJAKSJDAKSJDASKDJ crazy ass noise then i usually have to exit it and restart it, usually happens in media player




SteVen

"World's Best Boss"

50 XP

14th August 2004

0 Uploads

3,254 Posts

0 Threads

#9 11 years ago

Anyone have any other suggestions? This static is getting annoying as hell.




Chris

I pretend I'm cooler than AzH

50 XP

20th February 2006

0 Uploads

5,663 Posts

0 Threads

#10 11 years ago

Have you made sure that the sound card is mounted correctly?




  • 1
  • 2