MySQL Service on Windows 7 0 replies

Please wait...

G.R.A.E.M.E. VIP Member

OW & HS Addict

178,776 XP

14th August 2008

0 Uploads

15,860 Posts

0 Threads

#1 8 years ago

Hey there,

Wasn't sure whether to post this here or in Web-Related stuff, as this is more related to the "behaviour" of Windows 7. So yeah, your call. ;)

Anyway, I downloaded MySQL server 5.1 today for some personal purposes. I installed MySQL without any problems and did the configuration without a problem as well - MySQL easily connected through port 3306 and allowed the MySQL service to startup. I noticed I did something wrong if it comes to my password, so I decided to remove the created instance and re-do the lot. However, it seems that things didn't go as good as I hoped, for it started to act "buggy".

I chose the usual options and did the correct password this time, but when it tried to startup the service (at the end of the configuration of my instance), the configuration window decided to stop responding all the sudden. I wondered why that happened, so I investigated a little. First, I thought it was due to some bugged entry in the registry, so I uninstalled MySQL, removed the registry entry through the use of registry defrag and deleted both my temporary files as well as the temporary ones in AppData.

I reinstalled the lot and tried once more, but no avail. The screen froze once more. I then went to task manager > services and saw that the MySQL service wasn't running at all. So, I right-clicked and tried to start the service, but it told me that the access to service was denied.

I Googled a bit and found out that I should use Super Administrator privileges. I enabled the account and tried to start the service, but it didn't work either. So, I wonder: is there any way I could allow the service to startup? I also read something about possibly changing the registry security parameter of the MySQL (though I'm not sure if I understood correctly) entry to SYSTEM and USER so the service could be accessed, but any idea how precisely? I don't want to mess up my registry and I didn't really find any good results on Google to solve this issue.

And on a side-note: I didn't install MySQL in Program Files on purpose, because from what I've heard is that Windows 7 (and Vista?) has a habit of being over-protective if it comes to writing/editing files within said folder.

Any help would be greatly appreciated.

[EDIT] Never mind. I can't believe I was this stupid. Seems I used version 5.1 instead of 5.5, so... it works now that I've got the latest version. Thanks anyway.[/EDIT]


Formerly known as Graeme and Arld.