nVidea Control Panel not loading 5 replies

Please wait...

Sgt.kar98

Back from the dead

50 XP

23rd November 2004

0 Uploads

1,505 Posts

0 Threads

#1 9 years ago

Hello guys,long time away from here! My nVidea 9600 GTX (9800 GT?) control panel is not loading anymore.Actually,it keeps loading forever. I believe it was because I was dumb enought to delete the nVidea Display files with Driver Sweeper and installing drivers again in a desperate attempt to fix an issue in GT IV. Anyone know if there's a file missing,if I will have to nuke my video card files and install all over again or...?




*The.Doctor

Trust me, I'm a Doctor

102,440 XP

25th November 2003

0 Uploads

9,964 Posts

0 Threads

#2 9 years ago

Try uninstalling your current drivers, run driver cleaner or driver sweeper, and install the newest version.




Sgt.kar98

Back from the dead

50 XP

23rd November 2004

0 Uploads

1,505 Posts

0 Threads

#3 9 years ago

ALL nVidea drivers,not only the Display,but PhysX and etc?




Supa

People say I post too much

50 XP

1st April 2009

0 Uploads

1,368 Posts

0 Threads

#4 9 years ago

Pretty sure that when you uninstall one set of Nvidia drivers, it uninstalls everything relating to Nvidia, so it will uninstall the PhysX drivers for you.




*The.Doctor

Trust me, I'm a Doctor

102,440 XP

25th November 2003

0 Uploads

9,964 Posts

0 Threads

#5 9 years ago

Yeah, PhysX is part of the Nvidia drivers. When you install the new drivers it will install the newest version of the PhysX drivers at the same time.




Sgt.kar98

Back from the dead

50 XP

23rd November 2004

0 Uploads

1,505 Posts

0 Threads

#6 9 years ago

Well,I reinstalled the drivers using the "Clean install".Nothing.Installed NET Frameword .4.No use. Any other ideas?