Windows 7 file sharing problems 10 replies

  • 1
  • 2

Please wait...

*The.Doctor

Trust me, I'm a Doctor

102,440 XP

25th November 2003

0 Uploads

9,964 Posts

0 Threads

#1 8 years ago

For some reason my Win 7 install refuses to set up a proper file sharing connection to my laptop running Vista. I can't get file sharing turned on, every time i go into the advanced sharing options and turn on network discovery and file sharing and click save changes, it never saves my settings. I can open it back up as soon as i click save and it still tells me that file sharing and network discovery are off. I've tried saving settings and logging off and even rebooting my it still tells me everything is disabled. I have file sharing and everything needed turned on under Vista on my laptop no problem.

Also, it can see the connection to my laptop and lists it as a "Unidentified network", and sets the location to public, which it will not let me change to home either. It also is screwing up the HomeGroup settings. I don't use HomeGroup, yet it won't let me change any sharing settings, or even let me leave the HomeGroup. It tells me "Windows cannot remove your computer from the homegroup", So i tried changing the password but it tells me "Windows cannot set up a homegroup on this computer". I was going to try connecting my Macbook but it won't let me either because all the Win 7 networking options are stuck.

Any ideas? I've never had this much trouble setting up a quick simple file sharing connection in my life. So far this is the first thing i'm disappointed in with 7, setting up a simple connection seems to have taken a step backwards from Vista.




Guest

I didn't make it!

0 XP

 
#2 8 years ago

Re-install windows I hopr it will help u.Thanks.




*Daedalus

A Phoenix from the ashes

50 XP

18th April 2006

0 Uploads

3,091 Posts

0 Threads

#3 8 years ago

I don't know what they are - Google would help there - but try disabling and re-enabling the relevent services. Might at least give you access to the Homegroup settings.

"livingandlearning" Re-install windows I hopr it will help u.Thanks.

I doubt it.




Mr. Pedantic

I would die without GF

234,620 XP

8th October 2006

0 Uploads

23,127 Posts

0 Threads

#4 8 years ago

Seeing as your Homegroup looks like it's there to stay, you could share through that.




*The.Doctor

Trust me, I'm a Doctor

102,440 XP

25th November 2003

0 Uploads

9,964 Posts

0 Threads

#5 8 years ago

I never did get it fixed.

I got my files copied though using the awesomeness that is OSX. I just manually connected to my PC (Finder > Go > Connect to Server) and entered my PCs IP address username and password. I had pretty much full access too, which was a little troublesome as Win 7 had no idea at all that my Macbook was even connected or copying files....

Seeing as your Homegroup looks like it's there to stay, you could share through that.

It won't let me change the sharing settings though.




Red_Fist

GF is my bext friend *hugs GF*

50 XP

28th April 2010

0 Uploads

1,004 Posts

0 Threads

#6 8 years ago

Make sure "Server" service is running, a few others as well.

And log on as administrator.

maybe run gpedit.msc take a look.




Mr. Pedantic

I would die without GF

234,620 XP

8th October 2006

0 Uploads

23,127 Posts

0 Threads

#7 8 years ago
It won't let me change the sharing settings though.

You don't have to, do you? Libraries in your Homegroup are shared by default I think, you just have to add a new library. That's what I did, not 3 days ago.




*The.Doctor

Trust me, I'm a Doctor

102,440 XP

25th November 2003

0 Uploads

9,964 Posts

0 Threads

#8 8 years ago

Red_Fist;5421800Make sure "Server" service is running, a few others as well.

And log on as administrator.

maybe run gpedit.msc take a look.

My user account is admin, and i just looked and "server" is running.

gpedit.msc does nothing though, besides tell me its not a proper command.

Libraries in your Homegroup are shared by default I think, you just have to add a new library. That's what I did, not 3 days ago.

That's what i'm trying to say though, it won't let me add a new library at all.




Nemmerle Forum Mod

Voice of joy and sunshine

298,627 XP

26th May 2003

0 Uploads

28,166 Posts

6 Threads

#9 8 years ago

From an elevated CMD prompt (run as administrator)

[INDENT]Net stop p2pimsvc /y[/INDENT]

Go to the following folder and delete all the files inside C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking

Then run another elevated CMD prompt and

[INDENT]Net start p2pimsvc[/INDENT]

The gpedit.msc is not a command. Type it into the search box and run it that way. You're looking for

Computer Configuration\Administrative Templates\Windows Components\HomeGroup

See what the policy setting is.




Mr. Pedantic

I would die without GF

234,620 XP

8th October 2006

0 Uploads

23,127 Posts

0 Threads

#10 8 years ago
That's what i'm trying to say though, it won't let me add a new library at all.

Oh. Scrap that, then.




  • 1
  • 2