I Need Lots of Help Please : '( -1 reply

Please wait...

NoobProgrammer2004

I don't spend enough time here

50 XP

24th January 2004

0 Uploads

28 Posts

0 Threads

#1 14 years ago

Well my Friend and I have been Trying to Compile my Mod to test it out. But we get a error not allowing us to compile it similair to this list: In file included from ../game/bg_lib.c [Warning] ignoring #pragma warning [Warning] ignoring #pragma warning [Warning] ignoring #pragma warning [Warning] ignoring #pragma warning [Warning] ignoring #pragma warning [Warning] In function `qsort': argument `a' doesn't match prototype prototype declaration [Build Error] [../game/bg_lib.o] Error 1 So if you can any Tutorials(:deal: ) it Would be Greatly Appreciated, I Would Put a Large Thanks to You in My Mods Readme File :nodding:

Thanks Again ~noobProgrammer2004[ :type: ]




[BM]Subterfuge

The Internet ends at GF

50 XP

20th July 2003

0 Uploads

123 Posts

0 Threads

#2 14 years ago

What are you trying to compile with? VC++? etc. Please be a lil more specific Sub




nUllSkillZ

GF Pwns Me!

50 XP

13th January 2004

0 Uploads

53 Posts

0 Threads

#3 14 years ago

Hi, theres a tutorial (english) for compiling the source with Microsofts Visual C++ Version 6. You can find it here. If you use another compiler here are some other links you may find useful: RTCW Source Package for Linux Who has actually used and have working DevC++ v4 and compiles I think to avoid the error you have to exclude "game/bg_lib.c" from compiling. Edit: I've written some tutorials (in german language): First one is a translation of the first link. Second one is a tutorial about compiling with the free available IDE dev-c++ V 4 mainly a summarize of the second and third link.




NoobProgrammer2004

I don't spend enough time here

50 XP

24th January 2004

0 Uploads

28 Posts

0 Threads

#4 14 years ago

Thanks for the links! I'm using Dev-C++ v5 beta or wutever it is, at www.bloodshed.net . I'm going to try your tutorials now. do oyu have aol im? I'd rather talk instantly to you then wait for your replies =D.




NoobProgrammer2004

I don't spend enough time here

50 XP

24th January 2004

0 Uploads

28 Posts

0 Threads

#5 14 years ago

If You could Translate Your Tutorials It Would Be Appreciated =D I Don't Speak German or read It for the Matter lol.




nUllSkillZ

GF Pwns Me!

50 XP

13th January 2004

0 Uploads

53 Posts

0 Threads

#6 14 years ago

I will try to translate. But what I found in some other links (also in the PlanetWolfenstein Forum Modifications actual and archives) is that it is not possible to compile with dev-c++ V5. At the moment I'm trying to add a new class.




NoobProgrammer2004

I don't spend enough time here

50 XP

24th January 2004

0 Uploads

28 Posts

0 Threads

#7 14 years ago

Sounds cool, and What version Should I Download To Compile the Mod? ~Noobprog~:type:




nUllSkillZ

GF Pwns Me!

50 XP

13th January 2004

0 Uploads

53 Posts

0 Threads

#8 14 years ago

I used Version 4 with update to Version 4.01.




NoobProgrammer2004

I don't spend enough time here

50 XP

24th January 2004

0 Uploads

28 Posts

0 Threads

#9 14 years ago

Hmm...I Don't Know What I'm Doing Sine i cant Read The German Stuff...lol When Will Translation Bee Done? If you do it? thx for all the help...everyone, I'm getting farther and farther but slowly :naughty:

~noob...again~




NoobProgrammer2004

I don't spend enough time here

50 XP

24th January 2004

0 Uploads

28 Posts

0 Threads

#10 14 years ago

Yo Null, You have Been Very Helpful, I Just Need A Simple Tutorial. I Have Made The Projects And Have All The Files In Them, I Need A Tutorial On What To Do Next, If It's Not Too Much, Thx for the Previous Help :clap: