no light -1 reply

  • 1
  • 2

Please wait...

boner

The Internet ends at GF

50 XP

29th July 2002

0 Uploads

118 Posts

0 Threads

#1 18 years ago

i haev absolutely no light being emitted on my map, i run it , and can tell its my map, not just some default room, cuz i throw smoke cans and can see dimensions of things, any help, sorry for breifness, i hung those light things from cieling, and made the value 700, the little diamonds, yet i still have no light, thanks for the help




Tikkit

Slightly cooler than a n00b

50 XP

5th June 2002

0 Uploads

31 Posts

0 Threads

#2 18 years ago

A little more info would help.

Which compile option did you use in the BSP menu?

Are you getting any error messages when you scroll back though your console log?

If your room is very large, don't hang the lights from the ceiling, bring them down to where your player is and put them a few grid units off the floor. Make sure lights are in open space and not pushed into a wall or other brush. Then you can see the effect of the light and adjust them accordingly. Also, the default 300 value for lights is plenty.

Make sure you are using "lights" and not light "juniors".

Try adding a "sky" shader to the ceiling. Use a sky selection that has a white box around the picture in the texture menu. If there's no white box, then it means the sky is just a "texture", and NOT a shader. Your need a sky SHADER to emit light.

Simply as a test, you might want to use a compile option like bsp, -vis -fast, (with no light option), this way it will default to "fullbright". (Your map will be bright, but you won't get any effects of lights, such as shadows.)

If you have tried any of these things, it would be good to know so we can help you better.

Good luck.

TikkiT




Kenkenif!

GF makes me horny

50 XP

11th January 2003

0 Uploads

81 Posts

0 Threads

#3 18 years ago

i think you are using the "BSP" option when you should use "BSP vis" or some others to actually see your lights....and have you inserted light? (dont know how experienced you are) anyway...leave more info...




boner

The Internet ends at GF

50 XP

29th July 2002

0 Uploads

118 Posts

0 Threads

#4 18 years ago

well i compile it in wolfcompile, i dont know how it compiles it, that way i just go to file then run in wolfcompile, i dont know how to run it without doing that junk, someone please help me run it without goin thru wolfcompile




Tikkit

Slightly cooler than a n00b

50 XP

5th June 2002

0 Uploads

31 Posts

0 Threads

#5 18 years ago

OK, boner,

Sorry, I don't know anything about wolfcompile at all.

Somehow you need to figure out what your compiling string, (command line), looks like. You may not be lighting your map at all. I'll stay out the way here, cause I don't use wolfcompile.




Kenkenif!

GF makes me horny

50 XP

11th January 2003

0 Uploads

81 Posts

0 Threads

#6 18 years ago

YOU CAN ALSO COMPILE IN GtkRadiant!!!!! press BSP on the top menu bar.....then choose BSP vis and thats it....you can also go to preferences and then to the last option in the list and check "Launch game after compiling" that way the game AUTOMATICLY runs the map after you compiled it.....much easier :)




omnix32

The forums staffers think I'm Cool

50 XP

11th February 2002

0 Uploads

184 Posts

0 Threads

#7 18 years ago

Well, light has nothing to do with the vis compile options. What version of q3map are you using and what version of GTKRadiant are you using??

Light at 700 are very bright, What is the name of the light entity are you using ?




Kenkenif!

GF makes me horny

50 XP

11th January 2003

0 Uploads

81 Posts

0 Threads

#8 18 years ago

I'm using GtkRadiant-1.2.11 and that BSP -vis option ALWAYS works with me....or maybe you should choose some other BSP option.....anyways when you insert light? you get the qeustion how much light you want.......how much do you typ in? caus if you have 700 at EVERY light then you wont be able to see any lights just because everything is TO bright.....oh and can you make a screenie of how your map looks like after you compiled it? (in-game) maybe that will help.......

sorry for my poor english:uhm:




prime8

I'm too cool to Post

50 XP

18th January 2003

0 Uploads

1 Posts

0 Threads

#9 18 years ago

i am having a similar problem. it usually happens after using the "freescaling" tool. i replace all of the spawn points, and i am using "bsp vis fast light extra" to compile. i sometimes get an error that says max_map_light exceeded. i dont have any lights on my map, but can usually see everything because of the compiling option i use.




boner

The Internet ends at GF

50 XP

29th July 2002

0 Uploads

118 Posts

0 Threads

#10 18 years ago

bwahahahaha its alive!!! works now, i have light!!!




  • 1
  • 2