BF freezes up pc -1 reply

Please wait...

[CC] Chief

Last of the Mohicans...naah

50 XP

18th July 2002

0 Uploads

429 Posts

0 Threads

#1 15 years ago

Ok I played the BF42 demo without problems and the same goes for the BF42 full version.

However lately I suddenly get a lot of moments where BF42 simply freezes up my pc: I cant even use alt-tab or ctrl-alt-delete and have to manually reboot my machine.

Its not my system itself because any other game runs fine: Neverwinter Nights, Warcraft 3, CS, Day of Defeat etc all give no problems.

Has anybody ever had this problem and if so what did you do to fix it? I have allready reinstalled and repatched BF42 and that didnt work.

I use a GF4 4200 and SB 128 PIC, for the rest standard SDR memory (640 mb), 1,3 Ghz processor.

If anybody could post a reply if you know something that might help it would be appreciated!!




tdsmm

I'm too cool to Post

50 XP

3rd January 2003

0 Uploads

2 Posts

0 Threads

#2 15 years ago

I had the same problem. I bought a sound card and switched from win xp pro to 98se and it fixed it.




apocalypse_kid

I would die without GF

50 XP

20th May 2002

0 Uploads

5,498 Posts

0 Threads

#3 15 years ago

Hi [CC] Chief,

While it may be true that you can play many other games with no problem most of the games you mentioned are not very demanding on your vid card (relatively compared to BF1942 that is). There are many ppl who have had freezing problems cause the vid card has overheated and locked up. which seems it may be likely here cause yours was running fine previously.

Try borrowing a different vid card, or even pulling side of case and pointing desk fan at vid card for more cooling, an see if that fixes it.

Good luck

:cya: :cya: :cya:




OpTikN3Rv

Dread pwns me!

50 XP

5th August 2002

0 Uploads

433 Posts

0 Threads

#4 15 years ago

Also check the slots u have each card in.. AGP-PCI 1 share PCI 2-PCI 3 share PCI 4-PCI 6 Share PCI 5 is alone

windows xp likes to stick network cards, soundcards and Graphics cards all on same IRQ 11

Usually you'll be ok but in games like BF that rape video and soundcards this can cause instability.Try Soundcard in PCI 5 and if it still gets same IRQ assigned try forcing it in bios to a free IRQ.




[CC] Chief

Last of the Mohicans...naah

50 XP

18th July 2002

0 Uploads

429 Posts

0 Threads

#5 15 years ago

Thx for the help lads but......

1. I have Windows 98 SE, not the atrosity MS calls winXP :)

2. I have an Antec miditower with 3! additional fans so heat is definitely not the issue here. This is of course seperate from the fact that the GF4 itself has a cooler the size of a ceilingfan :)

3. Maybe its the sound or vid card driver?




apocalypse_kid

I would die without GF

50 XP

20th May 2002

0 Uploads

5,498 Posts

0 Threads

#6 15 years ago

Well it certainly sounds like you have enough cooling. BTW I ran BF1942 for many months on WinME with no problems - it all depends on how closely you monitor the health of your system. it is possible to get WinME running good. Also Win XP Uses a HAL (Hardware Abstraction Layer) to handle IO, it doesn't actually affect the way the hardware handles IRQ's, it just intercepts all the signals from the hardware interfaces and reroutes them through a software layer before passing the data to the GUI. The only PCI slot that generally gives trouble due to conflict is the AGP/PCI shared slot, so if you have any cards in that PCI slot (specially network cards, they are particularly troublesome) I suggest moving it.

So if you are sure it's not hardware (I mean really, really sure cause I have spent ages fiddling around with software only to find a faulty vid card or something similar), then it's time to,

A) Download latest Win98 drivers for everything - Vid Card, Sound Card, Motherboard etc and maybe update mobo bios to latest version.

B) Shut down all non-system apps or utilities, specially apps like MSN Messenger etc.

c) Test the game several times.

Now I have to ask again, cause it's rare that a purely software based problem will lock up your PC as you describe, are you sure it's not hardware related. The only time I have seen a PC lock up with BF1942 like you describe it was vid card related, and replacing that component fixed it, in your case it may be memory or vid card and as you say It may not be heat related at all, but I repair PC's for a living, and have seen many vid cards and DRAM sticks play up for no reason at all.

If you go through all software fixes - maybe even borrow a hard drive and do a clean install of win98 - and it still locks up - then it seems to me you have done a lot of work for nothing when a simple 5 minutes work to swap with a borrowed vid card or stick of DRAM may identify the problem.

Good luck [CC] Chief

:cya: :cya: :cya:




[CC] Chief

Last of the Mohicans...naah

50 XP

18th July 2002

0 Uploads

429 Posts

0 Threads

#7 15 years ago

Im sure its not the vidcard because Ive testplayed various demos and games, including for example Neverwinter Nights which is also hugely gfx intensive. And those games run fine.

However, checking up on the memory may be a solution. That I havent checked upon yet so it may definitely be worth looking into.

My question however is: if one of my memory sticks is flawed how come it doesnt affect win98? I have had a flawed memory stick before and that gave clear problems running different applications and games in windows, unzipping zip-files etc etc

Apart from the incidental crash that simply happens because windows has bugs I have had no errors in the last 3/4 of a year and win98 ran fine.

Thanks for the help btw!! :cya:




Herr Dickmeister

Addicted to GF

50 XP

15th August 2002

0 Uploads

264 Posts

0 Threads

#8 15 years ago

Hi,

first of all, correct me if I'm wrong here, but I thought Win 98 wasn't able to use more than 256 MB of RAM (so having 640 MB with win 98 is useless, I think)

Also, you say a 1,3 Ghz processor, but what kind? If you buy a budget Via processor, it's gonna give you problems.

Have you changed detonator drivers? Some versions apply 8X anisotropic filtering and 4x AA as a default, which looks great but is very hard on your system. The vid card can be cooled enough but it will cause the pc to lock up because it can't handle the filtering, specifically on large maps and spaces.

Do the lock ups only occur in MP? Maybe it's something with your connection then...




apocalypse_kid

I would die without GF

50 XP

20th May 2002

0 Uploads

5,498 Posts

0 Threads

#9 15 years ago

Hi Herr ****meister,

No, there is no practical limitation on using ram with Win98 (apart from the motherboard limit of course) however technical problems do crop up when you get over 512Mb to do with the Vcache settings that can cause systems to behave strangely. However [CC] Chief does have over 512 Mb so this could be causing the problem. There are several ways to fix it, I have extracted these from the Microsoft Knowledge Base Article (sorry it's so long but you know what MS is like - it's hard to get info out of them to start with, but when they do let loose - look out!)

"Out of Memory" Error Messages with Large Amounts of RAM Installed

-------------------------------------------------------------------------------- The information in this article applies to:

Microsoft Windows 98 Microsoft Windows 98 Second Edition Microsoft Windows 95

--------------------------------------------------------------------------------

SYMPTOMS If a computer that is running any of the versions of Windows listed above contains more than 512 megabytes (for example, 768 megabytes) of physical memory (RAM) installed, you may experience one or more of the following symptoms:

You may be unable to open an MS-DOS session (or command prompt) while Windows is running. Attempts to do so may generate the following error message:

There is not enough memory available to run this program. Quit one or more programs, and then try again. The computer may stop responding (hang) while Windows is starting, or halt and display the following error message:

Insufficient memory to initialize windows. Quit one or more memory-resident programs or remove unnecessary utilities from your Config.sys and Autoexec.bat files, and restart your computer.

CAUSE The Windows 32-bit protected-mode cache driver (Vcache) determines the maximum cache size based on the amount of RAM that is present when Windows starts. Vcache then reserves enough memory addresses to permit it to access a cache of the maximum size so that it can increase the cache to that size if needed. These addresses are allocated in a range of virtual addresses from 0xC0000000 through 0xFFFFFFFF (3 to 4 gigabytes) known as the system arena.

On computers with large amounts of RAM, the maximum cache size can be large enough that Vcache consumes all of the addresses in the system arena, leaving no virtual memory addresses available for other functions such as opening an MS-DOS prompt (creating a new virtual machine).

WORKAROUND To work around this problem, use one of the following methods:

Use the MaxFileCache setting in the System.ini file to reduce the maximum amount of memory that Vcache uses to 512 megabytes (524,288 KB) or less.

For additional information about how to use the MaxFileCache setting, click the article number below to view the article in the Microsoft Knowledge Base: Q108079 32-Bit File Access Maximum Cache Size Use the System Configuration utility to limit the amount of memory that Windows uses to 512 megabytes (MB) or less.

For additional information about how to use the System Configuration utility, click the article number below to view the article in the Microsoft Knowledge Base: Q181966 System Configuration Utility Advanced Troubleshooting Settings Reduce the amount of memory that is installed in your computer to 512 MB or less.

STATUS Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article

This may or may not help, but I hope it does.

God Luck

:cya: :cya: :cya:




Herr Dickmeister

Addicted to GF

50 XP

15th August 2002

0 Uploads

264 Posts

0 Threads

#10 15 years ago

:dance: All right apocalypse_kid! :rock: