Major problems -1 reply

  • 1
  • 2

Please wait...

w00t69

I'm too cool to Post

50 XP

19th January 2004

0 Uploads

7 Posts

0 Threads

#1 14 years ago

To start this off, I'd like to say it ran fine on this exact system before i formatted. Reformatted, fresh install of XP, sp1, dx 9.0b and latest drivers (though i have thus rolled back to catalyst 3.9). Now when I install bf1942, I first get the loading screen (little bf1942 square) then black screen and bam desktop. This is when it's version 1.0. So i update some patches, then it tells me when I try to start it up that I have an incorrect cd in the tray and to put in the correct CD. Now this is pissing me off, because I have the f00kin CD in the tray. :furious: Anyway system specs: Window Xp Professional (sp1, dx 9.0b, etc) 48x24x48 TDK burner Radeon 9800 pro (catalyst 3.9) 512 MB of pc3200 Abit NF7 v2.0 athlonxp 1700+ @ 2.2 ghz 80 gb maxtor Any help would be appreciated.




Marcavious

Cooler than Jesus

50 XP

16th December 2003

0 Uploads

5 Posts

0 Threads

#2 14 years ago

Try going here: [color=red]\Program Files\EA GAMES\Battlefield 1942\Mods\bf1942\Settings[/color] [color=black]Find and double click on the "VideoDefault" CON file and use notepad to adjust the "renderer.allowAllRefreshRates" from 0 to 1.[/color] I experienced the same problem the last time I formated using XP. Hope this helps




w00t69

I'm too cool to Post

50 XP

19th January 2004

0 Uploads

7 Posts

0 Threads

#3 14 years ago
MarcaviousTry going here: [color=red]\Program Files\EA GAMES\Battlefield 1942\Mods\bf1942\Settings[/color] [color=black]Find and double click on the "VideoDefault" CON file and use notepad to adjust the "renderer.allowAllRefreshRates" from 0 to 1.[/color] I experienced the same problem the last time I formated using XP. Hope this helps

Still crashes to desktop. Man this sucks. I dunno what to do with this crap lol. There was no mods/bf1942 folder, so i just went to settings. And there was no renderer.allowAllRefreshRates, I had to add it. And no, that didn't fix it.




ScOrPY VIP Member

Advanced Member

50 XP

17th November 2003

0 Uploads

15,582 Posts

0 Threads

#4 14 years ago

go into BF folder C:\Wateva its in\Battlefield 1942\Mods\bf1942\Settings and the file is there :)




w00t69

I'm too cool to Post

50 XP

19th January 2004

0 Uploads

7 Posts

0 Threads

#5 14 years ago

dude i said i did that. I edited it and it still doesn't work. Just crashes.




apocalypse_kid

I would die without GF

50 XP

20th May 2002

0 Uploads

5,498 Posts

0 Threads

#6 14 years ago

Hi w00t69,

This is where the VideoDefault.con file SHOULD be found.

C:\Program Files\EA GAMES\Battlefield 1942\Mods\bf1942\Settings

If the folder structure is not like this then your BF version either hasn't been updated to the latest version or the updating screwed up somehow. The earliest version of BF (1.1 and 1.2 I think) had a folder structure the way you describe, so it looks like it is an installation problem, you may have missed one of the update patches or put them in the wrong order or something. Also if you installed any of the new mods without updating that will make BF do what you describe. I suggest a uninstall, delete old BF folders, re-install, update with the BF full 1.5 patch, then install mods etc.

Oh yes, and then check the VideoDefault.con file.

Good luck

:cya: :cya: :cya:

:smokin:




w00t69

I'm too cool to Post

50 XP

19th January 2004

0 Uploads

7 Posts

0 Threads

#7 14 years ago

Did this already. How are you helping me when you keep telling me to do the same thing over and over. And patches... yeah don't do anything. I've gone all the way up to 1.5. The main problem right now I got is this: I go to get into the game and it tells me I have an incorrect cd in and to insert the correct cd (it is the correct legit cd that is in the tray). So i'm not sure what to do here. I've tried uninstalling/reinstalling (after cleaning out the registry and folders etc) to no avail. And yes, I have an old version of bf1942 (it's a version 1.0 cd) But this time, I installed it with my brothers' copy (i believe it's 1.3) and instead of crashing when booting, it asks me for my cd to be inserted (it is...). That's about it for now.




apocalypse_kid

I would die without GF

50 XP

20th May 2002

0 Uploads

5,498 Posts

0 Threads

#8 14 years ago

There are a number of things that can cause the incorrect CD thing. One of the problems with the incorrect cd message is the CD drive itself. With some CD drives BF won't recognise the BF CD unless it is in the CD drive when the computer starts. If you try installing it after the computer starts it doesn't pick it up properly. Another problem is if you have installed BF then made some changes that affected the drive letters of your various drives and changed the drive letter of the CD drive from say D: to E:. BF records the path of the installation drive in the registry, and if it is different from the actual drive letter that the disk is in it can cause problems. You can fix that by editing the entry in the registry so that it matches the drive. There was also a bug with one of the early versions that caused this problem no matter what you did. That's why I suggest upgrading to 1.5 with the ful 1.5 patch, that has many fixes.

The "renderer.allowAllRefreshRates" fix doesn't work for earlier version of BF, it was added to fix problems, try resetting the refresh rate of your monitor to 60hz and see if BF starts, if it does it is the refresh rate problem, if not then it is something else. But try my earlier suggestions for fixing the CD problem first.

Good luck

:cya: :cya: :cya:

:smokin:




millerman sr

I'm too cool to Post

50 XP

23rd January 2004

0 Uploads

6 Posts

0 Threads

#9 14 years ago

[COLOR=RED] While your suggestion is probably done for all the correct reasons, the subject you are raising is a banned subject, please don't do it a again, a repeat offense could result in another banning. Yours AK [/COLOR]




w00t69

I'm too cool to Post

50 XP

19th January 2004

0 Uploads

7 Posts

0 Threads

#10 14 years ago

putting my monitor to 60 hz??? Sweet jesus, my eyes will burn out of my skull.




  • 1
  • 2