Help With The Sims 2, Please! -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 14 years ago

I received The Sims 2 as an early Christmas present, and was very excited to finally be able to play this highly anticipated game. I installed it completely, went to play it, and received this error message: Failed to initialize Direct3D. Please make sure DirectX9.0c has been installed on this system. The application will now terminate.

I went into the DirectX Diagnostic to see what could possibly be wrong. I discovered that I have DirectX9.0b, so I went to the Microsoft website to download DirectX9.0c. I downloaded it, went to install it, and received yet another error message.

Another thing I found is that my AGP Texture Acceleration is not available, and it needs to be enabled. Is there any way I could do that?

Any feedback on this would be greatly appreciated. Thank you! :)




Aeroflot

I would die without GF

169,400 XP

2nd May 2003

0 Uploads

15,205 Posts

0 Threads

#2 14 years ago

I have the same problem, except with my C&C Generals. You have to have a video card that supports direct3d. Direct3d is a program that allows you to operate the 3d graphics in a game. Now, all I can suggest is, is to buy a new video card that supports direct3d.

Now, this is of course assuming that your video card doesn't support direct3d.




Guest

I didn't make it!

0 XP

 
#3 14 years ago

Direct3D seems to be supported. I did the test for it, and everything worked well. Thanks for your reply! :)




Guest

I didn't make it!

0 XP

 
#4 14 years ago

I'm still having problems, though. Any other ideas?




Aeroflot

I would die without GF

169,400 XP

2nd May 2003

0 Uploads

15,205 Posts

0 Threads

#5 14 years ago

WHat version of windows do you have?




Guest

I didn't make it!

0 XP

 
#6 14 years ago

Windows XP Home Edition




Guest

I didn't make it!

0 XP

 
#7 14 years ago

i just joined b/c i have the same problem. i have a laptop that i am trying to run Sims 2 on...its extremely slow and very frustrating...seems to get hung up alot. i have tried to disable all the things running in the back ground and also ensured that my graphics card is up to par. I am still not certain about the later issue, but can tell you that i am running Windows XP on a Toshiba A25-S307 with a graphics card named: Trident CyberAlladin -p4 bit graphics accelerator; BitBLT hardware; Alpha-blending, Direct 3D and OpenGL support; 32 MB external DDR video memory (that was enough to type!). This is really frustrating...when i installed it, the program said i had sufficient memory, etc. for the program. Any help would be greatly appreciated. Rach




Aeroflot

I would die without GF

169,400 XP

2nd May 2003

0 Uploads

15,205 Posts

0 Threads

#8 14 years ago

I think it's your lap top. I have a lap top also, and I cannot run alot of games.




Selura

Succubus

50 XP

10th November 2004

0 Uploads

220 Posts

0 Threads

#9 14 years ago

alot of people seem to have this problem. did you contact ea? go to the sims website and download the patch, that might help. also, look around the website for tips, thre is alot of info on the bbs. also, their is a tech support page. hope you get it fixed, its a great game.




Donavan

I am the only one who is actually cooler than AzH

50 XP

10th August 2004

0 Uploads

5,934 Posts

0 Threads

#10 13 years ago

Moved