Sims 2 Graphics and Game Play Problems -1 reply

Please wait...

Devryl

o.O

50 XP

27th September 2006

0 Uploads

12 Posts

0 Threads

#1 14 years ago

Here's a weird (and somewhat long) one for you ... I installed the new game last night and everything seems to work find until I get to the actual game play. All screens are beautiful, run well and smoothly and even in the very beginning stages of the process nothing is wrong. Then the play screen starts ... My Video card should be find as it asks for a Radeon 7200 or higher and mine is a 7500. (Yes, I know I should have something better into the 9000's) But if you look at the images over the main (play) screen they all look fine. This also happened to me with Sim City 4, but with no other Maxis game. Please for the love of God help me if you can. I'm dying to play! :cry:




Eagle One

:-D

50 XP

22nd December 2003

0 Uploads

2,992 Posts

0 Threads

#2 14 years ago

i havnt got this game yet, will be getting it tomorrow, so im not sure, but id say that if you can lower the graphical settings, textures, effects and things like that to low, low, low ect, then do so. can i just ask one question about the game, can you knock at peoples houses?




xgamerx

Willy Wonka ate my chocolate

50 XP

7th July 2003

0 Uploads

100 Posts

0 Threads

#3 14 years ago

Yes, just mess around with all your settings for textures...




y2k_37

W o r d.

50 XP

13th July 2003

0 Uploads

55 Posts

0 Threads

#4 14 years ago

trust me on this... go to the ATI website and download the latest drivers... and install DirectX 9.0c ... the 9.0b's a piece of s**t.




sohvicelord

The Internet ends at GF

50 XP

4th September 2004

0 Uploads

106 Posts

0 Threads

#5 14 years ago

to fix your problem turn down your setting on your video card. if you at high performance, turn it down to the next level performance. this should fix your problem, if still no luck go down to it works