Custom Sounds -1 reply

  • 1
  • 2

Please wait...

shimano55

AoE3 Files Vice *****

50 XP

23rd November 2003

0 Uploads

1,462 Posts

0 Threads

#1 14 years ago

I am trying to make a new unit for Age of Mythology, and to do that I need to use a sound that I got off the internet. I have inputed the sound into the soundsets-xpack.xml and the soundsets.xml. I have also inputed the sound into the anim file for the unit. But when I start up the game, the sounds don't work. Can anyone give me a hand?




coolsk8r32

NEW USERNAME: EyeOfTheTiger5

50 XP

3rd May 2003

0 Uploads

1,394 Posts

0 Threads

#2 14 years ago

you need to type in the Sound SET name in the anim file, not the sound filename for it to work




shimano55

AoE3 Files Vice *****

50 XP

23rd November 2003

0 Uploads

1,462 Posts

0 Threads

#3 14 years ago

I did.

Here is that section:

//============================================================================== anim RangedAttack { SetSelector none { set hotspot { version { Visual Scenario N Pirate Ship_attackA ReplaceTexture naval e pirate ship/Black Pearl //-- auto generated by the bang animation tool //-- do not hand edit these values tag Attack 0.40 true tag SpecificSoundSet 1.0 false pearlfire checkVisible //-- end auto generated section Connect ATTACHPOINT rippleidle hotspot Connect ATTACHPOINT smoke hotspot } } } }

//==============================================================================




coolsk8r32

NEW USERNAME: EyeOfTheTiger5

50 XP

3rd May 2003

0 Uploads

1,394 Posts

0 Threads

#4 14 years ago

the name of the SoundSet in SoundSets-xpack.xml is pearlfire??? or is that the name of your filename of that sound




shimano55

AoE3 Files Vice *****

50 XP

23rd November 2003

0 Uploads

1,462 Posts

0 Threads

#5 14 years ago

The file is named pearlfire.wav and the sound in the soundset-xpack is pearlfire.




coolsk8r32

NEW USERNAME: EyeOfTheTiger5

50 XP

3rd May 2003

0 Uploads

1,394 Posts

0 Threads

#6 14 years ago

could you paste the soundsets.xml data for that sound here?




shimano55

AoE3 Files Vice *****

50 XP

23rd November 2003

0 Uploads

1,462 Posts

0 Threads

#7 14 years ago

sure

here it is:




coolsk8r32

NEW USERNAME: EyeOfTheTiger5

50 XP

3rd May 2003

0 Uploads

1,394 Posts

0 Threads

#8 14 years ago

hmm that looks good now paste the anim attack section




shimano55

AoE3 Files Vice *****

50 XP

23rd November 2003

0 Uploads

1,462 Posts

0 Threads

#9 14 years ago

i already did

post #3




coolsk8r32

NEW USERNAME: EyeOfTheTiger5

50 XP

3rd May 2003

0 Uploads

1,394 Posts

0 Threads

#10 14 years ago

well i think there's a problem... here: tag SpecificSoundSet 1.0 false pearlfire checkVisible the number's way to big, prolly wont work - change the number to .01 instead of 1.0




  • 1
  • 2