Editor problems -1 reply

Please wait...

Mason42

I'm too cool to Post

50 XP

19th April 2004

0 Uploads

4 Posts

0 Threads

#1 14 years ago

Hi. So I've made a scenario, but I can't get it to work right. If I choose the "playtest scenario", only player 2 appears to have it's AI activated. I chose the default AI from the player screen, but only one works for some reason. If I go back to the main menu and try to load the scenario I've made to play it, none of the AI's are active AND I seem to be a third party observer, with no control over player 1 (or any other) despite it being set to "human" control. The others are set to CPU. Am I doing something wrong? Or is it just messed up?




Ashatay

.I.Am.Too.Cool.To.Post.

50 XP

25th May 2003

0 Uploads

6,490 Posts

0 Threads

#2 14 years ago

seems like the only problem is that you messed up with game settings, if not you might have a messed up ai file so reinstalling might work.




t0m

.!?

50 XP

30th January 2004

0 Uploads

3,207 Posts

0 Threads

#3 14 years ago

Default AI does practically nothing except build its way up from the ground. Then it attacks you hours later. Download a suitable AI for your map.




Ashatay

.I.Am.Too.Cool.To.Post.

50 XP

25th May 2003

0 Uploads

6,490 Posts

0 Threads

#4 14 years ago
Mason42

I'm too cool to Post

50 XP

19th April 2004

0 Uploads

4 Posts

0 Threads

#5 14 years ago

O.K. So I reinstalled the game, updated, and it still didn't really work right. I tried a new .scn file and had better luck. I think the first one was corrupted somehow. So now everything works... sort of. The computer players will not expand beyond their original town center. (I am using the enhanced AI now, but no effect) Everything else seems to be o.k., but the A.I. simply will not upgrade settlements. Any tips?




mharbourgirl

Warning!! Known to use irony!

50 XP

25th March 2004

0 Uploads

13 Posts

0 Threads

#6 14 years ago
Mason42 The computer players will not expand beyond their original town center. (I am using the enhanced AI now, but no effect) Everything else seems to be o.k., but the A.I. simply will not upgrade settlements. Any tips?

I hope someone has some tips, because this happens to me too, in scn's that I create. The default AI will upgrade, but not expand, even if spare settlements are a few steps away. The battlemachine AI I download is very aggressive (fun!) but still won't expand either.




Ashatay

.I.Am.Too.Cool.To.Post.

50 XP

25th May 2003

0 Uploads

6,490 Posts

0 Threads

#7 14 years ago

interesting, i've never noticed that. maybe if you have the difficulty set too low?