DirectIP probs -1 reply

Please wait...

Anakin_holland

I'm too cool to Post

50 XP

6th September 2003

0 Uploads

4 Posts

0 Threads

#1 16 years ago

Hello every1! I've got a problem with playing AoM 1.06 online with a friend of mine.

We both have a situation like this:

PC (192.168.1.100) -> (192.168.1.33) NAT-router (x.x.x.x) -> Internet

Problem is, we can't connect to one another... We both get the time-out screen of 15 seconds, after that, we get message: "could not join game at given address. Please try another." Offcourse one of us had started LAN/DirectIP -> Host at that time...;)

I've been reading on the internet about playing online, behind a NAT-router, and some sites gave interesting info, like opening/forwarding UDP ports an TCP ports on NAT-router. This didn't help. I red something about a aom.exe-parameter, being OverrideAddress="x.x.x.x" (x.x.x.x should be replaced with external IP-adres). I get to see the IP-adres as a Alternative Adres when I enter the LAN/DirectIP-screen. But is doesn't resolve te problem.

Also tried putting both PC's in our DMZ's, but that didn't help either... As a last resort we even disabled our firewalls... Not resolved...

Does anyone have a solution to my problem??

Thnx for the effort!




Ashatay

.I.Am.Too.Cool.To.Post.

50 XP

25th May 2003

0 Uploads

6,490 Posts

0 Threads

#2 16 years ago

firewall?




Anakin_holland

I'm too cool to Post

50 XP

6th September 2003

0 Uploads

4 Posts

0 Threads

#3 16 years ago
Ashatayfirewall?[/QUOTE]Thnx... But... [quote="Anakin_holland"]As a last resort we even disabled our firewalls... Not resolved...



Ashatay

.I.Am.Too.Cool.To.Post.

50 XP

25th May 2003

0 Uploads

6,490 Posts

0 Threads

#4 16 years ago

shouldv'e mentioned that when i saw what your problem is i didn't read the rest because i get so many people who ask me what's wrong when it's just thier firewall




Anakin_holland

I'm too cool to Post

50 XP

6th September 2003

0 Uploads

4 Posts

0 Threads

#5 16 years ago

Np... Usually i'm on the other side of the question, but this one, I just can't seem to crack... :confused:

On the internet I've red a lot of pages about playing online, but I just can't seem to get it to work... As for my previous post, as we both put our PC's in the DMZ, and disable our firewalls, there shouldn't be anything left to configure??

But there's a difference between this FAQ and Microsoft... We tried setting up a VPN-connection, which worked fine after half an hour of reading...

But after that, I was beaten... We could ping eachother, and if one of us started the host, the other could see the game in LAN-envirement, but when we tried to connect, it just gave the message: "Attempting connection". After the time ran out, it jumped back to LAN/DirectIP screen. This probably has got something to do with me getting a notification from my firewall that AoM.exe wants to broad-/multicast UDP-packets to 255.255.255.255. And the VPN-connection, as it should, doesn't support multicast...

In the readme for OpenVPN, there's a chapter about multicasting, and how to activate that by installing a bridging-function. But the actions that should be taken don't apply to my system. there simply not there...

Maybe you van help me out? Greetz!!




Anakin_holland

I'm too cool to Post

50 XP

6th September 2003

0 Uploads

4 Posts

0 Threads

#6 16 years ago

Well, thanks to everyone that put some time in this, but we solved is ourselves..

We were just babling about it, when it hit me. I red in a FAQ, that AoM doesn't like Multi-homed-PC's... And when you create a VPN, a second NIC will be created. That's the whole problem. The VPN-IP was allways graded "Alternative IP" and not Primary. So this is how we solved it:

1- Open VPN, so 2nd NIC/IP is activated. 2- Disable 1st NIC. VPN will be shut down, but 2nd NIC is still active 3- Start AoM. VPN-IP will be detected as sole address. 4- Alt+Tab to Windows. 5- Enable first NIC, and restart VPN. Connection is ok. 6- Play!!

Greetz!!




Ashatay

.I.Am.Too.Cool.To.Post.

50 XP

25th May 2003

0 Uploads

6,490 Posts

0 Threads

#7 16 years ago

good job!




zsh_xx

50 XP

25th November 2000

0 Uploads

232 Posts

0 Threads

#8 16 years ago

Why would AoM have trouble with 'Multi-Homed' Connections, though?

You should not have to disable one of the NICs ....

Did you use a 'routable' IP for the DirectIP/LAN (rather than the private IP range/NAT)?