That god damn vista!

Please wait...

This article was written on an older version of FileFront / GameFront

Formatting may be lacking as a result. If this article is un-readable please report it so that we may fix it.


Published by Riot 12 years ago , last updated 2 years ago
Have you recently bought Windows Vista and are having problems with running Age Of Empires III on it? Have no fear, AgeCommunity is here as it has been noted that they have set up a brand new page especially for players that are having troubles related to Windows Vista.
Known Issue: "This program has known compatibility issues" alert on Windows Vista This alert appears when installing or launching Age III (not Warchiefs) on any version of Windows Vista. It specifically refers to an issue with how the in-game autopatcher works under Windows Vista security settings. To correct the autopatch functionality, download and apply the latest stand alone patch. 1) Download the latest Age of Empires III patch from our game updates page. 2) Once the patch has been downloaded to your PC, you just need to double click on it to update your game. For any future patches, you will be able to update the game with our in-game auto update feature. Access this by clicking on "Help and Tools" from the main menu, then "Update Game".
You can check out the page http://agecommunity.com/vistapatching.aspx or if you are still having problems, you can make a thread in our forums.
Comments on this Article

There are no comments yet. Be the first!