Alpha Centauri Win 2000/XP Compatibility Update (v5.0)

This update resolves several issues between Sid Meier's Alpha Centauri and Windows 2000 and XP machines.

Download

Uploading...
Do not refresh or leave this page!

File Description

This update resolves several issues between Sid Meier's Alpha Centauri and Windows 2000 and XP machines.

If you have the Alien Crossfire expansion pack installed, first update Alpha Centauri to v4.0, then Alien Crossfire to v2.0, then Alpha Centauri to v5.0 (this patch).

Read More

Download 'SMAC_Win2000_XP_Compatibility_Update_v1.03f.exe' (8.48MB)

Comments on this File

There are no comments yet. Be the first!

Share This File
Embed File