Galactic Conquest .01d

Well, this patch isnt what most of you clicked for, no it isnt a giant patch that OMGz adds new vechs and such, its a patch that makes GC wo...

Download

Uploading...
Do not refresh or leave this page!

File Description

Well, this patch isnt what most of you clicked for, no it isnt a giant patch that OMGz adds new vechs and such, its a patch that makes GC work with 1.5. But, in my mind, thats just as good :)

And the GC mod team made some MINOR ajustments.

Read More

Download 'gcmod-01d.zip' (132KB)

Readme
        GALACTIC CONQUEST 0.1D


********    REQUIREMENTS    **********

Galactic Conquest needs the recommended PC specifications 
for Battlefield 1942 patched to 1.5 in order to work.


********    INSTALLATION    **********

Unzip this .rar to your Mods folder. 
Be sure that it overwrites the existing files.

********       CHANGES	    **********

[0.1d]

* Compitable with Battlefield 1.5
* Made both Rebel and Imperial sniper more inaccurate
* No more invisible TL-21

Read More

Comments on this File

There are no comments yet. Be the first!

Galactic Conquest


50 XP


Registered 1st August 2003

21 Files Uploaded

Share This File
Embed File