GC Flood Plains

This is my first map, and its pretty simple. This requires the Galactic Conquest mod version 4.2 and the Battlefield 1942 1.6 patch. This ma...

Download

Uploading...
Do not refresh or leave this page!

File Description

This is my first map, and its pretty simple. This requires the Galactic Conquest mod version 4.2 and the Battlefield 1942 1.6 patch. This map was made by Tortel

Read More

Download 'GC_Flood_Plains.rfa' (10.71MB)

Comments on this File

There are no comments yet. Be the first!

Share This File
Embed File