C&C 3: Tiberium Wars Mod SDK v5.0

If this is your first time modding for C&C 3, please download version 5.0 at the link below. If you downloaded version 4.0, be sure to updat...

Download

Uploading...
Do not refresh or leave this page!

File Description

If this is your first time modding for C&C 3, please download version 5.0 at the link below. If you downloaded version 4.0, be sure to update to version 5.0 below and take note of the critical fix. If you have not updated your MOD SDK since version 1.0, download and install the latest version below so all your files are completely up to date!

VISTA USERS - In order to install the new MOD SDK version correctly, please remove the old version first by using the add/remove function from the Control Panel. Once you have completely removed the MOD SDK, please proceed to install the new version. This will ensure you install correctly on Windows Vista.

There is only one major new feature and that is a fix to the Civilian Asset issue. This fixes up references to assets that are only located in our World Builder stream. This issue prevented modders from being able to use these assets in their own maps. You can now use these assets in your own maps after they are compiled using the new "BuildModCivAsset.bat" program included in the new version of the MOD SDK. You can also modify existing civilian assets or use the existing art assets to create new things for your mod. None of this was possible before.

HOW TO USE BuildModCivAsset.bat

BuildModCivAsset is used in the same way as Buildmod.bat, it takes the name of the mod to build as an argument. It should only be used to build mods that depend on assets that are in the worldbuilder stream. These assets are referenced from the worldbuilder.xml file in the cnc3xml folder. If you are creating civilian assets which use the art from existing civilian assets, you will need to use BuildModCivAsset rather than the normal BuildMod.

Please be advised: You must have Patch 1.09 installed in order for the MOD SDK v5.0 to function correctly. You also must download the newest version of World Builder labeled below as well if you have not already.

Read More

Comments on this File

There are no comments yet. Be the first!

Share This File
Embed File