<!DOCTYPE html>
<html lang="en">
<head>
    <!-- www.gamefront.com -->
        <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="keywords" content="pc, games, files, downloads, filefront, addons, client, demos, mods, freeware, maps, patches, skins, tools" />
    
    <meta name="google-site-verification" content="7OirSWKtBXIQuF-sYCPC03ssjdzO7j5sKB8ICeenioA" />
    <meta name="msvalidate.01" content="76D3260E07746F825E07DBA5EFD839EC" />
    
    <meta name="theme-color" content="#e38229">

    <meta name="p:domain_verify" content="1adbe29b46e8291d52b2235c310eb264"/>

    <link rel="icon" href="https://static.gamefront.com/images/favicons/favicon.ico" type="image/x-icon" />
    <link rel="icon" href="https://static.gamefront.com/images/favicons/favicon.png" type="image/png" sizes="96x96" />
    <link rel="icon" href="https://static.gamefront.com/images/favicons/favicon-new-192x192.png" type="image/png" sizes="192x192" />
    <link rel="apple-touch-icon-new" href="https://static.gamefront.com/images/favicons/apple-touch-icon-new.png" sizes="180x180" />

    <!-- CSRF Token -->
    <meta name="csrf-token" content="Xg0DwuLwB8p8MKIGFlh9DV9yDe336kTFZjNm1ZCJ">
    
    
    <title>Could Rebellion Reveal Sniper Elite 5 in 2020? - Gaming Industry News - GameFront</title>
<meta name="description" content="Rebellion are promising various reveals and releases in 2020, including Zombie Army 4: Dead War in February, Evil Genius 2: World Domination and Sniper Elite VR. It seems now though that we'll also be getting some kind or reveal for the next main Sniper Elite title in 2020 to.The news comes from Sadie Flayeh, PR executive at the company, as she teased the re...">
<link rel="canonical" href="https://www.gamefront.com/games/gamingtoday/article/could-rebellion-reveal-sniper-elite-5-in-2020"/>
<meta property="og:title" content="Could Rebellion Reveal Sniper Elite 5 in 2020? - Gaming Industry News - GameFront" />
<meta property="og:description" content="Rebellion are promising various reveals and releases in 2020, including Zombie Army 4: Dead War in February, Evil Genius 2: World Domination and Sniper Elite VR. It seems now though that we'll also be getting some kind or reveal for the next main Sniper Elite title in 2020 to.The news comes from Sadie Flayeh, PR executive at the company, as she teased the re..." />
<meta property="og:url" content="https://www.gamefront.com/games/gamingtoday/article/could-rebellion-reveal-sniper-elite-5-in-2020" />
<meta property="og:type" content="article" />
<meta property="og:site_name" content="GameFront" />
<meta property="og:image" content="https://www.gamefront.com/storage/images/articles/6Y4pkQgz7LQExmHR4xVC5E3iiOVysPfjCkiH2NEd.jpeg" />
<meta property="article:published_time" content="2020-01-05 14:09:11" />
<meta property="article:modified_time" content="2020-01-05 16:30:04" />
<meta property="og:author:username" content="FileTrekker" />

<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@GameFrontCom" />
<meta name="twitter:title" content="Could Rebellion Reveal Sniper Elite 5 in 2020? - Gaming Industry News" />
<meta name="twitter:description" content="Rebellion are promising various reveals and releases in 2020, including Zombie Army 4: Dead War in February, Evil Genius 2: World Domination and Sniper Elite VR. It seems now though that we'll also be getting some kind or reveal for the next main Sniper Elite title in 2020 to.The news comes from Sadie Flayeh, PR executive at the company, as she teased the re..." />
    
    <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"Organization","name":"GameFront","url":"https:\/\/www.gamefront.com","logo":"https:\/\/static.gamefront.com\/images\/logo.svg","contactPoint":{"@type":"ContactPoint","areaServed":"Worldwide","url":"https:\/\/www.gamefront.com\/support","contactType":"customer service"}}</script>
    <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"WebSite","name":"GameFront","url":"https:\/\/www.gamefront.com","sameAs":["https:\/\/www.facebook.com\/gamefrontcom","https:\/\/www.twitter.com\/gamefrontcom","https:\/\/www.youtube.com\/gamefront","https:\/\/steamcommunity.com\/groups\/filefrontgamefront","https:\/\/plus.google.com\/+gamefront","https:\/\/en.wikipedia.org\/wiki\/GameFront"]}</script>
    
        <link rel="amphtml" href="https://www.gamefront.com/games/amp/gamingtoday/article/could-rebellion-reveal-sniper-elite-5-in-2020">
    <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"NewsArticle","headline":"Could Rebellion Reveal Sniper Elite 5 in 2020?","url":"https:\/\/www.gamefront.com\/games\/gamingtoday\/article\/could-rebellion-reveal-sniper-elite-5-in-2020","articleBody":"<p>Rebellion are promising various reveals and releases in 2020, including Zombie Army 4: Dead War in February, Evil Genius 2: World Domination and Sniper Elite VR. It seems now though that we'll also be getting some kind or reveal for the next main Sniper Elite title in 2020 to.<\/p><p>The news comes from Sadie Flayeh, PR executive at the company, as she teased the reveal in on Twitter;<\/p><p><br><\/p><blockquote class=\"twitter-tweet\"><p dir=\"ltr\" lang=\"en\">Hello 2020 people! Just a reminder from your friendly neighborhood <a href=\"https:\/\/twitter.com\/Rebellion?ref_src=twsrc%5Etfw\">@Rebellion<\/a> PR bot...<br><br>ZOMBIE ARMY 4: DEAD WAR - February 4th<br>EVIL GENIUS 2: WORLD DOMINATION - Coming 2020<br>SNIPER ELITE VR - TBA<br>Oh... and there'll be news on the next mainline Sniper Elite!<br><br>🧐😱🙃🧐😱🙃🧐😱🙃🧐 <a href=\"https:\/\/t.co\/3OuaPBlJN1\">pic.twitter.com\/3OuaPBlJN1<\/a><\/p>— Sadie Flayeh (@shoibox) <a href=\"https:\/\/twitter.com\/shoibox\/status\/1212758896349261824?ref_src=twsrc%5Etfw\">January 2, 2020<\/a><\/blockquote><p>We suspected something to be announced as it was hinted at already last year that the game was in development, but it seems we may be getting an official reveal at some point in 2020.<\/p><p>As for what to expect, well, we have no idea. It remains to be seen if the game will be targeted at current generation hardware, but given the fall 2020 release dates of Xbox Series X and PS5, it could very well be targeted at these consoles.<\/p><p>Stay tuned to GameFront for any further news on this as we learn it.<\/p><p><br><\/p>","author":{"@type":"Person","name":"FileTrekker","image":"https:\/\/static.gamefront.com\/storage\/avatars\/73493\/X8qAQIhNOg41UFRgU6tzX2QoN716PRS3QaFi68Cv.jpeg"},"datePublished":"2020-01-05 14:09:11","dateModified":"2020-01-05 16:30:04","image":{"@type":"ImageObject","url":"https:\/\/www.gamefront.com\/storage\/images\/articles\/6Y4pkQgz7LQExmHR4xVC5E3iiOVysPfjCkiH2NEd.jpeg"},"publisher":{"@type":"Organization","name":"GameFront","url":"https:\/\/www.gamefront.com","logo":{"@type":"ImageObject","url":"https:\/\/static.gamefront.com\/images\/gf_social_header_new.jpg"}}}</script>
    

    <link href="https://fonts.googleapis.com/css?family=Roboto:300,400,700" rel="stylesheet">
    
    <link href="https://www.gamefront.com/css/leaguegothic-dev.css?hash=2020-v4" rel="stylesheet">
    
    
    

    <link rel="alternate" type="application/atom+xml" href="https://www.gamefront.com/feed/files" title="Latest Files - GameFront">
    <link rel="alternate" type="application/atom+xml" href="https://www.gamefront.com/feed/threads" title="Latest Threads - GameFront">
    <link rel="alternate" type="application/atom+xml" href="https://www.gamefront.com/feed/news" title="Latest News - GameFront">

    <!-- Styles -->
        <link href="https://static.gamefront.com/css/app.css?v=200106&hash=2020-v4" rel="stylesheet">
    <link href="https://static.gamefront.com/css/vendor.css?v=200106&hash=2020-v4" rel="stylesheet">
        <meta name="theme-color" content="#161D27">
<style>
        body {
        background-color: #0f141b !important;
    }
    .header__alt {
                background: linear-gradient(rgba(22,29,39,0.7), rgba(0,0,0,0.6)), url(https://static.gamefront.com/storage/images/games/CdIuEtmAV9Gba3tjMJTcioeaWJNs3NLdXxqISS04.jpeg);
                background-size: cover;
        background-position: center top;
    }
    .subnav {
        background-color: rgba(22,29,39,0.8);;
    }
    .menu__item:hover > ul {
        background-color: rgba(22,29,39,1);;
    }
    .menu__container {
        background-color: rgba(17,23,31,0.6);
    }
    .profile__game_name {
        background-color: rgba(22,29,39,0.6);;
    }
    .box {
        border-color: #161D27;
    }
    .button, .swal-button, input[type="submit"] {
        background-image: linear-gradient(-135deg, #161D27 0%, #11171f 100%);
    }
    .card__image--no-thumbnail {
        background-color: rgba(22,29,39,0.8);;
    }
    .mobile-menu ul li a:after {
        background: #E38229 !important;
    }
    .mobile-menu {
        background: #161D27;
    }
    a:hover {
        color: #161D27;
    }
    hr {
        border-color: #161D27;
    }
    
            a, i {
        color: #E38229;
    }
    .button:hover, .swal-button:hover, input[type="submit"]:hover {
        background-image: linear-gradient(-135deg, #E38229 0%, #9e5b1c 100%);
    }
    </style>
    <style>
    .header__alt {
        background: linear-gradient(rgba(22,29,39,0.7), rgba(0,0,0,0.6)), url(https://static.gamefront.com/storage/images/articles/6Y4pkQgz7LQExmHR4xVC5E3iiOVysPfjCkiH2NEd.jpeg);
        background-size: cover;
        background-position: center top;
    }

    </style>

    <!-- Scripts -->
    <script>
        window.Laravel = {"csrfToken":"Xg0DwuLwB8p8MKIGFlh9DV9yDe336kTFZjNm1ZCJ"};
        window.App = {"homeUrl":"https:\/\/www.gamefront.com","signedIn":false,"user":null}
    </script>
        <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-104975-22"></script>
    <script>
      window.dataLayer = window.dataLayer || [];
      function gtag(){dataLayer.push(arguments);}
      gtag('js', new Date());

      gtag('config', 'UA-104975-22');
    </script>
    <!-- Vue Scripts Injected -->
</head>
<body class="showArticle">
                <header class="header__alt">
        <div class="header__container">
            <div class="header__logo">
                <a href="https://www.gamefront.com">
                                        <img src="https://static.gamefront.com/images/logo.svg" alt="GameFront">
                                    </a>
            </div>
            <ul class="menu__right">
                                    <li class="menu__item">

                        <a href="https://www.gamefront.com/login" class="menu__link"><i class="fa fa-key"></i> Login</a> 
                        <a href="https://www.gamefront.com/register" class="menu__link"><i class="fa fa-user-plus"></i> Register</a>
                    </li>
                                <li class="menu__item">
                                        <a href="https://www.gamefront.com/upload?gamingtoday" class="button icon upload">
                        <i class="fa fa-cloud-upload-alt" aria-hidden="true" style="color: #fff;"></i> Upload File
                    </a>
                                    </li>
            </ul>
        </div>
        <div class="header__menu">
            <div class="menu__container">

                <div class="mobile_toggle">
                    <span></span>
                    <span></span>
                    <span></span>
                </div>

                <nav class="responsive-nav">
                    <div class="responsive-nav__close">
                        <a class="">&times;</a>
                    </div>
                    <div class="responsive-nav__logo">
                        <a href="https://www.gamefront.com">
                            <img src="https://static.gamefront.com/images/logo.svg" alt="GameFront Logo" class="logo-img">
                        </a>
                    </div>
                    <ul class="mobile-menu">
                                                    <li class="mobile-menu__item">
                                     <a href="/login"><i class="fa fa-user-circle"></i> Log-in / Register!</a>
                                </li>
                                        </ul>
                    <ul class="mobile-menu">
    <li class="mobile-menu__item ">
        <a href="https://www.gamefront.com" class="mobile-menu__link">
            <i class="fa fa-home"></i>
            Home
        </a>
    </li>

    <li class="mobile-menu__item  mobile-menu__item--has-children">
        <a href="https://www.gamefront.com/files" class="mobile-menu__link">
            <i class="fas fa-file-archive"></i>
            Files
        </a>
        <ul class="mobile-menu">
            <li class="mobile-menu__item">
                <a href="https://www.gamefront.com/files" class="mobile-menu__link">All Files</a>
                <a href="https://www.gamefront.com/files/top" class="mobile-menu__link">Top Files</a>
                <a href="https://www.gamefront.com/files/demos" class="mobile-menu__link">Demos</a>
                <a href="https://www.gamefront.com/files/patches" class="mobile-menu__link">Patches</a>
                <a href="https://www.gamefront.com/files/tools" class="mobile-menu__link">Tools</a>
                
                <a href="https://www.gamefront.com/files/upload" class="mobile-menu__link">Upload File</a>

                
            </li>
        </ul>
    </li>

    <li class="mobile-menu__item  mobile-menu__item--has-children ">
        <a href="https://www.gamefront.com/games" class="mobile-menu__link">
            <i class="fa fa-gamepad"></i>
            Games
        </a>
        <ul class="mobile-menu">
            <li class="mobile-menu__item">
                <a href="https://www.gamefront.com/games" class="mobile-menu__link">All Games</a>
                <a href="https://www.gamefront.com/games/create" class="mobile-menu__link">Add Game</a>
                <a href="https://www.gamefront.com/files/upload" class="mobile-menu__link">Upload File</a>
            </li>
        </ul>
    </li>

    <li class="mobile-menu__item   mobile-menu__item--has-children-active mobile-menu__item--active ">
        <a href="https://www.gamefront.com/news" class="mobile-menu__link">
            <i class="fas fa-newspaper"></i>
            Articles
        </a>
        <ul class="mobile-menu">
            <li class="mobile-menu__item">
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/gaming-industry-news" class="mobile-menu__link">Industry News</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/modding-news-1" class="mobile-menu__link">Modding News</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/walkthroughs" class="mobile-menu__link">Walkthroughs</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/essential-mods" class="mobile-menu__link">Essential Mods</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/game-deals" class="mobile-menu__link">Game Deals</a>
                <a href="https://www.gamefront.com/news" class="mobile-menu__link">All Articles</a>
            </li>
        </ul>
    </li>


    <li class="mobile-menu__item  mobile-menu__item--has-children ">
        <a href="https://www.gamefront.com/videos" class="mobile-menu__link">
            <i class="fas fa-play-circle"></i>
            Videos
        </a>
    <ul class="mobile-menu">
        <li class="mobile-menu__item">
            <a href="https://www.gamefront.com/videos" class="mobile-menu__link">Browse Videos</a>
            <a href="https://www.gamefront.com/files/upload" class="mobile-menu__link">Upload Video</a>
            <a href="https://www.youtube.com/gamefront" class="mobile-menu__link">YouTube Channel</a>
        </li>
    </ul>
    </li>


    <li class="mobile-menu__item  mobile-menu__item--has-children ">
        <a href="https://www.gamefront.com/forums" class="mobile-menu__link">
            <i class="fas fa-comments-alt"></i>
            Community
        </a>
        <ul class="mobile-menu">
            <li class="mobile-menu__item">
                <a href="https://www.gamefront.com/forums" class="mobile-menu__link">Gaming Forums</a>
                <a href="https://www.gamefront.com/forums/search/latest" class="mobile-menu__link">Latest Threads</a>
                <a href="https://discord.me/gamefront" class="mobile-menu__link" target="_blank">Discord Server</a>
                <a href="/page/the-gamefront-code-of-conduct" class="mobile-menu__link">Code of Conduct</a>
                <a href="https://www.gamefront.com/community/members" class="mobile-menu__link">User Directory</a>
            </li>
        </ul>
    </li>

    <li class="mobile-menu__item  mobile-menu__item--has-children ">
        <a href="https://www.gamefront.com/support" class="mobile-menu__link">
            <i class="fas fa-envelope-open-text"></i>
            Support
        </a>
        <ul class="mobile-menu">
            <li class="mobile-menu__item">
                <a href="https://www.gamefront.com/support/create" class="mobile-menu__link">Contact Us</a>
                <a href="https://www.gamefront.com/support" class="mobile-menu__link">My Tickets</a>
                <a href="https://www.gamefront.com/support/knowledgebase" class="mobile-menu__link">Knowledge Base</a>
                <a href="https://www.gamefront.com/forums/gamefront-development-support/create" class="mobile-menu__link">Feedback</a>
            </li>
        </ul>
    </li>
    
        
</ul>
                </nav>

                    
                    <ul class="menu">
    <li class="menu__item ">
        <a href="https://www.gamefront.com" class="menu__link">
            <i class="fa fa-home"></i>
            Home
        </a>
    </li>

    <li class="menu__item  menu__item--has-children">
        <a href="https://www.gamefront.com/files" class="menu__link">
            <i class="fas fa-file-archive"></i>
            Files
        </a>
        <ul class="menu">
            <li class="menu__item">
                <a href="https://www.gamefront.com/files" class="menu__link">All Files</a>
                <a href="https://www.gamefront.com/files/top" class="menu__link">Top Files</a>
                <a href="https://www.gamefront.com/files/demos" class="menu__link">Demos</a>
                <a href="https://www.gamefront.com/files/patches" class="menu__link">Patches</a>
                <a href="https://www.gamefront.com/files/tools" class="menu__link">Tools</a>
                
                <a href="https://www.gamefront.com/files/upload" class="menu__link">Upload File</a>

                
            </li>
        </ul>
    </li>

    <li class="menu__item  menu__item--has-children ">
        <a href="https://www.gamefront.com/games" class="menu__link">
            <i class="fa fa-gamepad"></i>
            Games
        </a>
        <ul class="menu">
            <li class="menu__item">
                <a href="https://www.gamefront.com/games" class="menu__link">All Games</a>
                <a href="https://www.gamefront.com/games/create" class="menu__link">Add Game</a>
                <a href="https://www.gamefront.com/files/upload" class="menu__link">Upload File</a>
            </li>
        </ul>
    </li>

    <li class="menu__item   menu__item--has-children-active menu__item--active ">
        <a href="https://www.gamefront.com/news" class="menu__link">
            <i class="fas fa-newspaper"></i>
            Articles
        </a>
        <ul class="menu">
            <li class="menu__item">
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/gaming-industry-news" class="menu__link">Industry News</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/modding-news-1" class="menu__link">Modding News</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/walkthroughs" class="menu__link">Walkthroughs</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/essential-mods" class="menu__link">Essential Mods</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/game-deals" class="menu__link">Game Deals</a>
                <a href="https://www.gamefront.com/news" class="menu__link">All Articles</a>
            </li>
        </ul>
    </li>


    <li class="menu__item  menu__item--has-children ">
        <a href="https://www.gamefront.com/videos" class="menu__link">
            <i class="fas fa-play-circle"></i>
            Videos
        </a>
    <ul class="menu">
        <li class="menu__item">
            <a href="https://www.gamefront.com/videos" class="menu__link">Browse Videos</a>
            <a href="https://www.gamefront.com/files/upload" class="menu__link">Upload Video</a>
            <a href="https://www.youtube.com/gamefront" class="menu__link">YouTube Channel</a>
        </li>
    </ul>
    </li>


    <li class="menu__item  menu__item--has-children ">
        <a href="https://www.gamefront.com/forums" class="menu__link">
            <i class="fas fa-comments-alt"></i>
            Community
        </a>
        <ul class="menu">
            <li class="menu__item">
                <a href="https://www.gamefront.com/forums" class="menu__link">Gaming Forums</a>
                <a href="https://www.gamefront.com/forums/search/latest" class="menu__link">Latest Threads</a>
                <a href="https://discord.me/gamefront" class="menu__link" target="_blank">Discord Server</a>
                <a href="/page/the-gamefront-code-of-conduct" class="menu__link">Code of Conduct</a>
                <a href="https://www.gamefront.com/community/members" class="menu__link">User Directory</a>
            </li>
        </ul>
    </li>

    <li class="menu__item  menu__item--has-children ">
        <a href="https://www.gamefront.com/support" class="menu__link">
            <i class="fas fa-envelope-open-text"></i>
            Support
        </a>
        <ul class="menu">
            <li class="menu__item">
                <a href="https://www.gamefront.com/support/create" class="menu__link">Contact Us</a>
                <a href="https://www.gamefront.com/support" class="menu__link">My Tickets</a>
                <a href="https://www.gamefront.com/support/knowledgebase" class="menu__link">Knowledge Base</a>
                <a href="https://www.gamefront.com/forums/gamefront-development-support/create" class="menu__link">Feedback</a>
            </li>
        </ul>
    </li>
    
    
                        
</ul>

                
                <div class="header__online">
                    <span>
                        <span title="Guests Online" class="status-online"></span> 1,197 ONLINE
                    </span>
                </div>
                
            </div>
        </div>

            <div class="hero" id="hero">
    <div class="hero__container">
        <div class="hero__content">

                <h1 class="hero__heading">
                        Could Rebellion Reveal Sniper Elite 5 in 2020?
                </h1>
            <p><p>
                <follow-button id="77646" type="article"></follow-button>
                            </p></p>
        </div>
        <div class="hero__search">
            
        </div>
        <div class="hero__extra">
            
        </div>
    </div>
</div>

            <section class="subnav subnav__alt">
    <div class="subnav__container">
        <nav class="breadcrumbs">
            <ul class="breadcrumbs__menu">
                                <li class="breadcrumbs__item">
                    <a href="https://www.gamefront.com" class="breadcrumbs__link">GameFront.com</a>
                </li>
                                <li class="breadcrumbs__item">
                    <a href="https://www.gamefront.com/games" class="breadcrumbs__link">Games</a>
                </li>
                                <li class="breadcrumbs__item">
                    <a href="https://www.gamefront.com/games/gamingtoday" class="breadcrumbs__link">Gaming Today</a>
                </li>
                                <li class="breadcrumbs__item">
                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/gaming-industry-news" class="breadcrumbs__link">Gaming Industry News</a>
                </li>
                                <li class="breadcrumbs__item">
                    <a href="" class="breadcrumbs__link">Could Rebellion Reveal Sniper Elite 5 in 2020?</a>
                </li>
                            </ul>
        </nav>
    </div>
</section>

    </header>
    

    <div class="blackout"></div>
    <div class="whiteout"></div>
    <div class="loader">
        <div class="loader__box">
            <div class="loader__content"> 
                <i class="fa fa-spinner fa-pulse fa-3x fa-fw"></i>
                <h3>
                                        Please wait...
                </h3>
            </div>
        </div>
    </div>
    
    <div class="site__container">
        <div class="site__content ad__desk">
            <div class="box" style="background-color: rgb(220, 220, 220); padding: 0;text-align: center;">
                <a href="https://www.gamefront.com/page/share-gaming-files-with-no-speed-caps-or-limits-gamefront" target="_blank" rel="nofollow">
                    <div class="alert alert-info" style="margin: 0;">
                        <i class="fa fa-exclamation-circle" style="display: inline-block;vertical-align: middle;"></i><p style="display: inline-block;vertical-align: middle;">Multi-threaded downloads, <strong>NO</strong> speed caps, <strong>NO</strong> ads and automatic downloads, all for free? Use GameFront! <strong>Learn more</strong>.</p>
                    </div>
                </a>
            </div>
        </div>
    </div>

    
        

        
            <main class="site">
            <section class="site__container">
                <section class="site__content">
                    <div class="box box--no-padding box--no-border" style="background-color: #EEE;">
                        <section class="gamefront__site-content matchheight" style="background-color: #fff !important;">
    <div class="box">
        
        
                <span class="box__title">
            <i class="fal fa-newspaper"></i>
                            Published by
            
                        <a href="https://www.gamefront.com/@filetrekker">FileTrekker</a>
            
            <span data-toggle="tooltip" data-placement="top" title="5th January 2020 16:01" >
                11 hours ago
            </span>

                            , last updated
                <span data-toggle="tooltip" data-placement="top" title="5th January 2020 16:01" >
                    10 hours ago
                </span>
                    </span>
        

        <div class="box__content fr-view article__content">
                        <p>Rebellion are promising various reveals and releases in 2020, including Zombie Army 4: Dead War in February, Evil Genius 2: World Domination and Sniper Elite VR. It seems now though that we'll also be getting some kind or reveal for the next main Sniper Elite title in 2020 to.</p><p>The news comes from Sadie Flayeh, PR executive at the company, as she teased the reveal in on Twitter;</p><p><br></p><blockquote class="twitter-tweet"><p dir="ltr" lang="en">Hello 2020 people! Just a reminder from your friendly neighborhood <a href="https://twitter.com/Rebellion?ref_src=twsrc%5Etfw">@Rebellion</a> PR bot...<br><br>ZOMBIE ARMY 4: DEAD WAR - February 4th<br>EVIL GENIUS 2: WORLD DOMINATION - Coming 2020<br>SNIPER ELITE VR - TBA<br>Oh... and there'll be news on the next mainline Sniper Elite!<br><br>🧐😱🙃🧐😱🙃🧐😱🙃🧐 <a href="https://t.co/3OuaPBlJN1">pic.twitter.com/3OuaPBlJN1</a></p>— Sadie Flayeh (@shoibox) <a href="https://twitter.com/shoibox/status/1212758896349261824?ref_src=twsrc%5Etfw">January 2, 2020</a></blockquote><p>We suspected something to be announced as it was hinted at already last year that the game was in development, but it seems we may be getting an official reveal at some point in 2020.</p><p>As for what to expect, well, we have no idea. It remains to be seen if the game will be targeted at current generation hardware, but given the fall 2020 release dates of Xbox Series X and PS5, it could very well be targeted at these consoles.</p><p>Stay tuned to GameFront for any further news on this as we learn it.</p><p><br></p>
                    </div>
    </div>

    <div class="box">
        <span class="box__title">
            <i class="fa fa-comments"></i> Comments on this Article
        </span>
                    <div class="box__content">
        <p>There are no comments yet. Be the first!</p>
    </div>
            <div class="box__content">
    <div class="panel panel-default">
        <div class="panel-body">
            <div class="social-auth">
                <p class="lead">Please <a href="/login">sign in</a> to participate in this discussion.</p>
                
                <!-- Socialauth Facebook -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/facebook" aria-label="Sign in with Facebook Account">
    <div class="resp-social-button resp-social-button--facebook resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-facebook" aria-hidden="true" style="margin: 1rem;"></i>
        </div>
    </div>
</a>

<!-- Socialauth Google -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/google" aria-label="Sign in with Google Account">
    <div class="resp-social-button resp-social-button--google resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-google" aria-hidden="true" style="margin: 1rem;"></i>
        </div>
    </div>
</a>

<!-- Socialauth Twitter -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/twitter" aria-label="Sign in with Twitter Account">
    <div class="resp-social-button resp-social-button--twitter resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-twitter" aria-hidden="true"  style="margin: 1rem;"></i>
        </div>
    </div>
</a>

<!-- Socialauth Steam -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/steam" aria-label="Sign in with Steam Account">
    <div class="resp-social-button resp-social-button--steam resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-steam" aria-hidden="true"  style="margin: 1rem;"></i>
        </div>
    </div>
</a>

<!-- Socialauth Microsoft -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/live" aria-label="Sign in with Microsoft Account">
    <div class="resp-social-button resp-social-button--microsoft resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-windows" aria-hidden="true"  style="margin: 1rem;"></i>
        </div>
    </div>
</a>


<!-- Socialauth Twitch -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/twitch" aria-label="Sign in with Twitch Account">
    <div class="resp-social-button resp-social-button--twitch resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-twitch" aria-hidden="true"  style="margin: 1rem;"></i>
        </div>
    </div>
</a>

<!-- Socialauth Discord -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/discord" aria-label="Sign in with Discord Account">
    <div class="resp-social-button resp-social-button--discord resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-discord" aria-hidden="true"  style="margin: 1rem;"></i>
        </div>
    </div>
</a>
            </div>
        </div>
    </div>
</div>

                
    </div>
</section>

<aside class="gamefront__site-sidebar matchheight">
    <!-- #partials.sidebar.item -->
    <div class="sidebar__item">

        <div class="box box__alpha">
    <span class="box__title"><i class="fa fa-share"></i> Share This Article</span>
    <div class="box__content">
        <div class="sharethis-inline-share-buttons"></div>
                        <div id="app">
                    <share-short-url :url="['https://www.gamefront.com/games/gamingtoday/article/could-rebellion-reveal-sniper-elite-5-in-2020']"></share-short-url>
                </div>
            </div>
</div>

        <div class="box box__alpha">
            <span class="box__title"><i class="fa fa-list"></i> Categories</span>
            <div class="table-responsive">
                <table class="table table-hover">
                                                                        <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/jim-sterlings-rant">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">/RANT</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/contests-2">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Contests</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/e3-expo-2017">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">E3 Expo 2017</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/essential-mods">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Essential Mods</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/game-deals">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Game Deals</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/gamefront-news">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">GameFront News</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/gaming-industry-news">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Gaming Industry News</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/graphics-mods">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Graphics Mods</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/interviews-51">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Interviews</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/maps-map-packs">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Maps &amp; Map Packs</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/miscellaneous-29">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Miscellaneous</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/modcasts">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">ModCasts</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/modding-news-1">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Modding News</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/monthly-mod-recap">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Monthly Mod Recap</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/network-news-28">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Network News</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/off-topic-28">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Off Topic</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/reviews-68">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Reviews</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/skins-character-mods">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Skins &amp; Character Mods</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/total-conversions-1">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Total Conversions</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/utilities-modding-tools">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Utilities &amp; Modding Tools</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/walkthroughs">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">Walkthroughs</span>
                                    </a>
                                </td>
                            </tr>
                                                                                                <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/gamingtoday/news/category/youtube-videos">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">YouTube Videos</span>
                                    </a>
                                </td>
                            </tr>
                                                            </table>
            </div>
        </div>
    </div>
    <!-- / #partials.sidebar.item -->

    <!-- #partials.sidebar.item -->
    <div class="sidebar__item">
    <div class="box box__alpha">
        <span class="box__title"><i class="fa fa-comments"></i> Latest Comments</span>
        <p></p>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@1?user_id=1&amp;slug=mikey&amp;display_name=Mikey&amp;location=Disunited%20Queendom&amp;gender=ApacheAttackHelicopter&amp;date_birth=1991-02-09%2000%3A00%3A00&amp;avatar=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Favatars%2F1%2FKdqmiJTsnq8OjVLsFTbRsoUi5Y66PLlvMmH40NP4.png&amp;signature=%3Cp%3E%3Cstrong%3EMikey%3C%2Fstrong%3E%20-%20GameFront.com%20-%20%3Cspan%20style%3D%22color%3Argb%28247%2C150%2C70%29%3B%22%3E%3Cem%3ELead%20Developer%3C%2Fem%3E%3C%2Fspan%3E%3C%2Fp%3E&amp;post_count=4010&amp;created_at=2008-06-13%2002%3A26%3A00&amp;updated_at=2020-01-04%2013%3A54%3A22&amp;avatar_path=avatars%2F1%2FKdqmiJTsnq8OjVLsFTbRsoUi5Y66PLlvMmH40NP4.png&amp;cover_photo_path=covers%2F1%2FPgVmpsbSU2EilOTaYKeoPZtp8z6Ci9dh37GmTeSt.png&amp;about=%3Cp%3EI%20built%20most%20of%20GameFront%20from%20scratch.%20Any%20problems%2C%20please%20pester%20%40FileTrekker%20%3B%29%3C%2Fp%3E&amp;social_networks%5Btwitter%5D=MadMikeyB&amp;social_networks%5Bsteam%5D=mrmadmikeyb&amp;social_networks%5Btwitch%5D=MadMikeyB&amp;social_networks%5Byoutube%5D=MadMikeyB&amp;thread_count=230&amp;cover=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Fcovers%2F1%2FPgVmpsbSU2EilOTaYKeoPZtp8z6Ci9dh37GmTeSt.png">Mikey</a> commented on <a href="https://www.gamefront.com/comments/934">Phil Spencer teases next game by Obsidian</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@1?user_id=1&amp;slug=mikey&amp;display_name=Mikey&amp;location=Disunited%20Queendom&amp;gender=ApacheAttackHelicopter&amp;date_birth=1991-02-09%2000%3A00%3A00&amp;avatar=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Favatars%2F1%2FKdqmiJTsnq8OjVLsFTbRsoUi5Y66PLlvMmH40NP4.png&amp;signature=%3Cp%3E%3Cstrong%3EMikey%3C%2Fstrong%3E%20-%20GameFront.com%20-%20%3Cspan%20style%3D%22color%3Argb%28247%2C150%2C70%29%3B%22%3E%3Cem%3ELead%20Developer%3C%2Fem%3E%3C%2Fspan%3E%3C%2Fp%3E&amp;post_count=4010&amp;created_at=2008-06-13%2002%3A26%3A00&amp;updated_at=2020-01-04%2013%3A54%3A22&amp;avatar_path=avatars%2F1%2FKdqmiJTsnq8OjVLsFTbRsoUi5Y66PLlvMmH40NP4.png&amp;cover_photo_path=covers%2F1%2FPgVmpsbSU2EilOTaYKeoPZtp8z6Ci9dh37GmTeSt.png&amp;about=%3Cp%3EI%20built%20most%20of%20GameFront%20from%20scratch.%20Any%20problems%2C%20please%20pester%20%40FileTrekker%20%3B%29%3C%2Fp%3E&amp;social_networks%5Btwitter%5D=MadMikeyB&amp;social_networks%5Bsteam%5D=mrmadmikeyb&amp;social_networks%5Btwitch%5D=MadMikeyB&amp;social_networks%5Byoutube%5D=MadMikeyB&amp;thread_count=230&amp;cover=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Fcovers%2F1%2FPgVmpsbSU2EilOTaYKeoPZtp8z6Ci9dh37GmTeSt.png">Mikey</a> commented on <a href="https://www.gamefront.com/comments/933">Wild Hunt popularity surges thanks to Netflix series</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@136075?user_id=171818&amp;slug=andathar&amp;display_name=%C3%82ndathar&amp;avatar=https%3A%2F%2Fstatic.gamefront.com%2Fimages%2Fdefaults%2Favatar_default.jpg&amp;signature=&amp;post_count=0&amp;created_at=2019-11-26%2016%3A16%3A15&amp;updated_at=2019-11-26%2016%3A16%3A15&amp;about=&amp;social_networks=0&amp;thread_count=0&amp;cover=https%3A%2F%2Fstatic.gamefront.com%2Fimages%2Fdefaults%2Fprofile_default.jpg">Ândathar</a> commented on <a href="https://www.gamefront.com/comments/912">What should be done with federation ships?</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@37752?user_id=73493&amp;slug=filetrekker&amp;display_name=FileTrekker&amp;user_title=I%27m%20spending%20a%20year%20dead%20for%20tax%20reasons.&amp;location=Manchester%2C%20UK&amp;gender=Male&amp;date_birth=1988-02-02%2000%3A00%3A00&amp;avatar=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Favatars%2F73493%2FX8qAQIhNOg41UFRgU6tzX2QoN716PRS3QaFi68Cv.jpeg&amp;signature=%3Cp%3EDanny%20King%20%7C%C2%A0%3Cstrong%3EEditor-in-Chief%3C%2Fstrong%3E%20%7C%20%3Ca%20href%3D%22https%3A%2F%2Fwww.gamefront.com%2F%22%20rel%3D%22nofollow%20noreferrer%20noopener%22%20target%3D%22_blank%22%3EGameFront.com%3C%2Fa%3E%3C%2Fp%3E&amp;post_count=22796&amp;created_at=2002-12-15%2021%3A00%3A00&amp;updated_at=2020-01-05%2009%3A54%3A50&amp;avatar_path=avatars%2F73493%2FX8qAQIhNOg41UFRgU6tzX2QoN716PRS3QaFi68Cv.jpeg&amp;cover_photo_path=covers%2F73493%2FX58qOirHUmc5ba9z2LVMkrtoOhvYXurXhrHFGOQO.jpeg&amp;about=%3Cp%3EFreelance%20web%20designer%2C%20Editor-in-Chief%20and%20YouTube%20Content%20Creator%20for%20GameFront.com%3C%2Fp%3E&amp;social_networks%5Btwitter%5D=FileTrekker&amp;social_networks%5Bsteam%5D=FileTrekker&amp;social_networks%5Btwitch%5D=GameFrontCom&amp;social_networks%5Byoutube%5D=GameFrontCom&amp;thread_count=1896&amp;cover=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Fcovers%2F73493%2FX58qOirHUmc5ba9z2LVMkrtoOhvYXurXhrHFGOQO.jpeg">FileTrekker</a> commented on <a href="https://www.gamefront.com/comments/910">Bombing Run Mod for UT3 coming soon!</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@136013?user_id=171756&amp;slug=Vence-816-&amp;display_name=Vence%20816%20%7C%7C%7B%CF%81.%CF%89.%CE%B9.%7D%7C%7C&amp;avatar=https%3A%2F%2Fstatic.gamefront.com%2Fimages%2Fdefaults%2Favatar_default.jpg&amp;signature=&amp;post_count=0&amp;created_at=2019-11-17%2014%3A04%3A59&amp;updated_at=2019-11-17%2014%3A07%3A28&amp;about=&amp;social_networks=0&amp;thread_count=0&amp;cover=https%3A%2F%2Fstatic.gamefront.com%2Fimages%2Fdefaults%2Fprofile_default.jpg">Vence 816 ||{ρ.ω.ι.}||</a> commented on <a href="https://www.gamefront.com/comments/909">Bombing Run Mod for UT3 coming soon!</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@31004?user_id=66745&amp;slug=radioactivelobster&amp;display_name=RadioactiveLobster&amp;user_title=Jeff%20is%20a%20mean%20boss&amp;location=%27Murica%21&amp;gender=Lobster&amp;date_birth=1987-01-30%2000%3A00%3A00&amp;avatar=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Favatars%2F66745%2FAAnB89EPkcIPhm63WYwN5U1zxpGUCuDHnutCOEXo.png&amp;signature=%3Cp%20style%3D%22text-align%3Acenter%3B%22%3E%3Cimg%20src%3D%22https%3A%2F%2Fi.imgur.com%2FNBDL9qd.png%22%20class%3D%22fr-fic%20fr-dib%22%20alt%3D%22If%20there%20is%20no%20image%2C%20Mikey%20broke%20something...%22%20%2F%3E%3C%2Fp%3E&amp;post_count=53193&amp;created_at=2002-07-28%2019%3A00%3A00&amp;updated_at=2020-01-04%2013%3A58%3A06&amp;avatar_path=avatars%2F66745%2FAAnB89EPkcIPhm63WYwN5U1zxpGUCuDHnutCOEXo.png&amp;cover_photo_path=covers%2F66745%2F1CJV2a1cc8NaepYc8qtKUWKqJb9Y3L7m64LSeida.png&amp;about=%3Cp%3EBorn%20and%20raised%20in%20a%20tank%20at%20Red%20Lobster%20my%20life%20changed%20the%20day%20a%20group%20of%20Nuclear%20Waste%20inspectors%20came%20in%20and%20decided%20to%20eat.%20Little%20did%20they%20know%20that%20the%20residue%20from%20their%20coats%20would%20affect%20me%20so.%3C%2Fp%3E&amp;social_networks%5Btwitter%5D=RadActiveLobstr&amp;social_networks%5Bsteam%5D=radioactivelobster&amp;social_networks%5Btwitch%5D=radioactivelobster&amp;social_networks%5Byoutube%5D=RadActiveLobster&amp;thread_count=1338&amp;cover=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Fcovers%2F66745%2F1CJV2a1cc8NaepYc8qtKUWKqJb9Y3L7m64LSeida.png">RadioactiveLobster</a> commented on <a href="https://www.gamefront.com/comments/905">I&#039;m actually excited for Sonic The Hedgehog&#039;s Movie</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@83289?user_id=119030&amp;slug=lysdestic&amp;display_name=Lysdestic&amp;user_title=Calmer%20than%20you%20are%2C%20dude.&amp;location=PDX&amp;gender=Sometimes&amp;date_birth=1989-08-01%2000%3A00%3A00&amp;avatar=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Favatars%2F119030%2F1hz74OV2fXDlJ5WElXRgJPTC4gcFHX6GvsrAWiYk.gif&amp;signature=&amp;post_count=4364&amp;created_at=2003-11-11%2019%3A00%3A00&amp;updated_at=2020-01-05%2002%3A13%3A17&amp;avatar_path=avatars%2F119030%2F1hz74OV2fXDlJ5WElXRgJPTC4gcFHX6GvsrAWiYk.gif&amp;cover_photo_path=covers%2F119030%2FWHGGmu3DYaHjFiFPruQuXmtmq6E0moohrRuVzBiQ.jpeg&amp;about=%3Cp%3EDr.%20Professor%20Logic%2C%20PhD.%3C%2Fp%3E&amp;social_networks%5Btwitter%5D=Lysdestic&amp;social_networks%5Bsteam%5D=Lysdestic&amp;social_networks%5Byoutube%5D=Lysdestic&amp;thread_count=100&amp;cover=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Fcovers%2F119030%2FWHGGmu3DYaHjFiFPruQuXmtmq6E0moohrRuVzBiQ.jpeg">Lysdestic</a> commented on <a href="https://www.gamefront.com/comments/896">Here&#039;s the System Requirements &amp; Crossplay Details for Halo: Reach</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@135867?user_id=171610&amp;slug=mitchell-myler&amp;display_name=Mitchell%20Myler&amp;avatar=https%3A%2F%2Fstatic.gamefront.com%2Fimages%2Fdefaults%2Favatar_default.jpg&amp;signature=&amp;post_count=0&amp;created_at=2019-10-30%2000%3A38%3A49&amp;updated_at=2019-10-30%2000%3A38%3A49&amp;about=&amp;social_networks=0&amp;thread_count=0&amp;cover=https%3A%2F%2Fstatic.gamefront.com%2Fimages%2Fdefaults%2Fprofile_default.jpg">Mitchell Myler</a> commented on <a href="https://www.gamefront.com/comments/895">Star Citizen is free to play all this week</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@83289?user_id=119030&amp;slug=lysdestic&amp;display_name=Lysdestic&amp;user_title=Calmer%20than%20you%20are%2C%20dude.&amp;location=PDX&amp;gender=Sometimes&amp;date_birth=1989-08-01%2000%3A00%3A00&amp;avatar=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Favatars%2F119030%2F1hz74OV2fXDlJ5WElXRgJPTC4gcFHX6GvsrAWiYk.gif&amp;signature=&amp;post_count=4364&amp;created_at=2003-11-11%2019%3A00%3A00&amp;updated_at=2020-01-05%2002%3A13%3A17&amp;avatar_path=avatars%2F119030%2F1hz74OV2fXDlJ5WElXRgJPTC4gcFHX6GvsrAWiYk.gif&amp;cover_photo_path=covers%2F119030%2FWHGGmu3DYaHjFiFPruQuXmtmq6E0moohrRuVzBiQ.jpeg&amp;about=%3Cp%3EDr.%20Professor%20Logic%2C%20PhD.%3C%2Fp%3E&amp;social_networks%5Btwitter%5D=Lysdestic&amp;social_networks%5Bsteam%5D=Lysdestic&amp;social_networks%5Byoutube%5D=Lysdestic&amp;thread_count=100&amp;cover=https%3A%2F%2Fstatic.gamefront.com%2Fstorage%2Fcovers%2F119030%2FWHGGmu3DYaHjFiFPruQuXmtmq6E0moohrRuVzBiQ.jpeg">Lysdestic</a> commented on <a href="https://www.gamefront.com/comments/894">The GameFront Review: The Outer Worlds</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@135753?user_id=171495&amp;slug=chris-cmi&amp;display_name=Chris%20Cmi&amp;avatar=https%3A%2F%2Fstatic.gamefront.com%2Fimages%2Fdefaults%2Favatar_default.jpg&amp;signature=&amp;post_count=0&amp;created_at=2019-10-14%2008%3A59%3A55&amp;updated_at=2019-10-14%2008%3A59%3A55&amp;about=&amp;social_networks=0&amp;thread_count=0&amp;cover=https%3A%2F%2Fstatic.gamefront.com%2Fimages%2Fdefaults%2Fprofile_default.jpg">Chris Cmi</a> commented on <a href="https://www.gamefront.com/comments/889">Microsoft Flight Simulator Insiders are taking off soon</a></p>
                
            </div>
                <p></p>
    </div>
</div>
    <!-- / #partials.sidebar.item -->
</aside>



                    </div>
                </section>
            </section>
        </main>
    
    <footer class="footer">
    <div class="footer__container">
        <div class="footer__col footer__link">
            <h3 class="footer__title">Interact</h3>
            <ul>
                <li><a href="https://www.gamefront.com/files/upload" title="Upload a File">Upload a File</a></li>
                <li><a href="https://www.gamefront.com/files" title="Latest Files">Latest Files</a></li>
                <li><a href="https://www.gamefront.com/games" title="Popular Games">Popular Games</a></li>
                <li><a href="https://www.gamefront.com/news" title="Recent Articles">Recent Articles</a></li>
                <li><a href="https://www.gamefront.com/forums" title="Gaming Forums">GamingForums</a></li>
                <li><a href="https://www.gamefront.com/missing" title="Missing Files">Missing Files</a></li>
            </ul>
        </div>
        <div class="footer__col  footer__link">
            <h3 class="footer__title">About</h3>
            <ul>
                <li><a href="https://www.gamefront.com/page/about-gamefront" title="About GameFront">About GameFront</a></li>
                <li><a href="https://www.gamefront.com/support" title="Support Desk">Support Desk</a></li>
                
                <li><a href="https://www.gamefront.com/login" title="Register with GameFront">Register</a></li>
                <li><a href="https://minecraft.gamefront.com" title="GameFront Official Minecraft Servers" rel="dofollow">Minecraft Server</a></li>
                <li><a href="https://randomga.me" title="Random Game Picker - Powered by GameFront" rel="dofollow">Random Game</a></li>
            </ul>
        </div>
        <div class="footer__col  footer__link">
            <h3 class="footer__title">DBolical</h3>
            <ul>
                <li><a href="https://www.moddb.com/" title="Games and mods development for Windows, Linux and Mac" rel="dofollow" target="_blank">ModDB</a></li>
                <li><a href="https://www.indiedb.com/" title="Rockin' Indie Games one pixel at a time" rel="dofollow" target="_blank">IndieDB</a></li>
                <li><a href="https://mod.io/" title="Mod API and SDK for game developers" rel="dofollow" target="_blank">mod.io</a></li>
                <li><a href="https://modularity.games/" title="Mobile gaming on the go" rel="dofollow" target="_blank">Modularity</a></li>
            </ul>
        </div>
        <div class="footer__col footer__col__lead">
            <h3 class="footer__title">GameFront</h3>
            <p>The best serving of video game culture, since 1998. Whether you're looking for the biggest collection of PC gaming files on the planet, tools, tips or advice, GameFront has you covered. Browse through over 150,000 mods, maps, tools and more. Game on!<br />
               <h5>
                <a href="https://www.facebook.com/GameFrontcom/" target="_blank" style="margin-left: -6px;"><i class="fab fa-facebook" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://twitter.com/gamefrontcom" target="_blank"><i class="fab fa-twitter-square" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://www.instagram.com/GameFrontcom/" target="_blank" style="margin-left: -6px;"><i class="fab fa-instagram" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://www.pinterest.com/GameFrontcom/" target="_blank" style="margin-left: -6px;"><i class="fab fa-pinterest-square" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://www.youtube.com/gamefront" target="_blank"><i class="fab fa-youtube" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://www.twitch.tv/gamefront" target="_blank"><i class="fab fa-twitch" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://steamcommunity.com/groups/filefrontgamefront" target="_blank"><i class="fab fa-steam-square" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a>
            </h5>
            </p>
        </div>
        <div class="clear"></div>
    </div>
    <div class="footer__bottom">
        <div class="footer__container">
        <p class="footer__text">
            <img src="https://static.gamefront.com/images/gf_joy_footer.png" style="vertical-align: middle;" alt="GameFront Joystick">   &copy; 1998 - 2020 DBolical Pty Ltd. All Rights Reserved. An Imperfect Product &mdash; v2.3.1. <span class="pull-right footer__terms"><a href="https://www.gamefront.com/page/privacy-policy">Privacy Policy</a> | <a href="https://www.gamefront.com/page/terms-of-service">Terms of Service</a></span>
        </p>
    </div>
</footer>


    <!-- Scripts -->
        <script src="https://static.gamefront.com/js/vendor.js?v=200106&hash=2020-v4"></script>
    <script src="https://static.gamefront.com/js/app.js?v=200106&hash=2020-v4"></script>
    
                        <script type="text/javascript" src="//platform-api.sharethis.com/js/sharethis.js#property=59fa4355ba4dac00122acaa8&product=inline-share-buttons"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/Caret.js/0.3.1/jquery.caret.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/at.js/1.5.4/js/jquery.atwho.min.js"></script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script>
    $('.box__content iframe').each(function() {
        $(this).height($(this).contents().outerHeight());
    });
</script>
        <script src="https://www.gamefront.com/js/jquery.matchHeight-min.js" charset="utf-8"></script>
        
    
    
</body>
</html>
