<!DOCTYPE html>
<html lang="en">
<head>
    <!-- www.gamefront.com -->
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="keywords" content="pc, games, files, downloads, filefront, addons, client, demos, mods, freeware, maps, patches, skins, tools" />
    
    <meta name="google-site-verification" content="7OirSWKtBXIQuF-sYCPC03ssjdzO7j5sKB8ICeenioA" />
    <meta name="msvalidate.01" content="76D3260E07746F825E07DBA5EFD839EC" />
    
    <meta name="theme-color" content="#e38229">

    <meta name="p:domain_verify" content="1adbe29b46e8291d52b2235c310eb264"/>


        <!--- INDEX TEST CHECK START - DOMAIN IS www.gamefront.com  --->
            <!--- Main URL Detected --->
            <!--- INDEX TEST CHECK END --->
    <meta name="msapplication-config" content="/browserconfig.xml" />
    <link rel="icon" href="https://static.gamefront.com/images/favicons/favicon.ico" type="image/x-icon" />
    <link rel="icon" href="https://static.gamefront.com/images/favicons/favicon.png" type="image/png" sizes="96x96" />
    <link rel="icon" href="https://static.gamefront.com/images/favicons/favicon-2020-192x192.png" type="image/png" sizes="192x192" />
    <link rel="apple-touch-icon" href="https://static.gamefront.com/images/favicons/apple-touch-icon-2020.png" sizes="180x180" />


    <!-- CSRF Token -->
    <meta name="csrf-token" content="JcYgIQeSebqVSnjkUxtCcCLmXDOP1bA04GbXLhiE">
    
    
    <title>Guild Wars 2 getting Autumn and Winter Updates galore! - News - Guild Wars 2 - GameFront</title>
<meta name="description" content="Guild Wars 2 is going to be getting a load of updates during the Autumn and Winter for players to look forward to, the content just seems to keep on rolling!The team are currently working through the feedback they received from the elite specialization and are gearing up for the second and third bet...">
<link rel="canonical" href="https://www.gamefront.com/games/guild-wars-2/article/guild-wars-2-autumn-and-winter-updates-galore"/>
<meta property="og:title" content="Guild Wars 2 getting Autumn and Winter Updates galore! - News - Guild Wars 2 - GameFront" />
<meta property="og:description" content="Guild Wars 2 is going to be getting a load of updates during the Autumn and Winter for players to look forward to, the content just seems to keep on rolling!The team are currently working through the feedback they received from the elite specialization and are gearing up for the second and third bet..." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.gamefront.com/games/guild-wars-2/article/guild-wars-2-autumn-and-winter-updates-galore" />
<meta property="og:site_name" content="GameFront" />
<meta property="og:image" content="https://www.gamefront.com/storage/images/articles/5wl95x5ppxJfM6O6Bsl41RJRCLycSEqXNkG0tk2H.jpg" />
<meta property="article:published_time" content="2021-08-25 11:05:30" />
<meta property="article:modified_time" content="2021-08-25 20:00:13" />
<meta property="og:author:username" content="Digz" />

<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@GameFrontCom" />
<meta name="twitter:title" content="Guild Wars 2 getting Autumn and Winter Updates galore! - News - Guild Wars 2" />
<meta name="twitter:description" content="Guild Wars 2 is going to be getting a load of updates during the Autumn and Winter for players to look forward to, the content just seems to keep on rolling!The team are currently working through the feedback they received from the elite specialization and are gearing up for the second and third bet..." />
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"WebPage","name":"Guild Wars 2 getting Autumn and Winter Updates galore! - News - Guild Wars 2","description":"Guild Wars 2 is going to be getting a load of updates during the Autumn and Winter for players to look forward to, the content just seems to keep on rolling!The team are currently working through the feedback they received from the elite specialization and are gearing up for the second and third bet..."}</script>
    
    <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"Organization","name":"GameFront","url":"https:\/\/www.gamefront.com","logo":"https:\/\/static.gamefront.com\/images\/logo.svg","contactPoint":{"@type":"ContactPoint","areaServed":"Worldwide","url":"https:\/\/www.gamefront.com\/support","contactType":"customer service"}}</script>
    <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"WebSite","name":"GameFront","url":"https:\/\/www.gamefront.com","sameAs":["https:\/\/www.facebook.com\/gamefrontcom","https:\/\/www.twitter.com\/gamefrontcom","https:\/\/www.youtube.com\/gamefront","https:\/\/steamcommunity.com\/groups\/filefrontgamefront","https:\/\/plus.google.com\/+gamefront","https:\/\/en.wikipedia.org\/wiki\/GameFront"]}</script>
    
        <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"NewsArticle","headline":"Guild Wars 2 getting Autumn and Winter Updates galore!","url":"https:\/\/www.gamefront.com\/games\/guild-wars-2\/article\/guild-wars-2-autumn-and-winter-updates-galore","articleBody":"<p>Guild Wars 2 is going to be getting a load of updates during the Autumn and Winter for players to look forward to, the content just seems to keep on rolling!<\/p><p><img src=\"https:\/\/d3b4yo2b5lbfy.cloudfront.net\/wp-content\/uploads\/2021\/08\/bae65210824-GW2-Fall-Winter-Roadmap-SOCIAL_EN.jpg\" style=\"width: 443px;\" class=\"fr-fic fr-dib\"><\/p><p>The team are currently working through the feedback they received from the elite specialization and are gearing up for the second and third beta events for new elite specialisations to try out alongside the new expansion packs elite specialisations in the fourth beta event. The second beta date is the 21 September, followed by beta three on the 26 October and the fourth beta on 30 November which will also include the new siege turtle mount.<\/p><p>This week players will face the first episode of Season 4 \"Daybreak\" in the Living World and an episode will be released each week in September.&nbsp;<\/p><p>Much needed World vs World restructuring is in full swing with the changes looking to be tested in a beta on 24 September with some substantial updates to server infrastructure being rolled out on 31 August. Players should not notice anything as these changes take place in the live environment. An update will be on the way soon to find out the full details of the World vs World changes in early September.<\/p><p>Don't forget festivals too in the midst of all these updates such as Halloween, Wintersday and Lunar New Year as well as the bonus events for World vs World and Season 20 of PvP.<\/p><p>With so much content on the horizon it's going to be a busy time for the developer team but also players too! Before you log back in to Guild Wars 2 check out the expansion trailer below:<\/p><p><span class=\"fr-video fr-fvc fr-dvb fr-draggable\" contenteditable=\"false\" draggable=\"true\"><iframe width=\"640\" height=\"360\" src=\"https:\/\/www.youtube.com\/embed\/pgcW3yoW82s?wmode=opaque\" frameborder=\"0\" allowfullscreen=\"\" class=\"fr-draggable\"><\/iframe><\/span><\/p><p>Check out the full details of all the changes posted above&nbsp;<a href=\"https:\/\/www.guildwars2.com\/en\/news\/guild-wars-2-live-fall-and-winter-2021\/\" rel=\"noopener noreferrer nofollow\" target=\"_blank\">here<\/a>.<\/p>","author":{"@type":"Person","name":"Digz","image":"https:\/\/static.gamefront.com\/storage\/avatars\/157735\/7So7jQxkt47ZTHZ0dMZRMqSXzOQVCgACa2VJiUa3.png"},"datePublished":"2021-08-25 11:05:30","dateModified":"2021-08-25 20:00:13","image":{"@type":"ImageObject","url":"https:\/\/www.gamefront.com\/storage\/images\/articles\/5wl95x5ppxJfM6O6Bsl41RJRCLycSEqXNkG0tk2H.jpg"},"publisher":{"@type":"Organization","name":"GameFront","url":"https:\/\/www.gamefront.com","logo":{"@type":"ImageObject","url":"https:\/\/static.gamefront.com\/images\/gf_social_header_new.jpg"}}}</script>

    <link rel="preconnect" href="https://tags.bkrtx.com/">
    <link rel="preconnect" href="https://securepubads.g.doubleclick.net/" crossorigin>

    <link href="https://fonts.googleapis.com/css?family=Roboto:300,400,700" rel="stylesheet">
    
    <link href="https://www.gamefront.com/css/leaguegothic-dev.css?hash=2021-v9" rel="stylesheet">
    
    
    

    <link rel="alternate" type="application/atom+xml" href="https://www.gamefront.com/feed/files" title="Latest Files - GameFront">
    <link rel="alternate" type="application/atom+xml" href="https://www.gamefront.com/feed/threads" title="Latest Threads - GameFront">
    <link rel="alternate" type="application/atom+xml" href="https://www.gamefront.com/feed/news" title="Latest News - GameFront">

    <!-- Styles -->
        <link href="https://static.gamefront.com/css/themes/gamefront-v1.css?v=210826&hash=2021-v9" rel="stylesheet">
    <link href="https://static.gamefront.com/css/vendor.css?v=210826&hash=2021-v9" rel="stylesheet">
        <meta name="theme-color" content="#484035">
<style>
        body {
        background-color: #322c25 !important;
    }
    .header__alt {
                background: linear-gradient(rgba(72,64,53,0.7), rgba(0,0,0,0.6)), url(https://static.gamefront.com/storage/images/games/bgX8vBYAuBjLP1hQISXu2410WHBq91Cu4Uvw3U46.jpeg);
                background-size: cover;
        background-position: center top;
    }
    .subnav {
        background-color: rgba(72,64,53,0.8);;
    }
    .menu__item:hover > ul {
        background-color: rgba(72,64,53,1);;
    }
    .menu__container {
        background-color: rgba(57,51,42,0.6);
    }
    .profile__game_name {
        background-color: rgba(72,64,53,0.6);;
    }
    .box {
        border-color: #484035;
    }
    .button, .swal-button, input[type="submit"] {
        background-image: linear-gradient(-135deg, #484035 0%, #39332a 100%);
    }
    .card__image--no-thumbnail {
        background-color: rgba(72,64,53,0.8);;
    }
    .mobile-menu ul li a:after {
        background: #872816 !important;
    }
    .mobile-menu {
        background: #484035;
    }
    a:hover {
        color: #484035;
    }
    hr {
        border-color: #484035;
    }
    
            a, i {
        color: #872816;
    }
    .button:hover, .swal-button:hover, input[type="submit"]:hover {
        background-image: linear-gradient(-135deg, #872816 0%, #5e1c0f 100%);
    }
    </style>
    <style>
    .header__alt {
        background: linear-gradient(rgba(72,64,53,0.7), rgba(0,0,0,0.6)), url(https://static.gamefront.com/storage/images/articles/5wl95x5ppxJfM6O6Bsl41RJRCLycSEqXNkG0tk2H.jpg);
        background-size: cover;
        background-position: center top;
    }

    </style>

    <!-- Scripts -->
    <script>
        window.Laravel = {"csrfToken":"JcYgIQeSebqVSnjkUxtCcCLmXDOP1bA04GbXLhiE"};
        window.App = {"homeUrl":"https:\/\/www.gamefront.com","signedIn":false,"user":null}
    </script>
        <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-104975-22"></script>
    <script>
      window.dataLayer = window.dataLayer || [];
      function gtag(){dataLayer.push(arguments);}
      gtag('js', new Date());

      gtag('config', 'UA-104975-22');
    </script>

        <!-- Begin ComScore Tag -->
    <script>
    !function(o,n){if(o._localCS={consent:null,loaded:!1,tx:null},o._comscore=o._comscore||[],o.__cmp){
    o.__cmp("getVendorConsents",[77],function(o,c){function e(o){return"object"==typeof o}c&&(_localCS.consent=e(o)
    &&e(o.vendorConsents)&&o.vendorConsents[77],_localCS.consent=_localCS.consent?"1":"0",t())}),function c(){
    o.__cmp("ping",null,function(o){if(!1===o.cmpLoaded){if(null===_localCS.tx)return void(_localCS.tx=setTimeout(c,3e3));
    t()}o.cmpLoaded&&(clearTimeout(_localCS.tx),t())})}()}function t(){var o,c,e;_localCS.loaded||
    (_comscore.push({c1:"2",c2:"25110922",cs_ucfr:_localCS.consent}),c=(o=n).createElement("script"),
    e=o.getElementsByTagName("script")[0],c.async=!0,c.src=("https:"==o.location.protocol?"https://sb":"http://b")
    +".scorecardresearch.com/beacon.js",e.parentNode.insertBefore(c,e),_localCS.loaded=!0)}o.__cmp||t()}(window,document);
    </script>
    <noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=25110922&cv=2.0&cj=1" /></noscript>
    <!-- End ComScore Tag -->

    <script>window.AdSlots = window.AdSlots || {cmd: [], disableScripts: ['gpt','bk']};</script>
    <script async src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
    <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>

    <script src="https://static.gamefront.com/js/gamefront.min.js?v=210826&hash=2021-v9" async></script>
    
    <!-- Vue Scripts Injected -->

<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="showArticle">
                <header class="header__alt">
        <div class="header__container">
            <div class="header__logo">
                <a href="https://www.gamefront.com">
                                        <img src="https://static.gamefront.com/images/logo.svg" alt="GameFront">
                                    </a>
            </div>
            <ul class="menu__right">
                                    <li class="menu__item">

                        <a href="https://www.gamefront.com/login" class="menu__link"><i class="fa fa-key"></i> Login</a> 
                        <a href="https://www.gamefront.com/register" class="menu__link"><i class="fa fa-user-plus"></i> Register</a>
                    </li>
                                <li class="menu__item">
                                        <a href="https://www.gamefront.com/upload?guild-wars-2" class="button icon upload">
                        <i class="fa fa-cloud-upload-alt" aria-hidden="true" style="color: #fff;"></i> Upload File
                    </a>
                                    </li>
            </ul>
        </div>
        <div class="header__menu">
            <div class="menu__container">

                <div class="mobile_toggle">
                    <span></span>
                    <span></span>
                    <span></span>
                </div>

                <nav class="responsive-nav">
                    <div class="responsive-nav__close">
                        <a class="">&times;</a>
                    </div>
                    <div class="responsive-nav__logo">
                        <a href="https://www.gamefront.com">
                            <img src="https://static.gamefront.com/images/logo.svg" alt="GameFront Logo" class="logo-img">
                        </a>
                    </div>
                    <ul class="mobile-menu">
                                                    <li class="mobile-menu__item">
                                     <a href="/login"><i class="fa fa-user-circle"></i> Log-in / Register!</a>
                                </li>
                                        </ul>
                    <ul class="mobile-menu">
    <li class="mobile-menu__item ">
        <a href="https://www.gamefront.com" class="mobile-menu__link">
            <i class="fa fa-home"></i>
            Home
        </a>
    </li>

    <li class="mobile-menu__item  mobile-menu__item--has-children">
        <a href="https://www.gamefront.com/files" class="mobile-menu__link">
            <i class="fas fa-file-archive"></i>
            Files
        </a>
        <ul class="mobile-menu">
            <li class="mobile-menu__item">
                <a href="https://www.gamefront.com/files" class="mobile-menu__link">All Files</a>
                <a href="https://www.gamefront.com/files/top" class="mobile-menu__link">Top Files</a>
                <a href="https://www.gamefront.com/files/demos" class="mobile-menu__link">Demos</a>
                <a href="https://www.gamefront.com/files/patches" class="mobile-menu__link">Patches</a>
                <a href="https://www.gamefront.com/files/tools" class="mobile-menu__link">Tools</a>
                
                <a href="https://www.gamefront.com/files/upload" class="mobile-menu__link">Upload File</a>

                
            </li>
        </ul>
    </li>

    <li class="mobile-menu__item  mobile-menu__item--has-children ">
        <a href="https://www.gamefront.com/games" class="mobile-menu__link">
            <i class="fa fa-gamepad"></i>
            Games
        </a>
        <ul class="mobile-menu">
            <li class="mobile-menu__item">
                <a href="https://www.gamefront.com/games" class="mobile-menu__link">All Games</a>
                <a href="https://www.gamefront.com/files/upload" class="mobile-menu__link">Upload File</a>
            </li>
        </ul>
    </li>

    <li class="mobile-menu__item   mobile-menu__item--has-children-active mobile-menu__item--active ">
        <a href="https://www.gamefront.com/news" class="mobile-menu__link">
            <i class="fas fa-newspaper"></i>
            Articles
        </a>
        <ul class="mobile-menu">
            <li class="mobile-menu__item">
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/gaming-industry-news" class="mobile-menu__link">Industry News</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/modding-news-1" class="mobile-menu__link">Modding News</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/walkthroughs" class="mobile-menu__link">Walkthroughs</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/essential-mods" class="mobile-menu__link">Essential Mods</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/game-deals" class="mobile-menu__link">Game Deals</a>
                <a href="https://www.gamefront.com/news" class="mobile-menu__link">All Articles</a>
            </li>
        </ul>
    </li>


    <li class="mobile-menu__item  mobile-menu__item--has-children ">
        <a href="https://www.gamefront.com/videos" class="mobile-menu__link">
            <i class="fas fa-play-circle"></i>
            Videos
        </a>
    <ul class="mobile-menu">
        <li class="mobile-menu__item">
            <a href="https://www.gamefront.com/videos" class="mobile-menu__link">Browse Videos</a>
            <a href="https://www.gamefront.com/files/upload" class="mobile-menu__link">Upload Video</a>
            <a href="https://www.youtube.com/gamefront" class="mobile-menu__link">YouTube Channel</a>
        </li>
    </ul>
    </li>


    <li class="mobile-menu__item  mobile-menu__item--has-children ">
        <a href="https://forums.gamefront.com" class="mobile-menu__link">
            <i class="fas fa-comments-alt"></i>
            Community
        </a>
        <ul class="mobile-menu">
            <li class="mobile-menu__item">
                <a href="https://forums.gamefront.com" class="mobile-menu__link">Gaming Forums</a>
                <a href="https://forums.gamefront.com/forums/search/latest" class="mobile-menu__link">Latest Threads</a>
                <a href="https://discord.me/gamefront" class="mobile-menu__link" target="_blank">Discord Server</a>
                <a href="/page/the-gamefront-code-of-conduct" class="mobile-menu__link">Code of Conduct</a>
                <a href="https://www.gamefront.com/community/members" class="mobile-menu__link">User Directory</a>
            </li>
        </ul>
    </li>

    <li class="mobile-menu__item  mobile-menu__item--has-children ">
        <a href="https://www.gamefront.com/support" class="mobile-menu__link">
            <i class="fas fa-envelope-open-text"></i>
            Support
        </a>
        <ul class="mobile-menu">
            <li class="mobile-menu__item">
                <a href="https://www.gamefront.com/support/create" class="mobile-menu__link">Contact Us</a>
                <a href="https://www.gamefront.com/support" class="mobile-menu__link">My Tickets</a>
                <a href="https://www.gamefront.com/support/knowledgebase" class="mobile-menu__link">Knowledge Base</a>
                <a href="https://forums.gamefront.com/gamefront-development-support/create" class="mobile-menu__link">Feedback</a>
            </li>
        </ul>
    </li>
    
        
</ul>
                </nav>

                    
                    <ul class="menu">
    <li class="menu__item ">
        <a href="https://www.gamefront.com" class="menu__link">
            <i class="fa fa-home"></i>
            Home
        </a>
    </li>

    <li class="menu__item  menu__item--has-children">
        <a href="https://www.gamefront.com/files" class="menu__link">
            <i class="fas fa-file-archive"></i>
            Files
        </a>
        <ul class="menu">
            <li class="menu__item">
                <a href="https://www.gamefront.com/files" class="menu__link">All Files</a>
                <a href="https://www.gamefront.com/files/top" class="menu__link">Top Files</a>
                <a href="https://www.gamefront.com/files/demos" class="menu__link">Demos</a>
                <a href="https://www.gamefront.com/files/patches" class="menu__link">Patches</a>
                <a href="https://www.gamefront.com/files/tools" class="menu__link">Tools</a>
                
                <a href="https://www.gamefront.com/files/upload" class="menu__link">Upload File</a>

                
            </li>
        </ul>
    </li>

    <li class="menu__item  menu__item--has-children ">
        <a href="https://www.gamefront.com/games" class="menu__link">
            <i class="fa fa-gamepad"></i>
            Games
        </a>
        <ul class="menu">
            <li class="menu__item">
                <a href="https://www.gamefront.com/games" class="menu__link">All Games</a>
                <a href="https://www.gamefront.com/files/upload" class="menu__link">Upload File</a>
            </li>
        </ul>
    </li>

    <li class="menu__item   menu__item--has-children-active menu__item--active ">
        <a href="https://www.gamefront.com/news" class="menu__link">
            <i class="fas fa-newspaper"></i>
            Articles
        </a>
        <ul class="menu">
            <li class="menu__item">
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/gaming-industry-news" class="menu__link">Industry News</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/modding-news-1" class="menu__link">Modding News</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/walkthroughs" class="menu__link">Walkthroughs</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/essential-mods" class="menu__link">Essential Mods</a>
                <a href="https://www.gamefront.com/games/gamingtoday/news/category/game-deals" class="menu__link">Game Deals</a>
                <a href="https://www.gamefront.com/news" class="menu__link">All Articles</a>
            </li>
        </ul>
    </li>


    <li class="menu__item  menu__item--has-children ">
        <a href="https://www.gamefront.com/videos" class="menu__link">
            <i class="fas fa-play-circle"></i>
            Videos
        </a>
    <ul class="menu">
        <li class="menu__item">
            <a href="https://www.gamefront.com/videos" class="menu__link">Browse Videos</a>
            <a href="https://www.gamefront.com/files/upload" class="menu__link">Upload Video</a>
            <a href="https://www.youtube.com/gamefront" class="menu__link">YouTube Channel</a>
        </li>
    </ul>
    </li>


    <li class="menu__item  menu__item--has-children ">
        <a href="https://forums.gamefront.com" class="menu__link">
            <i class="fas fa-comments-alt"></i>
            Community
        </a>
        <ul class="menu">
            <li class="menu__item">
                <a href="https://forums.gamefront.com" class="menu__link">Gaming Forums</a>
                <a href="https://forums.gamefront.com/forums/search/latest" class="menu__link">Latest Threads</a>
                <a href="https://discord.me/gamefront" class="menu__link" target="_blank">Discord Server</a>
                <a href="/page/the-gamefront-code-of-conduct" class="menu__link">Code of Conduct</a>
                <a href="https://www.gamefront.com/community/members" class="menu__link">User Directory</a>
            </li>
        </ul>
    </li>

    <li class="menu__item  menu__item--has-children ">
        <a href="https://www.gamefront.com/support" class="menu__link">
            <i class="fas fa-envelope-open-text"></i>
            Support
        </a>
        <ul class="menu">
            <li class="menu__item">
                <a href="https://www.gamefront.com/support/create" class="menu__link">Contact Us</a>
                <a href="https://www.gamefront.com/support" class="menu__link">My Tickets</a>
                <a href="https://www.gamefront.com/support/knowledgebase" class="menu__link">Knowledge Base</a>
                <a href="https://forums.gamefront.com/gamefront-development-support/create" class="menu__link">Feedback</a>
            </li>
        </ul>
    </li>
    
    
                        
</ul>

                
                <div class="header__online">
                    <span>
                        <span title="Guests Online" class="status-online"></span> 1,532 ONLINE
                    </span>
                </div>
                
            </div>
        </div>

            <div class="hero" id="hero">
    <div class="hero__container">
        <div class="hero__content">
            <h1 class="hero__heading" v-pre>
                Guild Wars 2 getting Autumn and Winter Updates galore!
            </h1>
            <p v-pre><p>
                <follow-button id="78735" type="article"></follow-button>
                            </p></p>
        </div>
        <div class="hero__search" v-pre>
            
        </div>
        <div class="hero__extra" v-pre>
            
        </div>
    </div>
</div>

            <section class="subnav subnav__alt">
    <div class="subnav__container">
        <nav class="breadcrumbs">
            <ul class="breadcrumbs__menu">
                                <li class="breadcrumbs__item">
                    <a href="https://www.gamefront.com" class="breadcrumbs__link" v-pre>GameFront.com</a>
                </li>
                                <li class="breadcrumbs__item">
                    <a href="https://www.gamefront.com/games" class="breadcrumbs__link" v-pre>Games</a>
                </li>
                                <li class="breadcrumbs__item">
                    <a href="https://www.gamefront.com/games/guild-wars-2" class="breadcrumbs__link" v-pre>Guild Wars 2</a>
                </li>
                                <li class="breadcrumbs__item">
                    <a href="https://www.gamefront.com/games/guild-wars-2/news/category/news-4" class="breadcrumbs__link" v-pre>News</a>
                </li>
                                <li class="breadcrumbs__item">
                    <a href="" class="breadcrumbs__link" v-pre>Guild Wars 2 getting Autumn and Winter Updates galore!</a>
                </li>
                            </ul>
        </nav>
    </div>
</section>

    </header>
    

    <div class="blackout"></div>
    <div class="whiteout"></div>
    <div class="loader">
        <div class="loader__box">
            <div class="loader__content"> 
                <i class="fa fa-spinner fa-pulse fa-3x fa-fw"></i>
                <h3>
                                        Please wait...
                </h3>
            </div>
        </div>
    </div>

    <div class="site__container">
        <div class="site__content">
            <div class="box" style="background-color: rgb(220, 220, 220); padding: 0;text-align: center;text-decoration: none;">
                <div id="nn_lb1" style="padding: 1.5rem 0;"></div>
                <div id="nn_mobile_mpu1"></div>
                <div id="nn_mobile_lb1_sticky"></div>
            </div>
        </div>
    </div>
    
    
    <div class="site__container">
        <div class="site__content" id="patreon-banner" style="display:none">
            <div class="box" style="background-color: rgb(220, 220, 220); padding: 0;text-align: center;text-decoration: none;">
                <a href="https://www.patreon.com/gamefront" target="_blank" rel="nofollow">
                    <div class="alert alert-info" style="margin: 0;background-color: #052d49;text-decoration: none;">
                        <i class="fab fa-patreon" style="display: inline-block;vertical-align: middle;"></i><p style="display: inline-block;vertical-align: middle;"> GameFront offers free file hosting, without speed caps or download limits! If you enjoy GameFront, please consider <strong><span style="background-color: #f96854;padding: 0 1rem;display: inline-flex;align-items: center;justify-content: center;margin: 0 1rem;">supporting us on Patreon <i class="fas fa-arrow-right"></i></span></strong>   
                        </p>
                    </div>
                </a>
            </div>
        </div>
    </div>
    

        
                    <div id="nn_skinl"></div>
                <main class="site">
            <section class="site__container">
                <section class="site__content">
                    <div class="box box--no-padding box--no-border" style="background-color: #EEE;">
                        <section class="gamefront__site-content matchheight" style="background-color: #fff !important;">
    <div class="box">
        
        
                <span class="box__title">
            <i class="fal fa-newspaper"></i>
                            Published by
            
                        <a href="https://www.gamefront.com/@digz">Digz</a>
            
            <span data-toggle="tooltip" data-placement="top" title="25th August 2021 19:08" >
                21 hours ago
            </span>

                            , last updated
                <span data-toggle="tooltip" data-placement="top" title="25th August 2021 19:08" >
                    21 hours ago
                </span>
                    </span>
        

        <div class="box__content fr-view article__content">
                        <p>Guild Wars 2 is going to be getting a load of updates during the Autumn and Winter for players to look forward to, the content just seems to keep on rolling!</p><p><img src="https://d3b4yo2b5lbfy.cloudfront.net/wp-content/uploads/2021/08/bae65210824-GW2-Fall-Winter-Roadmap-SOCIAL_EN.jpg" style="width: 443px;" class="fr-fic fr-dib"></p><p>The team are currently working through the feedback they received from the elite specialization and are gearing up for the second and third beta events for new elite specialisations to try out alongside the new expansion packs elite specialisations in the fourth beta event. The second beta date is the 21 September, followed by beta three on the 26 October and the fourth beta on 30 November which will also include the new siege turtle mount.</p><p>This week players will face the first episode of Season 4 "Daybreak" in the Living World and an episode will be released each week in September.&nbsp;</p><p>Much needed World vs World restructuring is in full swing with the changes looking to be tested in a beta on 24 September with some substantial updates to server infrastructure being rolled out on 31 August. Players should not notice anything as these changes take place in the live environment. An update will be on the way soon to find out the full details of the World vs World changes in early September.</p><p>Don't forget festivals too in the midst of all these updates such as Halloween, Wintersday and Lunar New Year as well as the bonus events for World vs World and Season 20 of PvP.</p><p>With so much content on the horizon it's going to be a busy time for the developer team but also players too! Before you log back in to Guild Wars 2 check out the expansion trailer below:</p><p><span class="fr-video fr-fvc fr-dvb fr-draggable" contenteditable="false" draggable="true"><iframe width="640" height="360" src="https://www.youtube.com/embed/pgcW3yoW82s?wmode=opaque" frameborder="0" allowfullscreen="" class="fr-draggable"></iframe></span></p><p>Check out the full details of all the changes posted above&nbsp;<a href="https://www.guildwars2.com/en/news/guild-wars-2-live-fall-and-winter-2021/" rel="noopener noreferrer nofollow" target="_blank">here</a>.</p>
                    </div>
    </div>
    <div style="padding: 0; margin-bottom: 15px; text-align: center;text-decoration: none;">
    <div id="nn_lb2" style="padding: 1.5rem 0;"></div>
</div>
    <div class="box">
        <span class="box__title">
            <i class="fa fa-comments"></i> Comments on this Article
        </span>
                    <div class="box__content">
        <p>There are no comments yet. Be the first!</p>
    </div>
            <div class="box__content">
    <div class="panel panel-default">
        <div class="panel-body">
            <div class="social-auth">
                <p class="lead">Please <a href="/login">sign in</a> to participate in this discussion.</p>
                
                <!-- Socialauth Facebook -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/facebook" aria-label="Sign in with Facebook Account">
    <div class="resp-social-button resp-social-button--facebook resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-facebook" aria-hidden="true" style="margin: 1rem;"></i>
        </div>
    </div>
</a>

<!-- Socialauth Google -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/google" aria-label="Sign in with Google Account">
    <div class="resp-social-button resp-social-button--google resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-google" aria-hidden="true" style="margin: 1rem;"></i>
        </div>
    </div>
</a>

<!-- Socialauth Twitter -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/twitter" aria-label="Sign in with Twitter Account">
    <div class="resp-social-button resp-social-button--twitter resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-twitter" aria-hidden="true"  style="margin: 1rem;"></i>
        </div>
    </div>
</a>

<!-- Socialauth Steam -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/steam" aria-label="Sign in with Steam Account">
    <div class="resp-social-button resp-social-button--steam resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-steam" aria-hidden="true"  style="margin: 1rem;"></i>
        </div>
    </div>
</a>

<!-- Socialauth Microsoft -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/live" aria-label="Sign in with Microsoft Account">
    <div class="resp-social-button resp-social-button--microsoft resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-windows" aria-hidden="true"  style="margin: 1rem;"></i>
        </div>
    </div>
</a>


<!-- Socialauth Twitch -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/twitch" aria-label="Sign in with Twitch Account">
    <div class="resp-social-button resp-social-button--twitch resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-twitch" aria-hidden="true"  style="margin: 1rem;"></i>
        </div>
    </div>
</a>

<!-- Socialauth Discord -->
<a class="resp-social-button__link" href="https://www.gamefront.com/login/discord" aria-label="Sign in with Discord Account">
    <div class="resp-social-button resp-social-button--discord resp-social-button--large">
        <div aria-hidden="true" class="resp-social-button__icon resp-social-button__icon--solid">
            <i class="fab fa-discord" aria-hidden="true"  style="margin: 1rem;"></i>
        </div>
    </div>
</a>
            </div>
        </div>
    </div>
</div>

                
    </div>
</section>

<aside class="gamefront__site-sidebar matchheight">
    <!-- #partials.sidebar.item -->
    <div class="sidebar__item">

        <div class="box box__alpha">
    <span class="box__title"><i class="fa fa-share"></i> Share This Article</span>
    <div class="box__content">
        <div class="sharethis-inline-share-buttons"></div>
                        <div id="app">
                    <share-short-url :url="['https://www.gamefront.com/games/guild-wars-2/article/guild-wars-2-autumn-and-winter-updates-galore']"></share-short-url>
                </div>
            </div>
</div>

        <div  style="display: -webkit-flex;display: -moz-flex;display: -ms-flex;display: -o-flex;display: flex;-ms-align-items: center;align-items: center;
    justify-content: center;"><div id="nn_mpu1"></div><div id="nn_mobile_mpu2"></div></div>

        <div class="box box__alpha">
            <span class="box__title"><i class="fa fa-list"></i> Categories</span>
            <div class="table-responsive">
                <table class="table table-hover">
                                                                        <tr>
                                <td>
                                    <a href="https://www.gamefront.com/games/guild-wars-2/news/category/news-4">
                                        <i class="fa fa-newspaper" style="margin:0;"></i> 
                                        <span style="font-weight: bold;">News</span>
                                    </a>
                                </td>
                            </tr>
                                                            </table>
            </div>
        </div>
    </div>
    <!-- / #partials.sidebar.item -->
<div  style="display: -webkit-flex;display: -moz-flex;display: -ms-flex;display: -o-flex;display: flex;-ms-align-items: center;align-items: center;
    justify-content: center;"><div id="nn_mpu2"></div></div>    <!-- #partials.sidebar.item -->
    <div class="sidebar__item">
    <div class="box box__alpha">
        <span class="box__title"><i class="fa fa-comments"></i> Latest Comments</span>
        <p></p>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@mikey">Mikey</a> commented on <a href="https://www.gamefront.com/comments/f/5360321">Destiny 2 leak indicates long awaited &quot;BattlEye&quot; Anti-Cheat is coming soon</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@lr227s-at-gmailcom">Redlin5</a> commented on <a href="https://www.gamefront.com/comments/1370">Steam Deck: everything you need to know about Valve&#039;s new handheld</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@lr227s-at-gmailcom">Redlin5</a> commented on <a href="https://www.gamefront.com/comments/1369">Classified military documents leak in War Thunder realism debate</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@guynamederick">GuyNamedErick</a> commented on <a href="https://www.gamefront.com/comments/1355">Team Fortress 2&#039;s latest patch tried to stomp out bots and failed</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@guynamederick">GuyNamedErick</a> commented on <a href="https://www.gamefront.com/comments/1354">Console players are having a rough time in Overwatch crossplay</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@pcgamepure">PC Game Pure</a> commented on <a href="https://www.gamefront.com/comments/1316">Our Top 8 GTA V Mods to Download in 2021</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@guynamederick">GuyNamedErick</a> commented on <a href="https://www.gamefront.com/comments/1311">Gotham Knights has been delayed until next year</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@guynamederick">GuyNamedErick</a> commented on <a href="https://www.gamefront.com/comments/1310">Microsoft is renaming Xbox Live to Xbox Network because reasons</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@guynamederick">GuyNamedErick</a> commented on <a href="https://www.gamefront.com/comments/1309">Serious Sam 2 gets a surprise major update after 15 years</a></p>
                
            </div>
                    <div class="latest-threads__item ">
                                    <p><a href="https://www.gamefront.com/@zipacna">Zipacna</a> commented on <a href="https://www.gamefront.com/comments/1295">Battle for Middle Earth: Reforged is a stunning Unreal Engine 4 remake</a></p>
                
            </div>
                <p></p>
    </div>
</div>
    <!-- / #partials.sidebar.item -->
</aside>



                    </div>
                </section>
            </section>
        </main>
                <div id="nn_skinr"></div>
            
    <footer class="footer">
    <div class="footer__container">
        <div class="footer__col footer__link">
            <h3 class="footer__title">Interact</h3>
            <ul>
                <li><a href="https://www.gamefront.com/files/upload" title="Upload a File">Upload a File</a></li>
                <li><a href="https://www.gamefront.com/files" title="Latest Files">Latest Files</a></li>
                <li><a href="https://www.gamefront.com/games" title="Popular Games">Popular Games</a></li>
                <li><a href="https://www.gamefront.com/news" title="Recent Articles">Recent Articles</a></li>
                <li><a href="https://forums.gamefront.com" title="Gaming Forums">GamingForums</a></li>
                <li><a href="https://www.gamefront.com/missing" title="Missing Files">Missing Files</a></li>
            </ul>
        </div>
        <div class="footer__col  footer__link">
            <h3 class="footer__title">About</h3>
            <ul>
                <li><a href="https://www.gamefront.com/page/about-gamefront" title="About GameFront">About GameFront</a></li>
                <li><a href="https://www.gamefront.com/support" title="Support Desk">Support Desk</a></li>
                
                <li><a href="https://www.gamefront.com/login" title="Register with GameFront">Register</a></li>
                <li><a href="https://www.teespring.com/stores/gamefront-swag" title="Get Gamefront Merch" rel="dofollow">GameFront Merch</a></li>
                <li><a href="https://minecraft.gamefront.com" title="GameFront Official Minecraft Servers" rel="dofollow">Minecraft Server</a></li>
                <li><a href="https://randomga.me" title="Random Game Picker - Powered by GameFront" rel="dofollow">Random Game</a></li>
            </ul>
        </div>
        <div class="footer__col  footer__link">

        </div>
        <div class="footer__col footer__col__lead">
            <h3 class="footer__title">GameFront</h3>
            <p>Originally known as FileFront, GameFront has been serving up the very best mods, maps, skins, tools, and utilities since 1998. Since 2010, we've also been bringing you the very best in gaming culture, short-form reporting and video content! <br />
               <h5>
                <a href="https://www.facebook.com/GameFrontcom/" target="_blank" style="margin-left: -6px;"><i class="fab fa-facebook" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://twitter.com/gamefrontcom" target="_blank"><i class="fab fa-twitter-square" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://www.instagram.com/GameFrontcom/" target="_blank" style="margin-left: -6px;"><i class="fab fa-instagram" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://www.pinterest.com/GameFrontcom/" target="_blank" style="margin-left: -6px;"><i class="fab fa-pinterest-square" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://www.youtube.com/gamefront" target="_blank"><i class="fab fa-youtube" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://www.twitch.tv/gamefront" target="_blank"><i class="fab fa-twitch" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a> <span style="color: #ccc">|</span>
                <a href="https://steamcommunity.com/groups/filefrontgamefront" target="_blank"><i class="fab fa-steam-square" aria-hidden="true" style="margin: 1rem; color: #fff;"></i></a>
            </h5>
            </p>
        </div>
        <div class="clear"></div>
    </div>
    <div class="footer__bottom">
        <div class="footer__container">
        <p class="footer__text">
            <img src="https://static.gamefront.com/images/gf_joy_footer.png" style="vertical-align: middle;" alt="GameFront Joystick">   &copy; 2021. "GameFront®" is a registered trademark of GameFront Ltd. &mdash; v2.3.1 (gf-web-01). <span class="pull-right footer__terms"><a href="https://www.gamefront.com/page/privacy-policy">Privacy Policy</a> | <a href="https://www.gamefront.com/page/terms-of-service">Terms of Service</a> | <a class="nn-cmp-show" href="#">Manage Cookie Settings</a></span>
        </p>
    </div>
</footer>


    <!-- Scripts -->
        <script src="https://static.gamefront.com/js/vendor-gamefront-v1.js?v=210826&hash=2021-v9"></script>
    <script src="https://static.gamefront.com/js/app.js?v=210826&hash=2021-v9"></script>
    
                        <script type="text/javascript" src="//platform-api.sharethis.com/js/sharethis.js#property=59fa4355ba4dac00122acaa8&product=inline-share-buttons"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/Caret.js/0.3.1/jquery.caret.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/at.js/1.5.4/js/jquery.atwho.min.js"></script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script>
    $('.box__content iframe').each(function() {
        $(this).height($(this).contents().outerHeight());
    });
</script>
    <script>
        function adsBlocked(callback){
            var testURL = 'https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'

            var myInit = {
                method: 'HEAD',
                mode: 'no-cors'
            };

            var myRequest = new Request(testURL, myInit);

            fetch(myRequest).then(function(response) {
                return response;
            }).then(function(response) {
                console.log(response);
                callback(false)
            }).catch(function(e){
                console.log(e)
                callback(true)
            });
        }
        $(document).ready(function() {
            adsBlocked(function(blocked){
                if(blocked){
                    $('#nn_lb1').css('padding', 0);
                    $('#patreon-banner').show();
                }
            })
        })
    </script>
    <script src="https://www.gamefront.com/js/jquery.matchHeight-min.js" charset="utf-8"></script>    
            <div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
        <div id="nn_1by1"></div>
    </div>
    <script type="text/javascript">(function(){window['__CF$cv$params']={r:'684e73422af85dd9',m:'9a450a50d80422955aaba13bed5aaec9e89885a6-1629995484-1800-AVsLDL2i+NXDvWZ/BMXSOOWm+tkGVgS7fbrJKM0zFmoy8C6XOhdtQga0/M9nF9oiHfN0/APZ156khTodUSYr6f2xpmldPgD0oybxhfqJ6zeGAtyuI09+oS8ru61GONlNJ7n/PLd3FJ8pJMcYiN5VWTstnDMzKZ3mtGithfY9FZqetKcIuIj/Jj7L2jdBA2SR0gGIBYN4bkdH8h1cuiWqBl0=',s:[0x18f8f252ec,0x5a11b27b6a],}})();</script></body>
</html>
